×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Regular Contributor
    Join Date
    Sep 2008
    Posts
    81

    GCCE build target doesn't compile

    Hello, I've just downloaded carbide v2 and SDK 3rd edition FP2 and i wanted to skim through the template examples given with the IDE so i created an EXE project and it worked just fine for WINSCW but when i tried to build it for GCCE there was some lines marked with red on the console output that says
    "Sorry, \epoc32\gcc\bin\as.exe is not supported in this release. please use a different device""
    What release did it mean?
    That was for GCCE udeb and urel and för armv5 there was another message
    "Platform ARMv5 not supported by "\Symbian\Carbide\workspace\Console\group\BLD.inf"
    How can i provide support for ARMv5 in the BLD.inf (PRJ_PALTFORM DEFAUT is currently in the file)

    And could somebody tell me the difference between build for ARM5 and GCCE . Does it have anything to do with the difference between GCC and RVCT?

    I'm running windows vista ultimate and i did what the SDK told me to do in the vistaplugin folde.

  2. #2
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Re: GCCE build target doesn't compile

    Hi,

    For Armv5 you can mention following in bld.inf

    PRJ_PLATFORMS
    WINSCW ARMV5 GCCE

    As you can see we have mentioned 3 platforms above winscw, armv5, gcce.

    Try replacing default with the stuff given above. It should resolve the problem

    Regards
    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  3. #3
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: GCCE build target doesn't compile

    The ARMV5 configuration requires the commercial RVCT compiler. If you have it then ensure that PRJ_PLATFORMS section of bld.inf is properly configured. N.B. the DEFAULT keyword includes ARMV5 so if you have that one it's also OK, no correction needed.

    As for the "\epoc32\gcc\bin\as.exe" problem there are plenty of discussions on this board about it. See http://www.google.com/search?hl=en&q...\bin\as.exe%22

    From what I can see the problem might come from wrong %PATH% settings and the problem is frequently mentioned with Windows Vista installs. See this old thread as a starter: http://discussion.forum.nokia.com/fo...d.php?t=107308
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. How to make build for GCCE
    By deepakk in forum Symbian
    Replies: 6
    Last Post: 2008-12-15, 05:37
  2. Problem with GCCE build in Carbide.vs
    By raffaelbechara in forum Symbian
    Replies: 6
    Last Post: 2008-10-20, 16:06
  3. Problem in resolving Build error prj0019
    By psandhu in forum Symbian
    Replies: 2
    Last Post: 2008-10-07, 14:30
  4. Much bigger raccoon_.sis
    By MikaelWT in forum Mobile Web Server
    Replies: 8
    Last Post: 2007-08-29, 15:43
  5. [Pys60, 3rd Ed.] build problems
    By MHOOO in forum Symbian
    Replies: 3
    Last Post: 2007-04-09, 19:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×