×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Jan 2009
    Posts
    7

    Exclamation STL support for qt for s60

    Is STL supported in 4.4.4-temple? During building platform I am getting warnings about not found headers <string> <iterator> <map> etc.

    WARNING: Can't find following headers in System Include Path
    <string> <iterator> <list> <iterator> <vector> <map>
    (Sys Inc Paths "\Qt\4.4.4-temple\mkspecs\symbian-abld\" "\Qt\4.4.4
    s\symbian-abld\tmp\" "\Qt\4.4.4-temple\include\QtCore\" "\Qt\4.4.4
    e\QtCore\tmp\" "\Qt\4.4.4-temple\include\" "\Qt\4.4.4-temple\inclu
    \devices\S60_5th_Edition_SDK_v0.9\epoc32\include\" "\S60\devices\S
    _SDK_v0.9\epoc32\include\stdapis\" "\S60\devices\S60_5th_Edition_S
    \include\stdapis\sys\" "\Qt\4.4.4-temple\include\QtGui\" "\Qt\4.4.
    de\QtGui\tmp\" "\Qt\4.4.4-temple\src\gui\tmp\rcc\debug_shared\" "\
    e\src\gui\tmp\rcc\debug_shared\tmp\" "\Qt\4.4.4-temple\src\3rdpart
    t\4.4.4-temple\src\3rdparty\libpng\tmp\" "\Qt\4.4.4-temple\src\3rd
    \Qt\4.4.4-temple\src\3rdparty\zlib\tmp\" "\Qt\4.4.4-temple\src\3rd
    \src\" "\Qt\4.4.4-temple\src\3rdparty\harfbuzz\src\tmp\" "\Qt\4.4.
    ui\dialogs\" "\Qt\4.4.4-temple\src\gui\dialogs\tmp\" "\Qt\4.4.4-te
    mp\moc\debug_shared\" "\Qt\4.4.4-temple\src\gui\tmp\moc\debug_shar
    4.4.4-temple\src\gui\" "\Qt\4.4.4-temple\src\gui\tmp\" "\Qt\4.4.4-
    \kernel\" "\Qt\4.4.4-temple\src\gui\kernel\tmp\" "\Qt\4.4.4-temple
    \" "\Qt\4.4.4-temple\src\gui\image\tmp\" "\Qt\4.4.4-temple\src\gui
    Qt\4.4.4-temple\src\gui\painting\tmp\" "\Qt\4.4.4-temple\src\gui\t
    .4-temple\src\gui\text\tmp\" "\Qt\4.4.4-temple\src\gui\styles\" "\
    e\src\gui\styles\tmp\" "\Qt\4.4.4-temple\src\gui\widgets\" "\Qt\4.
    \gui\widgets\tmp\" "\Qt\4.4.4-temple\src\gui\accessible\" "\Qt\4.4
    gui\accessible\tmp\" "\Qt\4.4.4-temple\src\gui\itemviews\" "\Qt\4.
    \gui\itemviews\tmp\" "\Qt\4.4.4-temple\src\gui\inputmethod\" "\Qt\
    rc\gui\inputmethod\tmp\" "\Qt\4.4.4-temple\src\gui\graphicsview\"


    Does anybody have solution to this problem?

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: STL support for qt for s60

    Hi,

    In the current release at least (I thought), Qt for S60 is being built without STL support (there are some NO_STL defines or similar in the code that are used to switch this feature on and off). You can still use the STL by simply including the relevant header paths:
    /epoc32/include/stdapis/sys
    /epoc32/include/stdapis/stlport
    However, any functions for converting between STL types and Qt types will probably not be available in the libraries (that's what I mean by building without STL support).

    I don't know if they're planning to change this in the future releases, but it would make sense.

    If you don't have those include paths, then you don't have Open C++ installed - only Open C is included in 3rd FP2, not Open C++.

    Mark

  3. #3
    Registered User
    Join Date
    Jan 2009
    Posts
    7

    Re: STL support for qt for s60

    This messages occured when I set the -stl switch during configuration of Qt. My platform is 5.0.9

  4. #4
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: STL support for qt for s60

    Hi,

    I think you can assume that configuration isn't supported at the moment. If you really want to try it, you'd probably have to hack qmake so that it adds the necessary system include paths (mentioned above) and libstdcpp.lib to the MMP files for Qt projects.

    Mark

  5. #5
    Registered User
    Join Date
    Mar 2003
    Posts
    31

    Re: STL support for qt for s60

    Configure in Temple release does not support -stl option. The upcoming release will support -stl option, meanwhile you can use STL as suggested by Mark in earlier post.

  6. #6
    Registered User
    Join Date
    Dec 2008
    Posts
    5

    Re: STL support for qt for s60

    Which file and how to set NO_STL or -stl option, thanks very much.

Similar Threads

  1. Mussing information on printing support on Eseries devices.
    By svdwal in forum Feedback - Nokia Developer Services & Infrastructure
    Replies: 3
    Last Post: 2008-05-16, 09:19
  2. Technical Support Engineer, Mobile, London
    By mobile2004 in forum Symbian C++
    Replies: 0
    Last Post: 2004-11-05, 09:38
  3. Technical Support Engineer, Mobile, London
    By mobile2004 in forum Symbian C++
    Replies: 0
    Last Post: 2004-11-05, 09:33
  4. Replies: 0
    Last Post: 2004-08-25, 11:42
  5. Nokia WAP stack support questions.
    By lamwt in forum Mobile Web Site Development
    Replies: 1
    Last Post: 2003-02-10, 08:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •