×

Discussion Board

Results 1 to 2 of 2

Hybrid View

  1. #1
    Regular Contributor
    Join Date
    Apr 2005
    Location
    England
    Posts
    91

    Question CEikRichTextEditor will not allow text input mode

    Hi,

    I am trying to get a CEikRichTextEditor to input characters - currently it will only input numbers.

    I actually have a working CEikRichTextEditor which allows character and numeric input in a basic application (where the AppUi owns the CCoeControl). However when I put the editor into a view based application, it will not allow character input.

    I've overridden InputCapabilities() as some posts suggests, but this is not getting called in the Control. I have also implemented this in the AppUI - this is getting called, but still no character input.

    I've tried constructing from resource where i've set the following flags
    Code:
    RESOURCE RTXTED r_richtext_editor
    	{
    	width = 176;
    	height = 180;
    	textlimit = 2000;
    	avkon_flags = EAknEditorFlagDefault;
    	default_case = EAknEditorLowerCase;
    	allowed_case_modes = EAknEditorUpperCase | EAknEditorLowerCase;
    	numeric_keymap = EAknEditorPlainNumberModeKeymap;
    	allowed_input_modes = EAknEditorTextInputMode | EAknEditorNumericInputMode;
    	default_input_mode = EAknEditorTextInputMode;
    	special_character_table = R_AVKON_SPECIAL_CHARACTER_TABLE_DIALOG;
    	}
    and also constructed from code, setting the input mode flags
    Code:
    	SetInputCapabilitiesL(TCoeInputCapabilities::EAllText);
    	SetAknEditorAllowedInputModes(EAknEditorAllInputModes);
    	SetAknEditorInputMode(EAknEditorTextInputMode); 
    	SetAknEditorCase(EAknEditorLowerCase);
    I've tried unfocusing and refocusing the editor. The control is on the control stack and is recieving key events, but it will only display numeric values.

    This is odd as I have a working version in a non-view based app. I also have the example RichTextEditor working, which comes with the sdk. But as soon as I add this code to a view based app, it no-longer accepts character input.

    Have I missed something? Is the view blocking the framework call to InputCapabilities()?

    Thanks,
    Helen

    P.S. I'm using 3rd Ed FP2 and problem occurs on both emulator and device.

  2. #2
    Regular Contributor
    Join Date
    Apr 2005
    Location
    England
    Posts
    91

    Re: CEikRichTextEditor will not allow text input mode

    Well I now know that it is not a problem with the view.

    I created a brand new single view based app and copied the editor container across. This editor can enter characters.

    However, I then copied the entire view and container files, across to another (large) view based project, and tested the editor again, in the scope of the new application. The editor will not display any characters. So I can eliminate a problem with the view and the editor code itself - something else in the application must be blocking it.

    Can you think of anything in the resources or capabilities of a project that may block the text input mode?

    Is there anything else that I may be overlooking?

    Thanks,
    Helen

Similar Threads

  1. Idle Mode Text on Nokia 6680
    By nitinkhobragade in forum General Development Questions
    Replies: 1
    Last Post: 2006-07-10, 18:52
  2. search field to text mode
    By sigh in forum Symbian
    Replies: 1
    Last Post: 2006-05-29, 09:43
  3. Default input mode "abc"
    By diplm in forum Mobile Java General
    Replies: 3
    Last Post: 2004-06-17, 22:04

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×