×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Aug 2008
    Posts
    13

    Jsession ID in widset url http request - Help !!

    hi,

    I am developing a widset that its server side is a tomcat.
    I am performing http requests to the server from the widset and needs the server to maintain the session per user.
    So I am using the jsessionid mechanism, sending it from the server to the widset client, and now on put it on the url so the server will bind the request to the correct session.
    BUT, I found that if I am trying to concatenate the jsession id to the url the request arrives to my server after some encoding, and the server claims that he cant find the page (404)

    client code before http requests:
    url = url + ";jsessionid=" + m_sessionId;

    this is what I get in the server logs:
    83.145.230.101 - - [26/Feb/2009:16:18:01 +0200] "GET /context/ccc%3Bjsessionid%3D259B71F64DEC9523F60A74EB8CABB9CF?la=en&updates=1&ar=1 HTTP/1.1" 404 - "-" "Jakarta Commons-HttpClient/3.0.1"

    as you can see this is what I got on server:
    /context/ccc%3Bjsessionid%3D259B71F64DEC9523F60A74EB8CABB9CF

    and this is what I sent from client:
    /context/ccc;jsessionid=259B71F64DEC9523F60A74EB8CABB9CF

    is there a correct way doing it from widsets api?

    thanks,
    Junam.

  2. #2
    Registered User
    Join Date
    Dec 2008
    Posts
    13

    Re: Jsession ID in widset url http request - Help !!

    Try POST method

  3. #3
    Registered User
    Join Date
    Aug 2008
    Posts
    13

    Re: Jsession ID in widset url http request - Help !!

    Jamapag,

    Post method indeed solves this problem, great

    Thanks a lot.

    Junam.

Similar Threads

  1. How to set proxy in an HTTP request
    By gigglie in forum Symbian C++
    Replies: 1
    Last Post: 2008-05-23, 10:26
  2. [ help ] how to add cookie in http request header
    By cysnew in forum Symbian C++
    Replies: 6
    Last Post: 2008-05-15, 07:55
  3. http request error -33
    By vimal r jain in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-03-06, 07:59
  4. problem sending an http request with # in it.
    By jaazz in forum Mobile Java Networking & Messaging & Security
    Replies: 4
    Last Post: 2006-12-06, 10:58
  5. How can i solve this error?
    By symbian-newbie in forum Symbian C++
    Replies: 6
    Last Post: 2006-05-23, 05:33

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •