Hi,

I unzipped the Garden release package of s60 in c:\Qt\4.5.0-garden and tried configuring it. I got the
following error....

C:\Qt\4.5.0-garden>configure -platform win32-mwc -xplatform symbian-abld -qconfi
g

This is the Qt for S60 Preview Edition.

You are licensed to use this software under the terms of
the TECHNOLOGY PREVIEW LICENSE AGREEMENT.

Type '?' to view the TECHNOLOGY PREVIEW LICENSE AGREEMENT.
Type 'y' to accept this license offer.
Type 'n' to decline this license offer.

Do you accept the terms of the license?
y
Environment:
INCLUDE=
Unset
LIB=
Unset
PATH=
C:\Program Files\ARM\bin\win_32-pentium
C:\Program Files\ARM\RVD\Core\1.8\734\win_32-pentium\bin
C:\Program Files\Nokia\Carbide.c++ v2.0\x86Build\Symbian_Tools\Command_Lin
e_Tools
C:\Perl\bin\
C:\Program Files\CA\SC\CAWIN\
C:\WINDOWS\system32
C:\WINDOWS
C:\WINDOWS\System32\Wbem
C:\Program Files\Java\jdk1.6.0_04\bin
C:\Program Files\Common Files\Adobe\AGL
C:\PROGRA~1\CA\SC\CAM\bin
C:\Program Files\CA\DSM\bin
C:\Program Files\Common Files\Symbian\tools
C:\Program Files\CSL Arm Toolchain\bin
C:\Program Files\ARM\Utilities\FLEXlm\9.2\release\win_32-pentium
C:\Program Files\ARM\RVCT\Programs\2.2\349\win_32-pentium
C:\Qt\4.5.0-garden\bin

Licensee....................
License ID..................
Product license.............Preview Edition
Expiry Date.................

Configuration:
minimal-config
small-config
medium-config
large-config
full-config
build_all
debug
cross_compile
Qt Configuration:
release
debug
zlib
png
ipv6
svg
minimal-config
small-config
medium-config
large-config
full-config

QMAKESPEC...................symbian-abld (commandline)
Architecture................symbian
Maketool....................make
Debug symbols...............yes
Accessibility support.......no
STL support.................no
Exception support...........no
RTTI support................no
MMX support.................no
3DNOW support...............no
SSE support.................no
SSE2 support................no
IWMMXT support..............no
OpenGL support..............no
Direct3D support............no
OpenSSL support.............no
QtDBus support..............no
QtXmlPatterns support.......no
Phonon support..............no
WebKit support..............no
QtScriptTools support.......no
Graphics System.............raster
Qt3 compatibility...........no

Third Party Libraries:
ZLIB support............qt
GIF support.............plugin
TIFF support............plugin
JPEG support............plugin
PNG support.............qt
MNG support.............plugin
FreeType support........no

Styles:
Windows.................yes
Windows XP..............no
Windows Vista...........no
Plastique...............no
Cleanlooks..............no
Motif...................no
CDE.....................no
Windows CE..............no
Windows Mobile..........no
S60.....................yes

Sql Drivers:
ODBC....................no
MySQL...................no
OCI.....................no
PostgreSQL..............no
TDS.....................no
DB2.....................no
SQLite..................plugin (qt)
SQLite2.................no
InterBase...............no

Sources are in..............C:\Qt\4.5.0-garden
Build is done in............C:\Qt\4.5.0-garden
Install prefix..............
Headers installed to........
Libraries installed to......
Plugins installed to........\resource\qt\plugins
Binaries installed to.......
Docs installed to...........
Data installed to...........
Translations installed to...
Examples installed to.......
Demos installed to..........

Running syncqt...
Creating qmake...
make: Makefile: line 7: Error -- Expecting macro or rule defn, found neither
make: Makefile: line 7: Error -- Expecting macro or rule defn, found neither
Cleaning qmake failed, return code 255


I followed all the installation procedure

Set the path to C:\Qt\4.5.0-garden\bin
Ran the configure environment for winscw command line in carbide.c++
Unpacked the release in the root directory of SDK
Executed qts60binaries.


Can anyone pls. help me in resolving the issue?

Thanks,
Sri