×

Discussion Board

Results 1 to 2 of 2
  1. #1
    Regular Contributor
    Join Date
    Feb 2009
    Posts
    181

    [moved] S60 5th Edition compatibility query

    I am working on application development using the S60 5th edition. I would like to know if it works only with Nokia 5800 or does it work with earlier Nokia phones too.(For example N72 , etc). I tried to port an executable file to a N72 and run it but it did not run . If it works with earlier Nokia phones too , then what can be the problem ?? How do I run an app on an actual device or do I need a Nokia 5800

    Plz help

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: S60 5th Edition compatibility query

    Quote Originally Posted by nisheethpandey View Post
    I am working on application development using the S60 5th edition. I would like to know if it works only with Nokia 5800 or does it work with earlier Nokia phones too.(For example N72 , etc). I tried to port an executable file to a N72 and run it but it did not run . If it works with earlier Nokia phones too , then what can be the problem ?? How do I run an app on an actual device or do I need a Nokia 5800

    Plz help
    You will have to learn about the backwards compatibility promise of the S60 Platform and about the binary break that occurred at the introduction of S60 3rd Edition. There is plenty of documentation of this site, including porting guide from S60 2nd Edition to S60 3rd Edition.

    Here is a starting point: How do I start programming for Symbian OS? (it includes link to Which S60 SDK should I use?)
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. S60 5th edition applications in 3rd edition phones
    By radhamanogar in forum Symbian
    Replies: 4
    Last Post: 2012-08-08, 06:47
  2. keywords: netbeans 6.5 debug S60 5th Edition Connection refused.
    By bobyhands in forum Mobile Java Tools & SDKs
    Replies: 11
    Last Post: 2009-11-25, 13:47
  3. Python for S60 1.9.3 released
    By tvijayan in forum Symbian
    Replies: 40
    Last Post: 2009-04-03, 15:00
  4. [moved] S60 SDK5th edition and gradient bitmaps cause Panic BITGDI 13.
    By palringosymbian in forum Symbian User Interface
    Replies: 7
    Last Post: 2009-02-12, 13:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×