×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Jan 2009
    Posts
    25

    Smile On device debugging problem, carbide 2.0 and TRK 3.0.9

    Hi,

    I am facing problem in enabling on device debugging with carbide 2.0 and TRK 3.0.9.
    TRK shows it is connected to the serial port via USB (it is the same port which nokia pc suite uses, I am closing nokia pc suite before starting debugging) but when I am trying to debug the application in phone debug mode it gives this error.
    “Target request failed: TRKProtocolPlugin : Unable to open communications port (Port may be used by another application or selected port may not be available.).”

    If I check the connection by going in Help->on-device connections and press “Initiate service testing” it gives this error.
    “Error: TCFError: Connection type is supported, but there was an error in connecting. OSError: Could not open the device”

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    I'm not sure what "the same port which nokia pc suite uses" means as I've never seen any port details in PC Suite (I wasn't really looking though). On thing is for sure, I never disconnect PC Suite when using ODD.

    Windows displays device's name next to the port name (you can see it in Windows' Device Manager) and Carbide.c++ displays the same string. Make sure that you select the port that has the name of your device, even if it appears to be a big COM number (e.g COM22 - Nokia N95). In fact, be suspicious if the port you are tempted to use is "low", like COM3 or COM5.

    See today's useful link from my signature, could be .. useful indeed.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Jan 2009
    Posts
    25

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    Thanks for the reply

    I am doing as you said in your reply but on-device debugging not working.
    This is the error.
    “Error: TCFError: Connection type is supported, but there was an error in connecting. OSError: Could not open the device”.

  4. #4
    Registered User
    Join Date
    Jun 2005
    Posts
    48

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    This is common problem. Try to restart the AppTRK, or reboot your pc if it doesn't help. This problem occurs if you unplug the USB cable in wrong time

  5. #5
    Registered User
    Join Date
    Mar 2003
    Location
    51°11'4.78"N -|- 2°48'27.05"E (Belgium)
    Posts
    730

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    Hi,

    have you solved this, I have the same problem !! have tried all ...

    Thanks,
    Domi.
    ----------------------------------------------------------------------------------
    FExplorer is my baby !

    you can get the FREE version from www.gosymbian.com
    you can get the PRO version from http://store.ovi.com/content/339454

  6. #6
    Registered User
    Join Date
    Apr 2009
    Posts
    1

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    I had similar problem. After removing battery from phone (probably too desperate and obsolete step) and turning power off (not simply shut down OS as my mainboard still remains under voltage) I reconnected with PC Suite and using Carbide was able to find NokiaUSB port connect to TRK.

  7. #7
    Registered User
    Join Date
    Mar 2003
    Location
    51°11'4.78"N -|- 2°48'27.05"E (Belgium)
    Posts
    730

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    epz, I have solved the problem with restarting the phone (+/- like you)

    Domi.
    ----------------------------------------------------------------------------------
    FExplorer is my baby !

    you can get the FREE version from www.gosymbian.com
    you can get the PRO version from http://store.ovi.com/content/339454

  8. #8
    Registered User
    Join Date
    Apr 2009
    Posts
    13

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    Go to control panel and click on phone and modem settings. Give the appropriate dialing rules and then click on "modems" tab. Now you can see your device and the port it is connected. Install TRK on device and give the same port manually and connect.Now in carbibe go to debug configuration add a new connection and select the port number to which your device is connected and Test the connection.

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,750

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    Remember that even the latest problem discussed in this thread was solved 2 weeks ago already, at it was a stability issue, not related to the configuration. Actually Carbide lists the available serial ports with full names, so you should always see which one to use "COMx - Nokia y USB".

  10. #10
    Regular Contributor
    Join Date
    Jul 2008
    Posts
    416

    Re: On device debugging problem, carbide 2.0 and TRK 3.0.9

    If I'm experiencing problems with Trk, I'm trying to resolve issues along this line:

    1) First check the pkg file if there are any dependencies among exe's, if one process starts another (i.e. gui client and service). Simplify these dependencies as much as possible. For the debug purposes I remove also any interaction (optional questions) during the installation process with the user.

    2) Check in the debug options if the serial port is connected with your device (Debug Configurations -> Symbian OS Application TRK -> Main Tab -> Use Connection -> Edit -> USB -> Next). There should be displayed several ports with a named port among them called i.e. COM8 - Nokia N95 USB.

    3) Check if the TRK application is running on your device. Choose the TRK version using the dialog in the debug settings. The dialog is the same as the one where the ports are displayed but the tab is called Install remote agents.

    4) Reconnect your device with the PC.

    5) Reinstall the PC Suite. Check the item "Ports (COM & LPT)" in the device manager. There should be the same port as in the debug options displayed: COM8 - Nokia N95 USB.

    6) Install the sisx first to check if the installation process is correct. There can be another application on the device using the same UID as the application you want to debug.

Similar Threads

  1. [moved] Carbide 2.0.0, TRK 3.0.9 - debugging problems
    By nadafu in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 14
    Last Post: 2009-10-15, 16:19
  2. Carbide 2.0 TRK 3.0.9
    By kamal_bhavita in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2009-03-25, 16:50
  3. TRK 3 on device debugging and Carbide 2.0
    By ilancopelyn in forum Tools and SDK Feedback (Closed)
    Replies: 2
    Last Post: 2009-03-11, 06:47
  4. [moved] Problem Trk 3.0.9 in n80 with carbide 2
    By elsuicidas in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2009-02-10, 15:02
  5. TRK 3.0.8 not working in Carbide 2.0
    By ilancopelyn in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2008-12-08, 23:26

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×