×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    10

    S60 5th Edition: Unable to load PhoneClientExt.dll

    I want to load the PhoneClientExt.dll in my project.

    My application worked fine in 3rd edition devices, but when the same software is installed on S60 5th Edition, the below statement fails to load PhoneClientExt.dll.

    "(RLibrary)iLibrary.Load(KPhoneCltExDllName)"

    Can anybody reply me as to how can I load/use the PhoneClientExt.dll in s60 5th edition phones. OR if you have any alternative to this in 5th edition, please guide me further.

    Thank you in advance.


    Regards,
    Purna

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    yes, you can't load it as it has been removed.

  3. #3
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    If I remember right, that was removed already in 3rd ed FP2.

  4. #4
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    You need to tell us what functionality you require for that phone client was providing.
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  5. #5
    Registered User
    Join Date
    Mar 2009
    Posts
    10

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    Thanks for you inputs.

    I would like to provide Voice(GSM) call as well as VoIP call functionality, as it is already implemented for 3rd Edition (MR) version).

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    user's of Plugin SDK's are warned that API might be removed/changed in future realses. so you might try opening a support case. Also you might want to refer to "Call Audio Control API"

  7. #7
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    The application interworking API's (AIW) can be used as a replacement
    At least that is what we have replaced our code with

    http://wiki.forum.nokia.com/index.ph...rking%28AIW%29
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

  8. #8
    Registered User
    Join Date
    Mar 2009
    Posts
    10

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    If "application interworking API's (AIW)" is used to develop the telephony functionality in 5th edition then will the application work on previous versions(backward compatibility with 3rd edition)??

    Could someone please send me a sample application how to originate a GSM call, send DTMF digits and terminate a call on S60 5th edition SDK?

    Thanks in advance!!

  9. #9
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    As with other PlugIn SDK apis binary compatibility is not Promised so you have to test before you release.

  10. #10
    Super Contributor
    Join Date
    Nov 2004
    Location
    Wiltshire, UK
    Posts
    3,644

    Re: S60 5th Edition: Unable to load PhoneClientExt.dll

    If you want the code to work across all 3rd and 5th edition versions then you will need to use CTelephony with an active object to dial the call, send dtmf and then drop the call.

    The AIW API works from FP2 onwards and also supports VOIP. There are samples on the wiki to show how to use it.

    Though it is beyond me why we need 4 API's to make a phone call.
    Download Symbian OS now! [url]http://developer.symbian.org[/url]

Similar Threads

  1. S60 5th edition applications in 3rd edition phones
    By radhamanogar in forum Symbian
    Replies: 4
    Last Post: 2012-08-08, 06:47
  2. keywords: netbeans 6.5 debug S60 5th Edition Connection refused.
    By bobyhands in forum Mobile Java Tools & SDKs
    Replies: 11
    Last Post: 2009-11-25, 13:47
  3. Replies: 35
    Last Post: 2009-04-11, 14:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •