×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Jul 2006
    Location
    Wieliczka, Poland
    Posts
    64

    Question Low performace of Sound Mixer on some devices

    Hi

    I recompiled S60 Platform: Sound Mixer Example v2.1 with only one red box flaying on screen (changed only for statements in DoTimer function) and with turned off background music.
    When I run this on various devices I observed some performance problems:
    on N82, N95 everything works fine without delays
    on E66 there is delay between moment when red box hit edge of the window and sound is played
    on 5500 there is longer delay than on E66.
    I also created my own sound mixer using CMdaAudioOutputStream Symbian IPC, and in one thread. Performance is better than this one from example but on both E66 and 5500 there is still delay between moment of calling play of sound sample and speaker sound generation. I think this is because on 5500 and E66 sound subsystem has lower hardware performance than on N82, N95. Is there other way of playing mixed sound on Symbian phones than CMdaAudioOutputStream?

  2. #2
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: Low performace of Sound Mixer on some devices

    Yes, others have noted the audio latency on the first generation single chip phones. There is not a lot you can do about it.

    There is a lower-level audio interface in the SDK API plug-in - CMMFDevSound. By using that I think you can remove some, but not all, of the latency, but it is a lot of work (coding) for little return. Possibly it's better just not to support the phones in question?

    Mark

  3. #3
    Registered User
    Join Date
    Apr 2003
    Location
    Finland, Espoo
    Posts
    37

    Re: Low performace of Sound Mixer on some devices

    Quote Originally Posted by Sorcery-ltd View Post
    Yes, others have noted the audio latency on the first generation single chip phones. There is not a lot you can do about it.

    There is a lower-level audio interface in the SDK API plug-in - CMMFDevSound. By using that I think you can remove some, but not all, of the latency, but it is a lot of work (coding) for little return. Possibly it's better just not to support the phones in question?

    Mark
    has anybody noticed this with 5800 or N97? I'm trying to get sound to play in response to user action, but delay is way over 1/10th of a second, which pretty much dissolves the association with action.

Similar Threads

  1. common sound format across all series 60 devices
    By dotcdotc in forum Mobile Java Media (Graphics & Sounds)
    Replies: 0
    Last Post: 2004-11-26, 09:03
  2. MIDI Sound problem (J2ME / Series 60)
    By JPapke in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2004-10-29, 08:17
  3. Sound and Devices
    By marcgom in forum Mobile Java Media (Graphics & Sounds)
    Replies: 3
    Last Post: 2003-04-22, 09:53
  4. Sound and low level info
    By RobyOne in forum Symbian
    Replies: 2
    Last Post: 2002-06-28, 20:17

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×