×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Nokia Developer Expert
    Join Date
    Apr 2007
    Posts
    131

    Python runtime SIS without PIPS SIS for 5800 XM

    Hi All,

    A new Python runtime SIS is uploaded on maemo garage. This SIS does not have any OpenC PIPS SIS embedded in it. This file is released so that users can install PyS60 1.9.3 runtime on devices (mainly 5800 XM) that have problems ("Component is built-in") in installing PIPS SIS, previously embedded in the runtime SIS.

    This will work with PIPS 1.4 libraries, but socket module and fixes to few bugs that depend on PIPS 1.5Beta libraries will not be available. The issue with PIPS 1.5Beta installation doesn't seem to be on all devices and OpenC team is investigating the cause for the same. We shall keep you updated on this.

    Thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,777

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Great! Now no longer hard reset needed!

    Thanx,

    //Croozeus
    Pankaj Nathani
    www.croozeus.com

  3. #3
    Regular Contributor
    Join Date
    Mar 2003
    Posts
    144

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Will there also be new packages for the emulator? Neither the 3rd Edition package nor the 3rd Edition FP1 work. Maybe due to references to PIPS 1.5 beta, which does not exist for the emulator? 1.9.2 worked fine on Emulator.

    Regards
    Max

  4. #4
    Registered User
    Join Date
    Sep 2004
    Posts
    2

    Unhappy Re: Python runtime SIS without PIPS SIS for 5800 XM

    hi,when i install Python runtime SIS 1.9.3 for 3rd ED FP2,my phone N78 also has the same problems(Components is built in)in installing PIPS SIS, previously embedded in the runtime SIS.

    please check the problem in my N78 that is buyed yesterday.my language set code is 015,software version is 12.046.

  5. #5
    Nokia Developer Expert
    Join Date
    Apr 2007
    Posts
    131

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Quote Originally Posted by lkz633 View Post
    Will there also be new packages for the emulator? Neither the 3rd Edition package nor the 3rd Edition FP1 work. Maybe due to references to PIPS 1.5 beta, which does not exist for the emulator? 1.9.2 worked fine on Emulator.

    Regards
    Max

    OpenC 1.5 beta is planned to be released soon and the OpenC packages for emulator will be part of this release.

  6. #6
    Nokia Developer Expert
    Join Date
    Apr 2007
    Posts
    131

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Quote Originally Posted by pandaxiaoxi View Post
    hi,when i install Python runtime SIS 1.9.3 for 3rd ED FP2,my phone N78 also has the same problems(Components is built in)in installing PIPS SIS, previously embedded in the runtime SIS.

    please check the problem in my N78 that is buyed yesterday.my language set code is 015,software version is 12.046.
    If i understand the problem correctly, you tried to install Python runtime SIS 1.9.3 sis on a brand new N78 and you got "Component built in" error? Before trying to install this, did you install 1.4 OpenC SIS on this phone ? or did you do a firmware update ?
    Last edited by mahesh.sayibabu; 2009-04-13 at 03:55.

  7. #7
    Registered User
    Join Date
    Sep 2004
    Posts
    2

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Quote Originally Posted by mahesh.sayibabu View Post
    If i understand the problem correctly, you tried to install Python runtime SIS 1.9.3 sis on a brand new N78 and you got "Component built in" error? Before trying to install this, did you install 1.4 OpenC SIS on this phone ? or did you do a firmware update ?
    yes,you are right.
    but i don't install 1.4 OpenC SIS anywhere.i also don't do a firmware update.
    please tell me which version to have OpenC 1.4 inside.

  8. #8
    Registered User
    Join Date
    Apr 2009
    Posts
    6

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Hi,

    When I try to install Python runtime 1.9.3 in nokia 5800, it gives error message "Expired Certificate" and quits the installtion.

    I tried 1.9.0, 1.9.1 and 1.9.2 also but same problem.

    Pls help

    Siddique

  9. #9
    (Retired) Nokia Developer Admin.
    Join Date
    Jan 2006
    Location
    Michigan
    Posts
    4,664

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Quote Originally Posted by siddiquemerchant View Post
    Hi,

    When I try to install Python runtime 1.9.3 in nokia 5800, it gives error message "Expired Certificate" and quits the installtion.

    I tried 1.9.0, 1.9.1 and 1.9.2 also but same problem.

    Pls help

    Siddique
    the answer is in post 22 of this sticky thread

    http://discussion.forum.nokia.com/fo...d.php?t=163019

    Ron

  10. #10
    Registered User
    Join Date
    Apr 2009
    Posts
    6

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Dear Mr. Ron
    Thanks for the quick reply.
    I checked the given link. It discusses about problem "Component is built-in"
    but I am getting a different problem. while installing "python for S60 1.9.3" sis file, it gives message "Expired Certificate" which I could not find anywhere in the forum.

    I have software version 11.0.009 and laguage set 11 installed in my nokia 5800.
    I tried to update the firmware but it says no update is available. probably update is not available in our region (United Arab Emirates)

    is it firmware version problem or am I missing doing something wrong.

    I already installed Pips 1.4 and Pythonscriptshell and all the dependencies, but python run time is not installing.

    pls help
    Regards,

  11. #11
    Registered User
    Join Date
    Oct 2008
    Posts
    4

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Sorry for being slow, but what is the exact process I go through to install python on my new 5800? Should I update the firmware first? I use the pre-built .sis file and what else do I need? etc... I installed python 5 months ago on an e51, but it looks like things have changed a bit. At that time, I just needed to copy 2 .sis files to the correct location...

    Kind regards,

    Vince

  12. #12
    Registered User
    Join Date
    Oct 2008
    Posts
    4

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Hello All,

    I used bluetooth to transfer:

    First Python runtime SIS without PIPS for 5800XM (Installed Fine)
    Then PyScriptShell_v1.4.5.S60v5

    and I get UNABLE TO INSTALL CONSTRAINED BY CERTIFICATE

    Any Ideas?

  13. #13
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    114

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Quote Originally Posted by vcorning View Post
    Then PyScriptShell_v1.4.5.S60v5

    Any Ideas?
    You installed the wrong ScriptShell. You need to install the ScriptShell present in Maemo Garage which is v1.9.3
    import antigravity

  14. #14
    Nokia Developer Expert
    Join Date
    Apr 2007
    Posts
    131

    Re: Python runtime SIS without PIPS SIS for 5800 XM

    Quote Originally Posted by pandaxiaoxi View Post
    yes,you are right.
    but i don't install 1.4 OpenC SIS anywhere.i also don't do a firmware update.
    please tell me which version to have OpenC 1.4 inside.
    Looks like this is because of the same issue in PIPS sis that is causing installation problem on certain 5800 XM phones. We shall check this, and get back to you.

Similar Threads

  1. Please help installing Python libraries on S60
    By ericroijen in forum Python
    Replies: 11
    Last Post: 2009-07-18, 10:43
  2. Python for Series 60 released on Forum Nokia!
    By eriksmartt in forum Python
    Replies: 5
    Last Post: 2009-07-14, 17:00
  3. Replies: 0
    Last Post: 2008-02-14, 10:27
  4. SIS files need previous python instalation
    By b4blue in forum Python
    Replies: 3
    Last Post: 2006-04-19, 06:45
  5. Running multiple python sis files simultaneously
    By bercobeute in forum Python
    Replies: 5
    Last Post: 2005-10-31, 14:40

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •