×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jul 2008
    Posts
    2

    who can help me ,there are some errors when I install qt 4.5 for symbian S60

    Hi,

    I unzipped the Garden release package of s60 in c:\Qt\4.5.0-garden and tried configuring it. I got the
    following error....

    C:\Qt\4.5.0-garden>configure -platform win32-mwc -xplatform symbian-abld

    This is the Qt for S60 Preview Edition.

    You are licensed to use this software under the terms of
    the TECHNOLOGY PREVIEW LICENSE AGREEMENT.

    Type '?' to view the TECHNOLOGY PREVIEW LICENSE AGREEMENT.
    Type 'y' to accept this license offer.
    Type 'n' to decline this license offer.

    Do you accept the terms of the license?
    y
    Environment:
    INCLUDE=
    Unset
    LIB=
    Unset
    PATH=

    C:\Program Files\Nokia\Carbide.c++ v2.0\x86Build\Symbian_Tools\Command_Lin
    e_Tools

    C:\Qt\4.5.0-garden\bin

    Licensee....................
    License ID..................
    Product license.............Preview Edition
    Expiry Date.................

    Configuration:
    minimal-config
    small-config
    medium-config
    large-config
    full-config
    build_all
    debug
    cross_compile
    Qt Configuration:
    release
    debug
    zlib
    png
    ipv6
    svg
    minimal-config
    small-config
    medium-config
    large-config
    full-config

    QMAKESPEC...................symbian-abld (commandline)
    Architecture................symbian
    Maketool....................make
    Debug symbols...............yes
    Accessibility support.......no
    STL support.................no
    Exception support...........no
    RTTI support................no
    MMX support.................no
    3DNOW support...............no
    SSE support.................no
    SSE2 support................no
    IWMMXT support..............no
    OpenGL support..............no
    Direct3D support............no
    OpenSSL support.............no
    QtDBus support..............no
    QtXmlPatterns support.......no
    Phonon support..............no
    WebKit support..............no
    QtScriptTools support.......no
    Graphics System.............raster
    Qt3 compatibility...........no

    Third Party Libraries:
    ZLIB support............qt
    GIF support.............plugin
    TIFF support............plugin
    JPEG support............plugin
    PNG support.............qt
    MNG support.............plugin
    FreeType support........no

    Styles:
    Windows.................yes
    Windows XP..............no
    Windows Vista...........no
    Plastique...............no
    Cleanlooks..............no
    Motif...................no
    CDE.....................no
    Windows CE..............no
    Windows Mobile..........no
    S60.....................yes

    Sql Drivers:
    ODBC....................no
    MySQL...................no
    OCI.....................no
    PostgreSQL..............no
    TDS.....................no
    DB2.....................no
    SQLite..................plugin (qt)
    SQLite2.................no
    InterBase...............no

    Sources are in..............C:\Qt\4.5.0-garden
    Build is done in............C:\Qt\4.5.0-garden
    Install prefix..............
    Headers installed to........
    Libraries installed to......
    Plugins installed to........\resource\qt\plugins
    Binaries installed to.......
    Docs installed to...........
    Data installed to...........
    Translations installed to...
    Examples installed to.......
    Demos installed to..........

    Running syncqt...
    Creating qmake...
    execute: File or path is not found (make)
    execute: File or path is not found (make)
    Cleaning qmake failed, return code 1


    I followed all the installation procedure

    Set the path to C:\Qt\4.5.0-garden\bin
    Ran the configure environment for winscw command line in carbide.c++
    Unpacked the release in the root directory of SDK
    Executed qts60binaries.
    Last edited by ljp1205; 2009-04-02 at 07:27.

  2. #2
    Registered User
    Join Date
    Jul 2008
    Posts
    2

    Re: who can help me ,there are some errors when I install qt 4.5 for symbian S60

    i don't find make.exe ,qmake.exe and moc.exe in C:\Qt\4.5.0-garden\bin
    why?

  3. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: who can help me ,there are some errors when I install qt 4.5 for symbian S60

    Please double check the installation instructions. You need to make sure you've got Carbide.c++ and that you've configured it for command line builds - otherwise your path and some other environment variables will not be set correctly to build the tools (qmake, moc etc).

    Mark

  4. #4
    Registered User
    Join Date
    May 2008
    Posts
    28

    Re: who can help me ,there are some errors when I install qt 4.5 for symbian S60

    Follow the Mark's instructions.
    If you're still getting same error.
    Then,
    go to your Qt folder through command prompt and build it for armv5 urel

    command is:

    c:\qt-4.5.0-garden>bldmake bldfiles
    c:\qt-4.5.0-garden>abld build armv5 urel

    It takes more than an hour.

    Regards,
    Sachin

Similar Threads

  1. Python for S60 1.9.2 released
    By tvijayan in forum Python
    Replies: 26
    Last Post: 2009-03-11, 09:28
  2. Icons in s60
    By drizzt6 in forum Mobile Java General
    Replies: 5
    Last Post: 2009-03-06, 09:32
  3. Replies: 2
    Last Post: 2008-03-17, 12:56
  4. How to install a signed MIDlet into S60 SDK?
    By nn_tt in forum Mobile Java General
    Replies: 0
    Last Post: 2004-03-18, 07:18
  5. Replies: 1
    Last Post: 2002-10-06, 09:14

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •