×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    5

    Problems in obsfucation for a J2ME application from Eclipse

    Hi experts,
    When I try to create obfuscated package from eclipse, I get the following error.
    I had been trying to find a solution for this for the past two days.
    I am pasting the error which I got in eclipse below while trying to obfuscate with Proguard 4.3 from eclipse.

    Code:
    Errors during build.
    Errors running builder 'Preverification' on project 'ProjectAlarm'.
    E:\WApps\ProjectAlarm\deployed\ProjectAlarm_obf.jar (The system cannot find the file specified)
    E:\WApps\ProjectAlarm\deployed\ProjectAlarm_obf.jar (The system cannot find the file specified)
    Kindly help me to resolve this issue.

    Warm Regards,
    Anees

  2. #2
    Super Contributor
    Join Date
    Sep 2008
    Location
    Noida, U.P.
    Posts
    1,330

    Thumbs up Re: Problems in obsfucation for a J2ME application from Eclipse

    Please check out the address of root directory of progaurd.jar at Window->Preferences->J2ME-> Pacakaging ->Obfuscation. Is it ok. might be the root directory of progaurd.jar is not found by eclipse.

    Sorry not know much more about eclipse. Im using Netbeans 6.0 IDE.
    thanks,
    jitu_goldie..

    KEEP TRYING..

  3. #3
    Registered User
    Join Date
    Apr 2009
    Posts
    5

    Re: Problems in obsfucation for a J2ME application from Eclipse

    Hi jitu_goldie,

    I have given it correctly -- F:\proguard4.3\proguard4.3
    Please refer links http://docs.google.com/Doc?id=dfzrknk_64fd4b4rds and https://docs.google.com/Doc?docid=df...hf53w4dz&hl=en

  4. #4
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Problems in obsfucation for a J2ME application from Eclipse

    Is there some error before this? This is saying that the preverifier cannot find the output of the obfuscator, so something else must have failed before this (or you are not running the obfuscator).

    How are you building? Are you using ant?

    Cheers,
    Graham.

  5. #5
    Registered User
    Join Date
    Apr 2009
    Posts
    5

    Re: Problems in obsfucation for a J2ME application from Eclipse

    Hi,

    >>Is there some error before this?

    No.


    >>something else must have failed before this

    There were no messages shown.

    >>or you are not running the obfuscator

    I have configured it in eclipse. Please refer http://docs.google.com/Doc?id=dfzrknk_68fcqq9vfp

  6. #6
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Problems in obsfucation for a J2ME application from Eclipse

    Well, except for the long list of obfuscator problems...

    Certainly, it sounds like com.sun.lwuit is not in the class path when you are obfuscating.

    Cheers,
    Graham.

  7. #7
    Registered User
    Join Date
    Apr 2009
    Posts
    5

    Re: Problems in obsfucation for a J2ME application from Eclipse

    grahamhughes,
    I think, that can be the problem.
    But, I have given the path of lwuit jar in Java build path of project in Eclipse.
    Why does that warning come "cant find com.sun.lwuit.... "
    This really puzzles me!

    Please give a solution.

  8. #8
    Registered User
    Join Date
    Mar 2009
    Posts
    21

    Post Re: Problems in obsfucation for a J2ME application from Eclipse

    Hi there,
    I have imported lwuit jar in my project.
    Whenever I try to build project / create package in eclipse,I get following error:
    Errors during build.
    Errors running builder 'Preverification' on project 'HelloLWUIT'.
    org.eclipse.jdt.internal.core.JavaModel.getTarget(Lorg/eclipse/core/resources/IContainer;Lorg/eclipse/core/runtime/IPath;Z)Ljava/lang/Object;
    org.eclipse.jdt.internal.core.JavaModel.getTarget(Lorg/eclipse/core/resources/IContainer;Lorg/eclipse/core/runtime/IPath;Z)Ljava/lang/Object;

    Please suggest me solution for this problem...

    Thanks.

  9. #9
    Super Contributor
    Join Date
    Jun 2003
    Location
    Cheshire, UK
    Posts
    7,395

    Re: Problems in obsfucation for a J2ME application from Eclipse

    I don't use eclipseME, so I can't help you much.

    I recommend building with Ant, and using Antenna. This means you can build without your IDE, and you don't need to depend on obscure IDE settings.

Similar Threads

  1. Series 60 J2ME emulator problems
    By evertomi in forum Mobile Java Tools & SDKs
    Replies: 2
    Last Post: 2009-06-15, 10:21
  2. J2ME or C++ for VoIP on Mobile Phone
    By sandeepkumar03 in forum Mobile Java Media (Graphics & Sounds)
    Replies: 2
    Last Post: 2008-11-13, 20:14
  3. Replies: 0
    Last Post: 2006-06-08, 09:04
  4. Integrating Eclipse J2Me plugin with J2MEUnit.. Vs JBuilder
    By brianpegan in forum Mobile Java General
    Replies: 3
    Last Post: 2004-03-15, 17:57
  5. Replies: 1
    Last Post: 2003-10-17, 08:45

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×