×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    4

    Unable to run project

    When i am trying to execute any project its showing the following error

    Launching test Emulator Debug (WINSCW) [S60_3rd-FP2_SDK]
    Reason: C:\S60....\filename.exe not found



    In console it is showing as below:

    ***Building project "test" for configuration "Emulator Debug (WINSCW) [S60_3rd_FP2_SDK]"

    ***Printing environment variables modified from default:
    MWCSYM2INCLUDES=C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_Common\Include;C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_Win32\Include;C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\MSL\MSL_C\MSL_X86;C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\MSL\MSL_C++\MSL_Common\Include;+C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Common\Include;C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\MSL\MSL_Extras\MSL_Win32\Include;C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Support\Win32-x86 Support\Headers\Win32 SDK;
    PATH=C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Tools\Command_Line_Tools;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\tools;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\gcc\bin;C:\Program Files\Nokia\Carbide.c++ v1.3\jre\bin\client;C:\Program Files\Nokia\Carbide.c++ v1.3\jre\bin;C:\Perl\bin\;C:\Perl\site\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\system32\wbem;C:\Program Files\my;C:\Program Files\Common Files\Ulead Systems\MPEG; C:\Python25;C:\Perl\lib;C:\Program Files\MySQL\MySQL Server 5.0\bin;%webdev%;C:\Program Files\CSL Arm Toolchain\bin;C:\Program Files\Java\jdk1.6.0\bin;C:\Program Files\Java\jdk1.6.0\lib;C:\Program Files\Java\jre1.6.0\bin;C:\Program Files\Java\jre1.6.0\lib;C:\Symbian\8.0a\S60_2nd_FP2_CW\Epoc32\release\winscw\udeb;C:\Program Files\Common Files\Symbian\tools;C:\Program Files\CSL Arm Toolchain\bin;C:\S60\devices\S60_3rd_FP2_SDK\bin;C:\S60\devices\S60_3rd_FP2_SDK\lib;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\winscw;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\tools;C:\S60\devices\S60_3rd_FP2_SDK\lib;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\winscw;C:\S60\devices\S60_3rd_FP2_SDK\epoc32;C:\Program Files\Microsoft SQL Server\90\Tools\binn\;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\winscw;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\release\winscw;C:\S60\devices\S60_3rd_FP2_SDK\epoc32\release\winscw\udeb;C:\Program Files\Nokia\Carbide.c++ v1.3\x86Build\Symbian_Tools\Command_Line_Tools;C:\Program Files\MySQL\MySQL Server 5.0\bin
    EPOCROOT=\S60\devices\S60_3rd_FP2_SDK\
    NO_DEPENDENCIES=-nd
    MAKE=make -j 4

    Working Directory: C:/Symbian/Carbide/workspace/test/group

    ***Makefile structures up to date. Skipping 'bldmake bldfiles'

    ***Invoking abld command
    perl.exe -S ABLD.PL \Symbian\Carbide\workspace\test\group\ export
    make -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\EXPORT.make" EXPORT VERBOSE=-s
    Nothing to do

    Total Time: 0 sec

    ***Invoking abld command
    perl.exe -S ABLD.PL \Symbian\Carbide\workspace\test\group\ library winscw
    make -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\WINSCW.make" LIBRARY VERBOSE=-s
    make -s -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\TEST\WINSCW\TEST.WINSCW" LIBRARY

    Total Time: 0 sec

    ***Invoking abld command
    perl.exe -S ABLD.PL \Symbian\Carbide\workspace\test\group\ resource winscw udeb
    make -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\WINSCW.make" RESOURCE CFG=UDEB VERBOSE=-s
    make -s -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\TEST\WINSCW\TEST.WINSCW" RESOURCEUDEB

    Total Time: 0 sec

    ***Invoking abld command
    perl.exe -S ABLD.PL \Symbian\Carbide\workspace\test\group\ target winscw udeb
    make -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\WINSCW.make" TARGET CFG=UDEB VERBOSE=-s
    make -j 4 -s -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\TEST\WINSCW\TEST.WINSCW" UDEB

    Total Time: 1 sec

    ***Invoking abld command
    perl.exe -S ABLD.PL \Symbian\Carbide\workspace\test\group\ final winscw udeb
    make -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\WINSCW.make" FINAL CFG=UDEB VERBOSE=-s

    Total Time: 1 sec

    ***Invoking abld command
    perl.exe -S ABLD.PL \Symbian\Carbide\workspace\test\group\ test export
    make -r -f "\S60\devices\S60_3rd_FP2_SDK\EPOC32\BUILD\Symbian\Carbide\workspace\test\group\EXPORTtest.make" EXPORT VERBOSE=-s
    Nothing to do

    Total Time: 1 sec

    ***Build Complete

    Total Time: 1 sec


    //////////////////////////////////////////////////////////

    Pls help me.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Unable to run project

    i suggest you update to newer carbide.c++ v2.0.2. might solve your problem

  3. #3
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: Unable to run project

    At the debug launch, were you asked which exe to launch ?
    at that point you should choose emulator and not your application name.exe

    You can still change that by right clicking on your project and then choosing Build Options and changing the build configuration done.
    Amit Kankani
    Nokia Developer Champion

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    4

    Re: Unable to run project

    @amitkankani

    In build configuration it is pointing to emulator debug only...

  5. #5
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: Unable to run project

    well even in emulator debug, you are asked which Exe to launch...

    I would suggest one quick thing:

    Delete the project (not the contents, just entry in the workspace).

    Do an import from bld.inf and try again...
    Amit Kankani
    Nokia Developer Champion

  6. #6
    Registered User
    Join Date
    Feb 2009
    Posts
    4

    Re: Unable to run project

    Quote Originally Posted by skumar_rao View Post
    i suggest you update to newer carbide.c++ v2.0.2. might solve your problem
    i upgrade my carbide c++, but still the same

  7. #7
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,734

    Re: Unable to run project

    Have you tried Clean-ing the project?

  8. #8
    Registered User
    Join Date
    Feb 2009
    Posts
    4

    Re: Unable to run project

    Quote Originally Posted by wizard_hu_ View Post
    Have you tried Clean-ing the project?
    I am new to symbian and carbide, can u tell me how to do that.
    I am just trying the examples.
    If i run the program in command prompt with the given examples then it is working, but the problem is coming when i am trying with carbide c++

  9. #9
    Nokia Developer Champion
    Join Date
    Oct 2006
    Location
    Bangalore, India
    Posts
    1,572

    Re: Unable to run project

    well, I would again suggest the same thing, delete the carbide project and re-import the bld.inf file and then start Debug.
    At start debug it will ask you the exe to launch, there make sure you choose Emulator and it should solve your problem
    Amit Kankani
    Nokia Developer Champion

Similar Threads

  1. [moved] Unable to run sample applications with Series 40 SDK..
    By tv_padmanabhan in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2008-11-11, 18:31
  2. [Moved] The makmake tool failed to run. Project creation aborted
    By sanjayks84 in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2008-04-12, 18:11
  3. j2me project can not be run on Series 60 MIDP SDK 2.1 emulator
    By slchim in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2005-01-12, 16:17
  4. Nokia 7210: Unable to run (ANY) application
    By done in forum Mobile Java General
    Replies: 6
    Last Post: 2004-03-06, 16:17
  5. I am unable to run the bldmake bldfiles
    By dheeraj_anand in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2003-07-21, 14:35

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×