×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Dec 2007
    Location
    Питер
    Posts
    91

    Problems with Integration Qt for S60 and Carbide.

    I can't build Qt project for run on emu.
    I can build only for Phone debug.
    When i go to step to select available SDK i see only phone debug and phone release.
    I do configure -platform win32-mwc -xplatform symbian-abld and make debug-winscw.
    Where I could be mistaken

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problems with Integration Qt for S60 and Carbide.

    How many SDKs do you have installed? Could it be that you have configured Qt for S60 for the wrong SDK? Or else, could it be that there were errors in the configuration and you have failed to notice and fix them?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Dec 2007
    Location
    Питер
    Posts
    91

    Re: Problems with Integration Qt for S60 and Carbide.

    I have installed UIQ3 SDK and s60v5 SDK.
    But before i many install and uninstall sdk(s60v3, s60v5(0.9,1.0)).
    maybe have command to uninstall Qt for s60(or it's not need? Just run config?).

  4. #4
    Registered User
    Join Date
    Apr 2009
    Location
    Cluj-Napoca, Romania
    Posts
    6

    Unhappy Re: Problems with Integration Qt for S60 and Carbide.

    hey, i have the same problem. have you found any solution to solve it ? i'm getting frustrated about it

  5. #5
    Registered User
    Join Date
    Feb 2007
    Location
    Tampere
    Posts
    370

    Re: Problems with Integration Qt for S60 and Carbide.

    Hi,

    What does devices reflect. What is the default device for your machine? Also is Qt and your sdk on same drive?
    Regards

    - MVP
    "Dare To Dream" - A.P.J.Kalam

  6. #6
    Registered User
    Join Date
    Apr 2009
    Location
    Cluj-Napoca, Romania
    Posts
    6

    Smile Re: Problems with Integration Qt for S60 and Carbide.

    hey, i solve it
    yes, i have everything installed on the same drive, on C:, everything in their default locations. but the problem was that i had more SDKs,

    S60_SDK_3_1,
    S60_3rd_Edition_SDK_Feature_Pack_2_v1_1_en and
    S60_5th_Edition_SDK_v1_0_en,

    and when I run "make debug-winscw", as the INSTALL file from Qt/S60 Version 4.5.0-garden says, the default sdk was 3rd Ed FP2, then i changed the default to 5th Ed, but couldn't select the 5th ed SDK's emulator (winscw) as the active build configuration in carbide, i couldn't select it in "build configuration" for a project, only for 3rd ed sdk.

    Here's how i solved it : i uninstalled all other SDKs except S60 5th Edition, set is as default and followed again everything in INSTALL file from C:\qt\4.5.0-garden, and build it again. This time it created the directory C:\S60\devices\S60_5th_Edition_SDK_v1.0\epoc32\BUILD\qt\4.5.0-garden\ into the 5th ed SDK, i didn't know it works like that.

    Thanks for your quick reply.

  7. #7
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Problems with Integration Qt for S60 and Carbide.

    All you had to do is configure Qt again, for the new default SDK as well. But well, as long as you fixed the problem ...
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Importing Carbide v1.1 project to Carbide v1.3 problems
    By mockba in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 17
    Last Post: 2008-06-27, 06:35
  2. Carbide Install Problems
    By dsreich in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2008-02-14, 02:24
  3. Carbide C++ v.1.1 and .pkg problems
    By lachee in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-06-15, 13:44
  4. Carbide C++ 1.1 Integration with subversion Importing projects
    By mockba in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2007-02-18, 00:14
  5. Problems we are facing with Carbide C++. Please help with the solutions
    By bharath_hegde in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-11-15, 18:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×