×

Discussion Board

Results 1 to 11 of 11
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Expired Certificate on Nokia 5800

    Hello,

    my name is Tom and i am new in developing qt applications for S60.

    I have installed all software and packages i need. Everything works really good. I transfered the fluidlauncher-demo without any problems and could start it too on my device.

    But i got problems while creating own applications in the Carbide C/C++ IDE.

    My application will be built in "Phone Release (GCCE) [S60_3rd_FP1]" successfully and i get an sisx file which i would like to transfer to my Nokia 5800.

    While installing the application a message "Expired Certificate" will be shown.

    What does this mean and how could i avoid that?



    Best regards,
    Tom

  2. #2
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Expired Certificate on Nokia 5800

    There is nothing wrong with your application building or with your tools. The phone has bug that shows up when the phone is not properly activated. For a solution see post #13 at http://discussion.forum.nokia.com/fo...775#post532775.

    (This proves that there are few "new" problems and there's a significant chance that a search will show you an answer for most of your problems.)
    Last edited by ltomuta; 2009-04-07 at 09:37. Reason: Replaced bad link :(
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Re: Expired Certificate on Nokia 5800

    Dear ltomuta,

    the thread seems to be deleted.

    But i see any more users got problems while getting own applications on their 5800.

    //Edit: Ah, i found the thread here isnt it?

    Is there any bugfix yet or do i already have to restore the factory settings?



    Best regards,
    Tom
    Last edited by KartoffelKiffer; 2009-04-07 at 08:51.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,535

    Re: Expired Certificate on Nokia 5800

    Quote Originally Posted by KartoffelKiffer View Post
    Dear ltomuta,

    the thread seems to be deleted.

    But i see any more users got problems while getting own applications on their 5800.

    //Edit: Ah, i found the thread here isnt it?

    Is there any bugfix yet or do i already have to restore the factory settings?



    Best regards,
    Tom

    Well in any event (flashing firmware with the bugfix), you will have to back-up and restore data. So the method provided by Lucian is worth going ahead without waiting any further.

    Good Luck!!

  5. #5
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Re: Expired Certificate on Nokia 5800

    It works!

    I could use my application successfully and also connect SIGNALS to SLOTS! Great!

    But how could i use S60 functions like vibration or something else?

    Is there any API to use?



    Many thanks,
    Tom

  6. #6
    Nokia Developer Champion
    Join Date
    Mar 2006
    Location
    Helsinki, Finland
    Posts
    8,344

    Re: Expired Certificate on Nokia 5800

    Quote Originally Posted by KartoffelKiffer View Post
    But how could i use S60 functions like vibration or something else?

    Is there any API to use?
    Yes, there is. Start reading this article: Mobile Extensions for Qt for S60. Then narrow down to: http://wiki.forum.nokia.com/index.ph...#16._Vibra_API in the same page.
    Nokia Developer Wiki Moderation team

  7. #7
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Re: Expired Certificate on Nokia 5800

    I love it. Thanks a lot!!



    Best regards,
    Tom

  8. #8
    Registered User
    Join Date
    Jan 2009
    Posts
    2

    Re: Expired Certificate on Nokia 5800

    Oh, sweet!

    Thanks, kiran!

  9. #9
    Registered User
    Join Date
    Jul 2009
    Posts
    1

    Re: Expired Certificate on Nokia 5800

    hi
    i have a Nokia 5800 phone, and when i wanna install applications, it just give me this message ( Expired Certificate / invalid Certificate)

    please tell me what i can do for this problem


    thanks

  10. #10
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    430

    Re: Expired Certificate on Nokia 5800

    I had the same problem and I think it was solved by changing security for applications to install back and forth from accept any to accept only signed to accept any.

  11. #11
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Expired Certificate on Nokia 5800

    Quote Originally Posted by waled6 View Post
    hi
    i have a Nokia 5800 phone, and when i wanna install applications, it just give me this message ( Expired Certificate / invalid Certificate)

    please tell me what i can do for this problem


    thanks
    Have you seen post #2 in this thread? If this is too complicated for you maybe you should go to http://www.nokisa.com/support or http://www.nokia.com/discussions
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×