×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Nov 2008
    Posts
    25

    RConnectionMonitor problem. Pls help!!

    Hi all,

    I am using RConnectionMonitor GetIntAttribute method to retrieve the bearer type of currently active connection.

    But it is always returning KErrNotFound (-1) status.

    Here's my code:

    Code:
    void CMyClass::EventL(const CConnMonEventBase& aConnEvent)
    	{
    	switch( aConnEvent.EventType() )
    		{
    		
    		case EConnMonDeleteConnection:
    		   {
    		   iConnMonitor.GetIntAttribute(aConnEvent.ConnectionId(),0,KBearer, iBearer, iStatus);
    		   SetActive();
    		   
    		   break;
                       }
                    }
             }

    I need to do it inside EConnMonDeleteConnection case as I want this info only for the currently active connection.

    Anybody knows what to do?
    Am I missing here something?

    Thank you in advance.

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: RConnectionMonitor problem. Pls help!!

    Have you connected to RConnectionMonitor using RConnectionMonitor::Connect() ???

  3. #3
    Registered User
    Join Date
    Nov 2008
    Posts
    25

    Re: RConnectionMonitor problem. Pls help!!

    Hi savaj,

    ofcourse I have done ConnectL...

    I am able to get all other data related to the event.
    Only GetIntAttribute is not working.

    Can u guess what might be wrong here?
    Thanks.

  4. #4
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: RConnectionMonitor problem. Pls help!!

    SDK says "EConnMonDeleteConnection event is triggered when an existing connection is deleted. It also means that its sub-connections are deleted.". So it might be possible that aConnEvent.ConnectionId() return wrong ConnectionId and cause problem.

    I might be wrong, so once confirm it.

  5. #5
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,737

    Re: RConnectionMonitor problem. Pls help!!

    In Symbian environment you have to distinguish between hooks and notifications. Basically you do not find hooks in the public SDK-s, and notifications happen after a certain thing has happened. So when you get notification about that your connection is deleted, it is already deleted, that is why you can not find it any more.

  6. #6
    Registered User
    Join Date
    Nov 2008
    Posts
    25

    Re: RConnectionMonitor problem. Pls help!!

    Thanks.. that was indeed the problem. Solved it now.

    Thanks all for your help.

Similar Threads

  1. Nokia Multimedia Converter 2.0 request serial number
    By iacos in forum General Development Questions
    Replies: 38
    Last Post: 2008-08-05, 09:50
  2. Replies: 15
    Last Post: 2006-08-28, 13:57
  3. pls help
    By viraj_turakhia in forum Symbian Tools & SDKs
    Replies: 0
    Last Post: 2004-12-13, 08:33
  4. pls help me pls..... (everybody read this).....need it urgently
    By Never_Die in forum Bluetooth Technology
    Replies: 0
    Last Post: 2004-11-30, 07:52

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×