×

Discussion Board

Results 1 to 6 of 6

Thread: Qt installation

  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Qt installation

    I'm trying to install Qt for S60. I have 3rd edition FP2 devkit installed. When I try to run configure, building of qmake fails miserably: http://pastebin.com/m13f9e112

    I've reinstalled SDK this didn't have any efect.

    J

  2. #2
    Regular Contributor
    Join Date
    May 2007
    Posts
    468

    Re: Qt installation

    Hi,
    the error
    # Error: ^^^^^^^^^^
    # the file 'stddef.h' cannot be opened

    would indicate to me that you're using S60 3rd Ed. FP1 and haven't installed Open C. Are you sure it's FP2 that you're using?

    Cheers,
    Jack

  3. #3
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Re: Qt installation

    devices output:
    Code:
    S60_3rd_FP2_SDK_v1.1:com.nokia.s60 - default
    Directory C:\S60\devices\S60_3rd_FP2_SDK_v1.1\epoc32\include\libc has stddef.h inside it.

  4. #4
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Re: Qt installation

    Added epoc32\include and epoc32\include\libc to env variable MWCSym2Includes. Now it finds stddef.h and friends. Current output is this.

  5. #5
    Regular Contributor
    Join Date
    Oct 2008
    Location
    bhavnagar
    Posts
    255

    Re: Qt installation

    Quote Originally Posted by fronty View Post
    Added epoc32\include and epoc32\include\libc to env variable MWCSym2Includes. Now it finds stddef.h and friends. Current output is this.
    make sure that u have first install carbide. and configure it.

    and u also give the path correct..

    after that u got error..than uninstall all sdk and all supported file of qt.

    and reinstall all..as instruction..

    hope this help you..

    best regards.
    nayan trivedi.

  6. #6
    Registered User
    Join Date
    Mar 2009
    Posts
    4

    Re: Qt installation

    Thanks, I ran Configure environment for WINSCW command line and everything seems to be working now.

    Edit\\ Now I feel embarassed, if I would've read the whole INSTALL before messing around I would've done that before.

Similar Threads

  1. Auto start application when installation finished
    By markos123 in forum Symbian Tools & SDKs
    Replies: 12
    Last Post: 2009-07-17, 06:00
  2. ProGuard Installation
    By davidmanpearl in forum Mobile Java Tools & SDKs
    Replies: 5
    Last Post: 2007-10-03, 16:28
  3. Carbide.c++ and installation of Nokia S60 3rd Edition SDK
    By mitesh_thakkar in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-04-19, 14:20
  4. Replies: 5
    Last Post: 2006-09-28, 14:26
  5. Installation Problem on the Nokia 6600
    By ManishPatil in forum Symbian
    Replies: 1
    Last Post: 2005-02-02, 09:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×