Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    23

    Question Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Hello

    I'm developing some software for some FP2 phones, like N96 and 6210 navigator. Since the sensors framework is only supported by PyS60 1.9.3, I'm using that one ATM.

    I'm looking for a way to make vibration on the phone. I know that the MISO library can do that, and I've installed it as well.

    BUT, when using PyS60 1.9.3, i just get this message:

    Code:
    Connected.
    Python 2.5.4 (r254:67916, Mar 24 2009, 10:31:23) [C] on symbian_s60
    Type "copyright", "credits" or "license" for more information.
    Type "commands" to see the commands available in this simple line editor.
    >>> import miso
    Traceback (most recent call last):
      File "<console>", line 1, in <module>
      File "newcore\Symbian\src\site.py", line 94, in platsec_import
    ImportError: No module named miso
    >>>
    I tried in PyS60 1.4.5, with the developer version of MISO 1.9.6 (miso-1.96-s60_31_dev.sis manually signed for the phone) and it worked and made the phone vibrate. (the self signed version gave a permission denied error when importing).

    What should I do? I've installed both PyS60 and MISO on the C: drive, as it was recommended on several sites (and the positioning module is broken on 1.9.3 running from E

    BUT: I'm looking for a way to get vibration from 1.9.3 by either another 3rd party module, or by making the import of MISO work... What can be wrong since 1.9.3 can't find it, when it works for the old 1.4.5 ?

  2. #2
    Super Contributor
    Join Date
    Feb 2008
    Location
    Belo Horizonte, Brazil
    Posts
    744

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Not sure if miso and/or misty modules will work on FP2 or later devices. Those modules were compiled for FP1, which has a different SDK

    Guess you'll have to wait for an update



    BR,

    Rafael.

  3. #3
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    114

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Quote Originally Posted by sbn View Post
    <snip>

    BUT: I'm looking for a way to get vibration from 1.9.3 by either another 3rd party module, or by making the import of MISO work... What can be wrong since 1.9.3 can't find it, when it works for the old 1.4.5 ?
    To get the PyS60 extension modules working on 1.9.x series there are some mandatory changes needed which has to be done by the extension developer. These changes are listed in PyS60_1_9_x_README.txt in the source zip under the section - "6.2 Porting existing native extensions to PyS60 1.9.x". You can download the source and do the changes or ask the extension developer to make them for you. Without these changes the module cannot be imported in 1.9.x PyS60.
    import antigravity

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    23

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Rafael T.: As I wrote, MISO 1.9.6 works with PyS60 1.4.5
    ashwinurao: Thanks - i guess I'll contact the developer, or look for the source code...

  5. #5
    Registered User
    Join Date
    Apr 2009
    Posts
    10

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    I am also trying to get Miso or Misty working with 3rd FP2 on my Nokia N95 AND my Nokia E71 (module import error on both).

    Had limited success with Misty working on the N95 using PyS60 1.4.5 - however Python 1.9.4 just will not let me import it.

  6. #6
    Regular Contributor
    Join Date
    Jul 2007
    Location
    Eindhoven, the Netherlands
    Posts
    187

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Quote Originally Posted by benjeee View Post
    I am also trying to get Miso or Misty working with 3rd FP2 on my Nokia N95 AND my Nokia E71 (module import error on both).

    Had limited success with Misty working on the N95 using PyS60 1.4.5 - however Python 1.9.4 just will not let me import it.
    Did you rebuild misty for using the 1.9.4 SDK?
    In that case I would be interested to try your sis (on my N95), and hear what problems you have been running
    into so far with getting this to work on 1.9.4.

    I have not been able to track down modules for 1.9.4 that I need: miso or misty, Locationrequestor, Landmarks, and envy.
    For miso, locationrequestor an landmarks I have found sources, so my plan was to rebuild them myself for
    1.9.4 as soon as I got the 1.9.4 SDK working. From envy I only use the SetSystem call, which I can easily
    put in a new module myself (or add it to miso).

    I haven't tried it myself yet, but it looks like the PyS60 Community Edition is also preparing for 1.9.4,
    and that probably includes miso and various other popular extensions out of the box.

  7. #7
    Registered User
    Join Date
    Apr 2009
    Posts
    10

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    I couldnt get Miso or Misty working for 1.9.4, I didnt go as far as re-compiling the modules im afraid.

    Decided to fall back to 1.4.5 where I finally got misty working.. turns out if you are developing on a N95 without a SIM card installed (offline mode) then it disables the Vibration... Put a working SIM card in the phone and it works a treat using latest version of MISTY

  8. #8
    Super Contributor
    Join Date
    Mar 2003
    Location
    Espoo, Finland
    Posts
    976

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Quote Originally Posted by benjeee View Post
    turns out if you are developing on a N95 without a SIM card installed (offline mode) then it disables the Vibration... Put a working SIM card in the phone and it works a treat using latest version of MISTY
    There's a diffence between offline vs. no SIM card. Tried to use Nokia Maps without SIM card, wondering why it didn't get fix in 30 minutes. Put in a SIM card, got fix in 30 secs

    Thanx for tip that also Vibra doesn't work without SIM card! Can't imagine why it wouldn't work, but will try to remember that.

    Cheers,

    --jouni

  9. #9
    Nokia Developer Moderator
    Join Date
    May 2007
    Location
    21.46 N 72.11 E
    Posts
    3,805

    Smile Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Quote Originally Posted by JOM View Post

    Thanx for tip that also Vibra doesn't work without SIM card! Can't imagine why it wouldn't work, but will try to remember that.
    I don't think SIM card should affect the situation for either of them.

    Possible reasons that it did not work,

    * Vibra - Check offline profile - may be vibration is switched off. Might be a reason.

    * Maps - Internet through SIM card?
    Pankaj Nathani
    www.croozeus.com

  10. #10
    Super Contributor
    Join Date
    Mar 2003
    Location
    Espoo, Finland
    Posts
    976

    Re: Vibration for PyS60 1.9.3 on 3rd FP2 ? (miso?)

    Quote Originally Posted by croozeus View Post
    * Vibra - Check offline profile - may be vibration is switched off. Might be a reason.
    Good point!

    Quote Originally Posted by croozeus View Post
    * Maps - Internet through SIM card?
    Nope, it's wasn't any technical reason. Someone just has declared that Nokia Maps may not be used without SIM card. Politics maybe, possibly legal/patent/IPR issue to avoid making a "mobile phone" look like a "GPS handset". Also the A part in AGPS does require SIM card, but in my case the A was turned off (as far as I could tell).

    Cheers,

    --jouni

Similar Threads

  1. How to reboot 3rd Ed FP2 device (N85)?
    By aaaaapo in forum Symbian
    Replies: 2
    Last Post: 2009-04-07, 14:35
  2. [announce] Misty : MISO for 3rd edition !
    By cyke64 in forum Symbian
    Replies: 24
    Last Post: 2008-12-28, 16:36
  3. CContactDatabase problem in 3rd FP2
    By bgenady in forum Symbian
    Replies: 2
    Last Post: 2008-07-18, 11:38
  4. Title pane rect in S60 3rd fp2
    By mobi1 in forum Symbian
    Replies: 2
    Last Post: 2008-06-24, 09:55
  5. Replies: 17
    Last Post: 2007-01-11, 19:53

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×