×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Aug 2006
    Posts
    31

    QT, S60_3rd_FP1, S60_3rd_MR ...

    Hi all,

    I have questions related to backward compatibility between S60_3rd_FP1 and S60_3rd_MR. Trolltech says that the LASTEST platform that supports QT is S60_3rd_FP1.

    1) Does this mean that there is no way to configure Carbide to work with S60_3rd_MR and QT? I have (finally) compiled qt 4.5.0-garden winscw libraries for S60_3rd_FP1 and it works perfectly now in emulator. But I have only E60 and N80 devices so is there a way to use S60_3rd_MR with qt?

    2) If answer for (1) is NOT, how can I deploy code written in S60_3rd_FP1 for S60_3rd_MR in QT? Is it possible at all? I know that FP1 and MR are backward compatible, but this means that MR code will work on FP1 devices, not vice versa. I'm asking this because I have installed those QT demos on my E60 phone and they work perfectly. Are they written for FP1 and coincidentally work on MR or I'm missing something?

    I think that these topics are a little bit fuzzy, so any help would be appreceated

    Thanks
    Ljubomir

  2. #2
    Registered User
    Join Date
    Aug 2006
    Posts
    31

    Re: QT, S60_3rd_FP1, S60_3rd_MR ...

    Anyone?

  3. #3
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: QT, S60_3rd_FP1, S60_3rd_MR ...

    As far as I know, the Qt libraries don't build correctly on 3rd MR. At least some of the 3rd MR devices don't work with the Qt libraries (Feature not supported error on trying to start any app).

    Since 3rd MR and 3rd FP1 are fairly close in terms of compatibility, it may often be the case that applications built for 3rd FP1 will run on 3rd MR devices, but there is absolutely no guarantee of this.

    Does that answer your question?

    Basically, your devices aren't supported - if they work, then you're lucky!

    Mark

  4. #4
    Registered User
    Join Date
    Aug 2006
    Posts
    31

    Re: QT, S60_3rd_FP1, S60_3rd_MR ...

    Hi Mark,

    Actually, the problem is that few months ago these devices were supported and now they are not. I have successfully installed qt libraries, pips and fluidlauncher demo on E60 then, and it all worked very very well. But, after I installed qt 4.5.0-garden libraries on E60, the fluidlauncher demo won't start anymore (it throws now well-known error "Feature not supported"). And also, all of my examples built for Garden + FP1 won't start on E60 device too.

    There is nothing I can do here, I understand. But It is just too lame from Trolltech that something that worked well (I must say again: WELL) works no more. I can't imagine what features from FP1 were so important to make MR completely unusable in Garden.

    If somebody beats "Feature not supported" error, please let me know

    Cheers,
    Ljubomir
    Last edited by ljubex; 2009-04-16 at 18:00.

  5. #5
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Post Re: QT, S60_3rd_FP1, S60_3rd_MR ...

    Actually, the problem is that few months ago these devices were supported and now they are not. I have successfully installed qt libraries, pips and fluidlauncher demo on E60 then, and it all worked very very well. But, after I installed qt 4.5.0-garden libraries on E60, the fluidlauncher demo won't start anymore (it throws now well-known error "Feature not supported"). And also, all of my examples built for Garden + FP1 won't start on E60 device too.

    There is nothing I can do here, I understand. But It is just too lame from Trolltech that something that worked well (I must say again: WELL) works no more. I can't imagine what features from FP1 were so important to make MR completely unusable in Garden.
    hi Ljubomir

    After going a depth search on this topic i just come to know that S60_3rd_MR is a Maintance Release(MR) for windows vista.
    Because when windows vista was launched some of the S60_3rd_FP1 lib were not supported in vista so S60_3rd edition was a patch for vista.

    So think that your errors due to use of S60_3rd_MR with windows XP.

    Hope this will help you

    Regards
    Mind_freak

  6. #6
    Registered User
    Join Date
    Aug 2006
    Posts
    31

    Re: QT, S60_3rd_FP1, S60_3rd_MR ...

    Hi,

    Well, I think we're not talking about the same problem. Try to use fluidlauncher demos from Trolltech's site in combination with Garden's pre-built libraries on a real S60 3rd MR device. So, no compilation, no instalation, no Windows, no nothing on my computer. I'm just using officialy published "real device" software from Trolltech, and it's not working on MR devices.

    And there is nothing to complain about: they said that S60 3rd MR is NOT supported and that's it. I'm just feeling sad because I saw with my eyes how spectacular the demos ran on my E60 device with previous pre-relase of Qt. And actually, I'm asking for a "hack" that would made S60 3rd MR phones capable for Qt Garden.

    Has someone tried to compile Garden libraries for ARMV platform "by hand"?

    Cheers,
    Ljubomir

  7. #7
    Registered User
    Join Date
    Dec 2006
    Posts
    2,280

    Re: QT, S60_3rd_FP1, S60_3rd_MR ...

    I understand the problem and the frustration.

    The Qt for S60 porting team are using 3rd FP1 as their base, so they won't be testing anything to see if they break compatibility with 3rd MR. So you were lucky that it worked before and it's unfortunate that it doesn't now.

    It almost certainly is possible to fix it, and I'm very sure everyone would be happy if a community contributor provided a solution. However, it won't be a priority for the porting team and sadly, it's not yet possible to compile the Qt libraries with GCCE for target devices, so it's hard for anyone to get involved just now.

    Mark

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •