×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    23

    TRK no response in Carbide.c++ IDE

    Hi all,

    I tried to use TRK to do on-device debug. I used Carbide.c++ 2.0. I installed TRK version 3.0.8 on Nokia E61.

    I tried to use bluetooth and USB cable.

    Firstly, when I use bluetooth, I connected cell phone to PC. App TRK on cell phone showed the status is connected. The device name was correct. Then I used "Initiate service testing" in IDE. I always got "TRK no response". I am sure that I selected the correct com port which I check it in Device Management.

    Secondly, I tried USB cable. I choose the mode as PC suite. Then I closed the PC suite on PC. App TRK showed that the status is connected, but there is no any information about baudrate, stopbit, and something like this. I got "TRK no response" too when I tried "Initiate service testing".

    I was so confused what was wrong about my operation. Do you have any opinions on it?

    Another question is that I want to test memory errors on device. Does HookLogger support real device?

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: TRK no response in Carbide.c++ IDE

    Quote Originally Posted by charles_happysunny View Post
    Hi all,

    I tried to use TRK to do on-device debug. I used Carbide.c++ 2.0. I installed TRK version 3.0.8 on Nokia E61.

    I tried to use bluetooth and USB cable.

    Firstly, when I use bluetooth, I connected cell phone to PC. App TRK on cell phone showed the status is connected. The device name was correct. Then I used "Initiate service testing" in IDE. I always got "TRK no response". I am sure that I selected the correct com port which I check it in Device Management.

    Secondly, I tried USB cable. I choose the mode as PC suite. Then I closed the PC suite on PC. App TRK showed that the status is connected, but there is no any information about baudrate, stopbit, and something like this. I got "TRK no response" too when I tried "Initiate service testing".

    I was so confused what was wrong about my operation. Do you have any opinions on it?
    It has been discussed so many times and for different reasons so search in this Section.
    Another question is that I want to test memory errors on device. Does HookLogger support real device?
    At this time HookLogger is not supported for device.

  3. #3
    Super Contributor
    Join Date
    Jul 2008
    Posts
    2,020

    Re: TRK no response in Carbide.c++ IDE

    Prolly mismatch between TRK version and settings.

    1) Update Carbide to latest version
    2) check connection - it MUST NOT use TRK v2
    The lines above are the best I have to offer.If anyone of you is of more advanced knowledge, I ask for your patience and understanding! - unknown arab poet
    http://www.tamoggemon.com - Symbian blog - Windows Phone blog
    My other blogs:
    webOS blog iPhone blog BlackBerry blog Samsung bada blog Android blog

Similar Threads

  1. TRK 3 on device debugging and Carbide 2.0
    By ilancopelyn in forum Tools and SDK Feedback (Closed)
    Replies: 2
    Last Post: 2009-03-11, 06:47
  2. Handling asynch USSD response from operator
    By espenwe in forum Symbian Networking & Messaging (Closed)
    Replies: 9
    Last Post: 2009-02-05, 08:46
  3. TRK 3.0.8 not working in Carbide 2.0
    By ilancopelyn in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2008-12-08, 23:26
  4. 'Response Unknown' when downloading midlet
    By Weevil in forum Mobile Java General
    Replies: 3
    Last Post: 2004-05-30, 17:01
  5. nokia 7210 modem via IR doesn't work !
    By oussamaaiadi in forum PC Suite API and PC Connectivity SDK
    Replies: 1
    Last Post: 2003-03-06, 10:46

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×