×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    2

    Feature not supported

    Hi all
    I've downloaded helloworld application from this site:
    http://wiki.forum.nokia.com/index.ph...ith_Qt_for_S60
    I have build it and it works under emulator but it does not works under my phone (e66)!
    This is how I've made sis file:
    1. Carbide.c++ >> Import >> Qt >> Qt Project >> Hello.pro
    2. Project >> properties >> Caerbide.c++ >> Build Configurations
    3. Build Configurations: Active Configuration: Phone Release (GCCE) [S60_3rd_FP1]
    4. Build Configurations: Add >> Sis file creation options: PKG file: Hello_gcce_urel.pkg (or other)
    Signing options: Self sign sis file
    5. C:\Symbian\Carbide\workspace\Hello>make debug-gcce
    6. C:\Symbian\Carbide\workspace\Hello>createpackage -i Hello_gcce_urel.pkg (or other)
    7. From directory C:\Qt\4.5.0-garden\qts60binaries\3.x I copy to phone file qt_libs_armv5_udeb.sisx
    When I've tried to install it I've got respons that I dont have PIPS but I've install it anyway.
    8. I've install Hello_gcce_urel.sisx without any problem but when I've tried to launch application nothing happened

    9. I went to http://developer.symbian.com/wiki/display/pub/P.I.P.S. and install on my phone P.I.P.S. S60 .SIS but now when I'm trying to launch HelloWorld application I get message "Feature not supported"

    Don't konow what to do more... Please Help if u can I've got this problem with all applications

  2. #2
    Registered User
    Join Date
    Apr 2009
    Posts
    2

    Thumbs up Re: Feature not supported

    Ok it works now!!!
    I've installed wrong PIPS application. Didnt't read this: "Please, remember to install PIPS/Open C on S60 3.1 phones" :P
    U can find PIPS for s60 3.1 here: http://labs.trolltech.com/blogs/2008...ing-qt-to-s60/

    Best Regards
    Artur

  3. #3
    Registered User
    Join Date
    Jul 2009
    Posts
    15

    Re: Feature not supported

    Hi!

    I've got the same problem. Error "Feature not supported".

    But installing this PIPS application, doesn't help.

    Thanks.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,545

    Re: Feature not supported

    Quote Originally Posted by wmielcar View Post
    Hi!

    I've got the same problem. Error "Feature not supported".

    But installing this PIPS application, doesn't help.

    Thanks.
    Whats the SDK you are using, what application you are installing and what device you are installing on..etc? Information..information pls

  5. #5
    Registered User
    Join Date
    Jul 2009
    Posts
    15

    Re: Feature not supported

    SDK 3rd FP1, Nokia E66, my own application.
    The same application worked on Nokia E51.

  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,545

    Re: Feature not supported

    Quote Originally Posted by wmielcar View Post
    SDK 3rd FP1, Nokia E66, my own application.
    The same application worked on Nokia E51.
    And have you checked if E66 has support for features that your application needs? Check http://www.forum.nokia.com/devices/matrix_all_1.html

    Maybe you dont have all the plugins in your device your application would need?? QT libs (since you have posted in QT section)?

  7. #7
    Registered User
    Join Date
    Jul 2009
    Posts
    15

    Re: Feature not supported

    E66 supports all features my application need, I install all libs as on the E51 and even more.

    Does order of libs installation matters?

  8. #8
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,545

    Re: Feature not supported

    Quote Originally Posted by wmielcar View Post

    Does order of libs installation matters?
    I dont think so.

  9. #9
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Feature not supported

    What your application is doing?? Have you ever changed UID of application??? Same SISX (not application) working on E51?

  10. #10
    Registered User
    Join Date
    Jul 2009
    Posts
    15

    Re: Feature not supported

    It connects to internet, downloads some data and view this data.
    It switchs screen orientation. Nothing more complicated.

    SISX works on E51.

    I didn't change UID.

  11. #11
    Regular Contributor
    Join Date
    Oct 2008
    Location
    Oslo, Norway
    Posts
    329

    Re: Feature not supported

    Hi,

    It's better to make sure that the versions of following resources match up somehow :


    • Qt for Symbian (pre)release
    • Qt binaries installed in S60 device
    • OpenC/C++ Plugin for S60 SDK
    • OpenC binaries installed in S60 device


    When starting Qt development for S60, I would recommend that the latest available releases for both Qt and OpenC are used. The link posted below points to rather old OpenC binaries. Check this page in Forum Nokia, it has the latest version of both headers/libs and SIS packages (see <sdk_root>\nokia_plugin\openc\s60opencsis folder).

  12. #12
    Registered User
    Join Date
    Jul 2009
    Posts
    15

    Re: Feature not supported

    Thanks for reply, I've got:
    • qt s60 release 4.5.2
    • qt_libs.sis from 4.5.2 release
    • OpenC plugin release 1.5.5 beta
    • OpenC binaries release 1.5.5 beta on device


    Could this libs be the reason of problem on E66, even if it worked on E51?

Similar Threads

  1. Replies: 4
    Last Post: 2009-12-19, 15:35
  2. Python S60 Emulator
    By NAYSAMBO in forum Symbian
    Replies: 25
    Last Post: 2009-04-08, 10:22
  3. Icons in s60
    By drizzt6 in forum Mobile Java General
    Replies: 5
    Last Post: 2009-03-06, 09:32
  4. Error in Emulator: Feature Not Supported
    By seacabo in forum Symbian
    Replies: 3
    Last Post: 2006-05-12, 17:17
  5. installer feature was not supported
    By RearCog in forum Symbian
    Replies: 3
    Last Post: 2005-06-28, 04:02

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×