×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Mar 2003
    Location
    Luttenberg (Netherlands)
    Posts
    577

    Cannot install s60_3_1_app_trk_2_8_7.sisx on E71 / N82

    Hi,

    so Carbide.c++ v1.3 + s60_3_0_app_trk_2_8_7.sisx works on N73.
    so Carbide.c++ v2.0 + s60_3_0_app_trk_3_0_8.sisx DOES NOT works on E71.

    So naturally you would try:

    Carbide.c++ v1.3 + s60_3_1_app_trk_2_8_7.sisx for E71 (or N82).

    But that gives an error on the device saying

    "Unable to install. Component is built-in" ...

    Guess there is something in the ROM which conflicts with the AppTRK which is being installed? Forgot to put a stub in the ROM such that eclipsing is possible in the C: drive?

    So tell me how we are going to debug on new 3.1 devices?

    BR,

    Rene
    Rene Heuven
    Inmote - Creative Smartphone Solutions
    Web: www.inmote.com
    E-mail: rene@inmote.com

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,689

    Re: Cannot install s60_3_1_app_trk_2_8_7.sisx on E71 / N82

    If you have searched for a bit, you would have found that it is intentional that newer devices refuse older TRK-s (a decision against hacking I would guess).
    And use Help/Software Updates in Carbide, you will get TRK version 3.0.9. Try that.

  3. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    10

    Re: Cannot install s60_3_1_app_trk_2_8_7.sisx on E71 / N82

    Yes - I did search and have read that older version are not supported on newer devices for security reasons.

    But the newer versions of AppTRK do not allow debugging to work properly.

    See my post:
    Carbide.c++ v2.0 + s60_3_0_app_trk_3_0_8.sisx DOES NOT works on E71.

    So any solution? Or just sit and do nothing? Reporting is as a S60 platform bug will also not help that much - you get a standard reply that it is queued and never hear again (very encouraging).

    BR,

    Rene

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Cannot install s60_3_1_app_trk_2_8_7.sisx on E71 / N82

    @r_heuven (aka heuven)

    you do seem to have some problems using TRK and I'm sure the Carbide.c++ (and the other developers here) would like to know what happens. But I am confused, why would you even try TRK 2.8.7? And if that does not work who cares? It is old and obsolete. You have then tried 3.0.8, 3.0.9 and apparently 3.1.0 (I didn't know it exists!) ...

    It is always the latest one that should be tried and errors should be reported against it. And remember that TRK works with Carbide.c++ too so Carbide must be up-to-date as well. You should also expect that the R&D team tests TRK on the latest available firmware version so in that sense upgrading the firmware should be your priority.

    I think you should narrow your search and focus your effort in this direction then open a discussion (and a bug report) about your experience in this context.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Can't install TRK on N79
    By jgitter in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2009-04-14, 13:35
  2. App TRK on an E71
    By James McMurray in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2008-09-03, 21:17
  3. N82 Problem of synchronization with PC Suite
    By Telemann in forum General Development Questions
    Replies: 1
    Last Post: 2008-08-06, 13:48
  4. Cannot instal Nokia Search after new SD card install
    By Bart Van Mulders in forum General Development Questions
    Replies: 2
    Last Post: 2008-07-30, 15:42
  5. Unable to install on N82
    By bholowasia in forum Symbian Signed Support, Application Packaging and Distribution and Security
    Replies: 22
    Last Post: 2008-06-16, 20:25

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×