×

Discussion Board

Page 2 of 2 FirstFirst 12
Results 16 to 25 of 25
  1. #16
    Regular Contributor
    Join Date
    Sep 2008
    Location
    London, UK
    Posts
    176

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Hi Christophe,

    I didnt change the source code. Only altered the settings to allow compilation for 1.9.x platform.

    I'm not so familiar with Symbian C++, so I dont really understand your request.

    I created C:\Log on my phone, but no log file was created.

    could it be that the elocation.py file needs to be edited?

    --
    c:\resource\python25\elocation.py
    !:\sys\bin\kf_elocation.pyd
    --

  2. #17
    Regular Contributor
    Join Date
    Sep 2008
    Location
    London, UK
    Posts
    176

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    [announce] elocation compiled what's the best way to distribute?

    I tried wlantools, but there are too many c++ errors...

  3. #18
    Registered User
    Join Date
    Mar 2007
    Location
    Paris, France
    Posts
    78

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Hi

    Quote Originally Posted by the86hitman View Post
    [announce] elocation compiled what's the best way to distribute?

    I tried wlantools, but there are too many c++ errors...

    Yes, wlantools needs c++ corrections I think. I though elocation required also code adjustements. Does it work fine on your phone ? Did you try a loop with 100+ calls to the function ?



    To distribute it, I can make a link on my website, or just add you file on it and add a special mention that it is your work.

    I'm interested in knowing what modifications you did. I will reinstall completely my dev environment as soon as I have time to compile wlantools...

    Regards,

    Christophe
    Christophe Berger

  4. #19
    Regular Contributor
    Join Date
    Oct 2007
    Posts
    114

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Quote Originally Posted by the86hitman View Post
    [announce] elocation compiled what's the best way to distribute?
    Quote Originally Posted by bergerc View Post
    Hi

    To distribute it, I can make a link on my website, or just add you file on it and add a special mention that it is your work.
    Please please don't distribute it as a SIS file. One of the major features of 1.9.x is "Module Repository". If you are not yet familiar with it then please check out Chapter 7 of the documentation. I'll just brief you on what needs to be done:

    - I'm guessing the elocation module has it's own PYD and a .py wrapper. So, place these two file in a directory named "elocation" and zip/tar the folder.

    - Upload this zip/tar and instruct the users to extract this archive to the Module Repository on their PC (<PyS60 installed folder>\PythonForS60\module-repo\dev-modules )

    - It would be even better if you create the archive _WITH_ the directory structure i.e.
    \module-repo\dev-modules\_elocation.pyd
    \module-repo\dev-modules\elocation.py
    This way the users will extract directly to PythonForS60 folder.

    - Now application developers can use the elocation module in their script.

    - When they package their script using the PyS60 application packager the packager will scan the script for dependencies and automatically pick up the elocation related files from the dev-modules folder.


    Hopefully that was not very confusing.
    import antigravity

  5. #20
    Regular Contributor
    Join Date
    Sep 2008
    Location
    London, UK
    Posts
    176

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Christophe,

    http://sites.google.com/site/mrhtail...attredirects=0 download the sis file, install+test it..if it works, upload to your site

    http://sites.google.com/site/mrhtail...attredirects=0 for the pyd+py file
    Last edited by the86hitman; 2009-07-07 at 15:04. Reason: added the zip for module-repo

  6. #21
    Registered User
    Join Date
    Mar 2007
    Location
    Paris, France
    Posts
    78

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Quote Originally Posted by the86hitman View Post
    Christophe,

    http://sites.google.com/site/mrhtail...attredirects=0 download the sis file, install+test it..if it works, upload to your site

    http://sites.google.com/site/mrhtail...attredirects=0 for the pyd+py file
    Hi,

    Sorry for the -long- delay. I tested it and it's working well on my 5800 Xpress Music. I added your files to my webpage and a note...

    Thanks for your help,


    Christophe
    Christophe Berger

  7. #22
    Regular Contributor
    Join Date
    Sep 2008
    Location
    London, UK
    Posts
    176

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Quote Originally Posted by bergerc View Post
    Hi,

    Sorry for the -long- delay. I tested it and it's working well on my 5800 Xpress Music. I added your files to my webpage and a note...

    Thanks for your help,


    Christophe
    happy to help
    if I succeed with wlantools i'll let you know.

  8. #23
    Regular Contributor
    Join Date
    Sep 2008
    Location
    London, UK
    Posts
    176

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    wlantools compiled and ported to 1.9.x

  9. #24
    Regular Contributor
    Join Date
    Sep 2005
    Location
    Finland, Helsinki
    Posts
    323

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    Quote Originally Posted by the86hitman View Post
    wlantools compiled and ported to 1.9.x
    Good news! How to download?
    --
    Aapo Rista
    http://code.google.com/p/pys60gps/
    http://opennetmap.org/

  10. #25
    Regular Contributor
    Join Date
    Sep 2008
    Location
    London, UK
    Posts
    176

    Re: PyS60 1.9.3 compilation problem (in order to compile modules)

    The86Hitman
    PyS60 1.9.7 on E71
    http://www.drhtailor.com/pys60

Similar Threads

  1. Importing new modules in pys60?
    By Faultsprofit in forum Symbian
    Replies: 2
    Last Post: 2010-07-31, 18:42
  2. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  3. problem with installation of 1.9.3 - N5800
    By maclun123 in forum Symbian
    Replies: 2
    Last Post: 2009-03-30, 20:52
  4. Conditional compilation: managing set of modules
    By doctordwarf in forum Symbian
    Replies: 3
    Last Post: 2004-08-31, 14:01
  5. Sun Wireless toolkit and compilation problem...
    By TomXX in forum Mobile Java Tools & SDKs
    Replies: 0
    Last Post: 2003-04-15, 17:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×