×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Regular Contributor
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    285

    Question how to configure S60 5th edition sdk for QT development

    hi folk,

    i've S60 5th edition sdk installed with carbide.
    1) how to configure S60 5th edition sdk for QT development?
    2) will QT application run on s60 devices?

  2. #2
    Registered User
    Join Date
    Jan 2009
    Location
    ભારત->ગુજરાત->ભાવનગર
    Posts
    279

    Post Re: how to configure S60 5th edition sdk for QT development

    hi chandra

    i think your new to QT,but don't worry i am going to tell you that step by step installation of QT with 5th edition.
    1>Install Perl(set the enviroment variable)
    2>Install JDK(latest version)
    3>Install 5th Edition SdK(befor installing this plz replace the winscw file)
    4>Install Carbid C++ V.2.0(after installing click on Start->programs->carbid c++->configure enviroment for winscw)
    5>Extract QT-Garden to the same directory where you have done your all previous installation...
    6>Refer INSTALL file(Qt->QT-garden->INSTALL)
    Here You will find the commands that you have to run in CMD.After Going through all the commands launch carbid c++
    7>click tool->preference->Qt tab and add you bin path of OT.

    Hope This will help You
    Regards
    Mind_freak

  3. #3
    Nokia Developer Champion
    Join Date
    Sep 2007
    Location
    Bhavnagar
    Posts
    928

    Re: how to configure S60 5th edition sdk for QT development

    Hi
    welcome to the forum.
    Regrding your second question, you can run the qt application on the s60 3rd edition fp1 device or fp2 and 5th edition.
    Jajal Mehul

  4. #4
    Registered User
    Join Date
    Apr 2008
    Posts
    18

    Re: how to configure S60 5th edition sdk for QT development

    Hi,
    Follow the "install" document in your qt-sdk.

  5. #5
    Regular Contributor
    Join Date
    Jul 2008
    Location
    Delhi, India
    Posts
    285

    Re: how to configure S60 5th edition sdk for QT development

    thanks for ur 2 the point response.
    i am a symbian developer, and few days ago i got an idea about QT having suach a brilliant UI design and ease to use.
    1) can i use QT API in symbian application?
    2) or Symbian API can be used in QT projects?

  6. #6
    Nokia Developer Champion
    Join Date
    Sep 2007
    Location
    Bhavnagar
    Posts
    928

    Re: how to configure S60 5th edition sdk for QT development

    Hi chandra1234,

    Check this wiki article. Download the zip file there ,It may be helpful for you. There is a mixup of symbian and qt.

    Hope this helps you.
    Jajal Mehul

  7. #7
    Nokia Developer Expert
    Join Date
    Jun 2008
    Posts
    333

    Re: how to configure S60 5th edition sdk for QT development

    1. Install needed IDE and SDKs

    Make sure you have the following installed:
    - Carbide.c++ v2.0.0 or higher
    - S60 Platform SDK 3rd Edition FP1 or higher
    - Open C/C++ for S60 3rd Edition (automatically included in 3.2 and higher)

    These instructions assume the above tools are installed and
    that the enviroment variables for your compiler are set correctly.

    Note: Users of S60 Platform SDK 3rd Edition FP1 also need special updates:
    http://pepper.troll.no/s60prereleases/patches/

    Note: The wsini.ini provided with the S60 Platform SDK 5th Edition v0.9
    needs to be updated for correct font rendering in the emulator. For details:
    http://pepper.troll.no/s60prereleases/patches/

    2. Install Qt

    Uncompress the package into the directory you want Qt installed,
    e.g. C:\Qt\4.5.0-garden.

    Note: Qt must be installed on the same drive as the S60 SDK you are
    using, and the install path must not contain any whitespaces.

    3. Environment variables

    In order to build and use Qt, the PATH environment variable needs
    to be extended:

    PATH - to locate qmake, moc and other Qt tools

    This is done by adding c:\Qt\4.5.0-garden\bin to the PATH variable.

    On Windows the PATH can be extended by navigating to
    "Control Panel->System->Advanced->Environment variables".

    In addition, you must configure the environment for use with the S60
    emulator. This is done by locating the Carbide.c++ submenu on the Start
    menu, and choosing "Configure environment for WINSCW command line".

    4. Configure Qt

    To configure Qt for S60, do:

    cd \Qt\4.5.0-garden
    configure -platform win32-mwc -xplatform symbian-abld

    For other options, type "configure -help" to get a list of all available
    options.

    5. Build Qt

    The Qt libraries comes pre-built for real devices.
    If you are using a 3.x S60 SDK, install qts60binaries\3.x\qtlibs-4.5.0-garden.exe
    into the S60 SDK root directory. For example: C:\Symbian\9.2\S60_3rd_FP1_2\
    If you are using a 5.0 S60 SDK, install qts60binaries\5.0\qtlibs-4.5.0-garden.exe
    into the S60 SDK root directory. For example: C:\S60\devices\S60_5th_Edition_SDK_v0.9\

    To build Qt for the emulator, type:

    make debug-winscw

    Congratulations, Qt is now ready to use.

    6. Running Qt demos

    We've included a subset of the Qt demos in this package for you
    to try out. An excellent starting point is the "fluidlauncher"
    demo. To run the demo on a real device, you first have to install
    the Qt libraries on the device.
    For 3.x devices install qts60binaries\3.x\qt_libs_armv5_udeb.sisx
    For 5.0 devices install qts60binaries\5.0\qt_libs_armv5_udeb.sisx
    included in this package to the device. Then type:

    cd examples
    make debug-gcce
    cd ..\demos

    make debug-gcce
    cd embedded\fluidlauncher
    createpackage -i fluidlauncher_gcce_udeb.pkg

    This will create a self-signed fluidlauncher_gcce_udeb.sisx and
    install it to your device.

    Note: You can specify your own certificate and key files as additional
    parameters to createpackage if default ones are not suitable.

    To run the demos on the emulator simply run:

    make run

Similar Threads

  1. S60 5th edition applications in 3rd edition phones
    By radhamanogar in forum Symbian
    Replies: 4
    Last Post: 2012-08-08, 06:47
  2. Python for S60 1.9.2 released
    By tvijayan in forum Symbian
    Replies: 26
    Last Post: 2009-03-11, 09:28
  3. Replies: 4
    Last Post: 2007-03-02, 00:15
  4. S60 2nd OR 3rd edition for new software development
    By patil_ruturaj in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2006-06-30, 08:57

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×