×

Discussion Board

Results 1 to 3 of 3
  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    19

    Exclamation Cannot run MIDlet with Eclipse MJT and Nokia 6212 SDK

    Hi,

    I use a up-tp-date Eclipse version with JDK 1.6 Update 13 and the up-to-date Eclipse MJT (latest "Version" of JavaME, see http://www.eclipse.org/dsdp/mtj/) and the Nokia 6212 SDK. The device configuration is done as described in the SDK's guide.

    So running my simple TestFrame-Midlet opens the Emulator but it never starts and says:

    "Invalid application. Delete?"
    "Smart card communication error 0x80100017"

    Please help me! I'm currently only able to manually build the .jad file and start the MIDlet manually but thats not the solution while beeing able to fly to the moon :-)


    What is the problem here?

  2. #2
    Registered User
    Join Date
    Oct 2008
    Posts
    41

    Smile Re: Cannot run MIDlet with Eclipse MJT and Nokia 6212 SDK

    I have a similar problem,but in my case It is with the S40 SDK, so I didn't find a correct solution. If I find I will post here...

    Best regards...

  3. #3
    Registered User
    Join Date
    Apr 2009
    Posts
    19

    Lightbulb Re: Cannot run MIDlet with Eclipse MJT and Nokia 6212 SDK

    It works! I've figured out the correct configuration. I show you what's important to run Midlets on Nokia 6212 SDK Emulator:

    - use Mobile Java Tools 1.0M6 (http://www.eclipse.org/dsdp/mtj/)
    - Create new MIDlet Project
    - Check the Project properties for Java Compiler and set (if not already) "enable project specific settings" and "Use default compliance settings" 1.3 or 1.1
    - Create a new MIDlet Class and save
    - Open the Application Descriptor Overwiev and set MIDlet version 1.0.0, CLDC 1.1 and MIDP 2.1
    - Note the buttons at the buttom of the Application descriptor and click "MIDlets" to see the list
    - Add your MIDlet with "Add" and choose a name for it or leave it "MIDlet-1" and save the Application Decriptor
    - Now running as emulated MIDlet or as JAD should work.

    - If not, then this is because sometimes the JAR is not build correctly..
    - Therefore I have always opened the Explorer on path /eclipseworkspace/myMidletProject/.mtj.tmp/emulation
    - There just delete the .jar file and go back to eclipse and remove the MIDlet, save, re-add the Midlet and save

    It works :-)

    Important is the correct configuration of the Application Descriptor and the package-path to the MIDlet in the MINIFEST file within the JAR file and to compile with compliance level 1.3 or 1.1.

    There are two nice getting started tutorials:
    - http://www.forum.nokia.com/Events/Tr...Learning.xhtml
    - http://live.eclipse.org/node/614

    Regards
    Last edited by mathias4u; 2009-04-26 at 11:58.

Similar Threads

  1. Eclipse + SDK for Nokia 6131 NFC + MJT
    By AnDrEaMM in forum Near Field Communication
    Replies: 3
    Last Post: 2009-09-10, 11:18

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×