×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    Feb 2009
    Posts
    50

    5800, SetDisplayWindowL

    Hi all,

    I'm working on video playback using CVideoPlayerUtility.
    App plays RTSP stream.
    When video is playing, tries to change video rectangle by calling SetDisplayWindowL function.
    As result, video disappears but audio remains ok.

    Any ideas?

    Thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,699

    Re: 5800, SetDisplayWindowL

    Try PauseL+Play.

  3. #3
    Registered User
    Join Date
    Feb 2009
    Posts
    50

    Re: 5800, SetDisplayWindowL

    Already tried PauseL + SetDisplayWindowL + Play.
    The same result.

    PS. On emulator all is OK with and without PauseL.

  4. #4
    Registered User
    Join Date
    Feb 2009
    Posts
    50

    Re: 5800, SetDisplayWindowL

    I had a little investigation.
    It looks like video disappears even through I redraws window by calling DrawDeferred, for instance.

    Is it some platform issue?

  5. #5
    Registered User
    Join Date
    Oct 2007
    Posts
    17

    Re: 5800, SetDisplayWindowL

    Hi,

    did you find any solution for this?

    Thank you.

  6. #6
    Registered User
    Join Date
    Feb 2009
    Posts
    50

    Re: 5800, SetDisplayWindowL

    Yep,

    Use DrawNow instead of DrawDeferred. And use DrawNow before calling SetDisplayWindowL.

  7. #7
    Registered User
    Join Date
    Oct 2007
    Posts
    17

    Re: 5800, SetDisplayWindowL

    Well, in my case that solution does not work. I've tried to replace every single call to DrawDeferred, but the results remain the same. Thank you for your rapid response.
    Last edited by jmblazquez; 2009-10-02 at 07:08.

  8. #8
    Registered User
    Join Date
    Dec 2003
    Posts
    1

    Re: 5800, SetDisplayWindowL

    Finally it worked. There was a "hidden" call to DrawDeferred.
    Last edited by mlizondo; 2009-10-02 at 11:55.

Similar Threads

  1. Problems with application Icons on 5800 device
    By John.Holloway in forum Symbian User Interface
    Replies: 35
    Last Post: 2009-09-30, 08:48
  2. Replies: 0
    Last Post: 2009-03-03, 22:51
  3. Capturing and Streaming Video / Audio on 5800 for S60
    By MBFonz in forum Streaming and Video
    Replies: 1
    Last Post: 2009-02-13, 00:10
  4. Capturing Video / Audio on 5800 in S60 Application
    By MBFonz in forum General Development Questions
    Replies: 1
    Last Post: 2009-02-13, 00:08

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×