×

Discussion Board

Results 1 to 6 of 6
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    36

    Please help with auto start of my app

    Hello,

    I have created a GUI Application with UI Designer and I want to auto start my application at phone startup. I'm using Startup List Management API to do this but no luck. Application doesn't start and I have no error messages at phone startup.
    I don't know why. Can you please help me with this issue?

    This is my code:

    0x101F7961.rss file:
    Code:
    #include <startupitem.rh>
    RESOURCE STARTUP_ITEM_INFO app
    {
    	executable_name = "!:\\sys\\bin\\MyApp.exe";
    	recovery = EStartupItemExPolicyNone;
    }
    Piece of MMP file:
    Code:
    START RESOURCE 	0x101F7961.rss
    TARGETPATH      resource\apps
    END
    Piece of PKG file:
    Code:
    "$(EPOCROOT)Epoc32\data\z\resource\apps\0x101F7961.R01" -"!:\private\101f875a\import\[0x101F7961].rsc"
    Tested on N95.

    Thanks!

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,673

    Re: Please help with auto start of my app

    0x is wrong (remove), 101F7961 is suspicious (re-check what it is).

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    36

    Re: Please help with auto start of my app

    Same result...

  4. #4
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,673

    Re: Please help with auto start of my app

    What is 101F7961? It does not seems like a UID of yours.
    Anyway, the UID of the startup registration file should match with the UID of your .pkg file.

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Bangalore,India
    Posts
    2,146

    Re: Please help with auto start of my app

    Quote Originally Posted by Boris S. View Post
    Same result...
    Please check this link :-

    http://wiki.forum.nokia.com/index.ph...Management_API

    also make sure to have the .rss file name that you create to be of type [YourAPPUID].rss, also the UID should be consistent in the mmp file and pkg file.

    Cheers,
    Mayank

  6. #6
    Registered User
    Join Date
    Sep 2008
    Posts
    36

    Re: Please help with auto start of my app

    I have solve the problem. My mistake, 0x101F7961 isn't application UID... Now all works fine.
    Thanks to all!

Similar Threads

  1. Auto start application will not work
    By xhoust00 in forum Symbian
    Replies: 10
    Last Post: 2009-03-07, 05:39
  2. problem with auto start && pre-install
    By Teddy_ in forum Symbian
    Replies: 1
    Last Post: 2009-02-26, 08:27
  3. Replies: 10
    Last Post: 2009-02-16, 12:03
  4. Auto start and Auto installation
    By sunithadevim in forum Symbian
    Replies: 8
    Last Post: 2008-02-07, 04:58
  5. Auto start and embeded SIS file
    By zabbas12 in forum Symbian
    Replies: 5
    Last Post: 2007-04-12, 06:59

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×