×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    4

    Qt Garden installation problem

    Hi all,
    I am following the step-by-step instructions in the INSTALL file in 4.5.0-garden folder and I am running into this problem.
    I have done the following (which are the steps in INSTALL)
    1. Install needed IDE and SDKs
    --> I installed "Carbide.c++ v2.00"
    --> I installed "S60 Platform SDK 3rd Edition"
    --> I installed "Open C/C++ for S60 3rd Edition"

    2. Install Qt
    --> I installed it as instructed under C:\Qt\4.5.0-garden\

    3. Environment variables
    --> I have extended the PATH variable with the c:\Qt\4.5.0-garden\bin

    4. Configure Qt
    --> I typed these two commands:
    1) cd \Qt\4.5.0-garden
    2) "configure -platform win32-mwc -xplatform symbian-abld"

    5. Build Qt
    --> I installed qts60binaries\3.x\qtlibs-4.5.0-garden.exe under my directory C:\Symbian\9.1\S60_3rd\ and it produced a folder called \Epoc32
    --> The next step states: To build Qt for the emulator, type: make debug-winscw

    When I type this, I get the following error output... (here is the beginning of the output...)

    C:\Qt\4.5.0-garden>make debug-winscw
    ABLD.BAT build winscw udeb
    make -r -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Qt\4.5.0-garden\EXPORT.make" EXPORT VERBOSE=-s
    make[1]: Entering directory `C:/Qt/4.5.0-garden'
    Nothing to do
    make[1]: Leaving directory `C:/Qt/4.5.0-garden'
    make -r -f "\Symbian\9.1\S60_3rd\EPOC32\BUILD\Qt\4.5.0-garden\WINSCW.make" MAKEFILE VERBOSE=-s
    make[1]: Entering directory `C:/Qt/4.5.0-garden'
    make -s -C \Qt\4.5.0-garden\src\s60main -f "MAKEFILE_0X2001E61F.MK" TO_ROOT=..\..\..\.. EPOCBLD=..\
    ..\..\..\Symbian\9.1\S60_3rd\EPOC32\BUILD\Qt\4.5.0-garden\MAKEFILE_0X2001E61F\WINSCW TO_BLDINF=..\..
    \..\..\Qt\4.5.0-garden PLATFORM=WINSCW MAKMAKE
    perl -S makmake.pl -D \Qt\4.5.0-garden\src\s60main\S60MAIN_0X2001E61F WINSCW
    WARNING: Cannot determine the version of the RVCT Compiler.

    MMPFILE "\Qt\4.5.0-garden\src\s60main\S60MAIN_0X2001E61F.MMP"
    WARNING: \Qt\4.5.0-garden\src\s60main\S60MAIN_0X2001E61F.MMP(37) : SYSTEMINCLUDE path "\Qt\4.5.0-gar
    den\src\s60main\/epoc32/include\" not found

    WARNING: \Qt\4.5.0-garden\src\s60main\S60MAIN_0X2001E61F.MMP(38) : SYSTEMINCLUDE path "\Qt\4.5.0-gar
    den\src\s60main\/epoc32/include/stdapis\" not found

    WARNING: \Qt\4.5.0-garden\src\s60main\S60MAIN_0X2001E61F.MMP(39) : SYSTEMINCLUDE path "\Qt\4.5.0-gar
    den\src\s60main\/epoc32/include/stdapis/sys\" not found


    WARNING: Can't find following headers in System Include Path
    <appinfo.rh> <eikon.rh> <avkon.rh>
    (Sys Inc Paths "\Qt\4.5.0-garden\src\s60main\../../include\" "\Qt\4.5.0-garden\src\s60main\../../inc
    lude/tmp\" "\Qt\4.5.0-garden\src\s60main\../../mkspecs/symbian-abld/stl-off\" "\Qt\4.5.0-garden\src\
    s60main\../../mkspecs/symbian-abld/stl-off/tmp\" "\Qt\4.5.0-garden\src\s60main\../../mkspecs/symbian
    -abld\" "\Qt\4.5.0-garden\src\s60main\../../mkspecs/symbian-abld/tmp\" "\Qt\4.5.0-garden\src\s60main
    \/epoc32/include\" "\Qt\4.5.0-garden\src\s60main\/epoc32/include/stdapis\" "\Qt\4.5.0-garden\src\s60
    main\/epoc32/include/stdapis/sys\" "\Qt\4.5.0-garden\src\s60main\" "\Qt\4.5.0-garden\src\s60main\tmp
    \" "\Qt\4.5.0-garden\src\s60main\tmp/tmp\" "\Qt\4.5.0-garden\src\s60main\../../include/QtCore\" "\Qt
    \4.5.0-garden\src\s60main\../../include/QtCore/tmp\" "\Qt\4.5.0-garden\src\s60main\tmp/moc/debug_sha
    red\" "\Qt\4.5.0-garden\src\s60main\tmp/moc/debug_shared/tmp\" "\Symbian\9.1\S60_3rd\epoc32\include\
    variant")


    Can anyone shed some light on my issue?

    thanks in advance!

  2. #2
    Nokia Developer Champion
    Join Date
    Sep 2007
    Location
    Bhavnagar
    Posts
    928

    Re: Qt Garden installation problem

    Hi v333k,
    We have a many threads on this discussion board regarding the installation issue. May be your problem is discuss somewhere and you can get the solution by searching this forum.

    Have you configure the carbide for winscw environment? You can do it from start->programs->carbide2.0->configure for winscw environment.

    Hope this helps you.

    Regards.
    Jajal Mehul

  3. #3
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Qt Garden installation problem

    Quote Originally Posted by v333k View Post
    --> I installed "S60 Platform SDK 3rd Edition"
    if i am not wrong, than you require S60 Platform SDK 3rd Edition FP1 or higher. Read this installation guide for Qt for S60.

    Quote Originally Posted by v333k View Post
    5. Build Qt
    --> I installed qts60binaries\3.x\qtlibs-4.5.0-garden.exe under my directory C:\Symbian\9.1\S60_3rd\ and it produced a folder called \Epoc32
    If produced mean created folder Epoc32, than you have not installed SDK (S60) properly. Because on installation of S60 SDK, Epoc32 folder will be creatd automatically.

  4. #4
    Registered User
    Join Date
    May 2009
    Posts
    4

    Re: Qt Garden installation problem

    Thanks!
    I installed a newer version SDK S60_FP2_v1_1 and it worked. I downloaded the zipped package and installed it, but I can only see in "Active Configuration":
    Emulator Debug (WINSCW)[S60_3rd_FP2_SDK_V1.1]
    Previously, when I had S60_3rd_SDK I had Phone_Debug Phone_Release in addition to the emulator. I would like to run an application on my phone now and I don't know what the next step is to add a new configuration for the phone.

    Thanks in advance for any pointers!

  5. #5
    Nokia Developer Champion
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Qt Garden installation problem

    Have you installed binaries for real devices at correct location (step 5)??? I mean at "..\9.2\S60_3rd_FP1_2" .

    Follows step 4 and 5 carefully from this page.
    http://pepper.troll.no/s60prerelease...stall-s60.html

  6. #6
    Registered User
    Join Date
    May 2009
    Posts
    4

    Re: Qt Garden installation problem

    Thanks Savaj for your reply.
    Yes, I did follow steps 4 and 5 as instructed in the link. I still don't see anything other than the emulator configuration.
    I am thinking about uninstalling and reinstalling everything from the beginning.

    Do you have any other suggestions before I do that?

    thanks!
    v333k

  7. #7
    Nokia Developer Moderator
    Join Date
    May 2007
    Posts
    468

    Re: Qt Garden installation problem

    Hi, carbide version 2.0.0 should work just fine if you really have installed the target build libraries by running C:\Qt\4.5.0-garden2\qts60binaries\3.x\qtlibs-4.5.0-garden.exe. This is easy to verify, check from your SDKs epoc32\release\armv5\lib (f.ex C:\Symbian\9.3\S60_3rd_FP2_SDK_v1.1\epoc32\release\armv5\lib) that you have Qt libraries there, f.ex QtGui.lib.

    If this doesn't for some reason help I would recommend updating Carbide before doing full re-install. From Help menu check software updates.

    Cheers,
    Jack

  8. #8
    Registered User
    Join Date
    May 2009
    Posts
    4

    Re: Qt Garden installation problem

    Hi Jack,
    Thanks for the info.
    I am under the impression that I installed the latest carbide.
    However, I noticed this, and it could be causing some abnormalities.
    It looks like the version of Symbian I installed is 9.1 - so I need to upgrade this first.

    This is what I see in my directory:

    C:\Symbian\9.1\S60_3rd
    \Epoc32
    \Examples
    \glib
    \nokia_plugin
    \S60Ex

    C:\Symbian\9.1\S60_3rd_FP1_2
    \Epoc32 (only)

    I have a 6650 fold, and I think I have Symbian 9.3, so I should get this taken care of first.

Similar Threads

  1. problem with installation of 1.9.3 - N5800
    By maclun123 in forum Symbian
    Replies: 2
    Last Post: 2009-03-30, 20:52
  2. Installation problem for S60 3.0 SDK
    By harri_salminen in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2007-11-14, 22:01

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •