×

Discussion Board

Results 1 to 10 of 10
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    38

    error while run simple cube program in carbide c++ ..plz help

    Hello Everyone,


    i m trying to run simple cube (artolkitplus s60/Augmented Reality)program into carbide c++ v2.0 using sdk_s60_3rd...but after try to build/run in carbide c++ 2.0.. it shows some error:

    1.ARToolKitPlus/TrackerSingleMarker.h: No such file or directory[/Nokia/artoolkitplus-s60/OpenGLEx/SimpleCube/inc/Tracker_ARTK.h:14]
    2.error: `ARToolKitPlus' has not been declared
    3.error: ISO C++ forbids declaration of `TrackerSingleMarker' with no type
    4.error: expected `;' before '*' token
    5.error: `tracker' undeclared (first use this function)
    6.error: (Each undeclared identifier is reported only once for each function it appears in.)


    so what is the solution to overcome this error...plz plz ..help me..

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,544

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by rassall_jubair View Post
    Hello Everyone,


    i m trying to run simple cube (artolkitplus s60/Augmented Reality)program into carbide c++ v2.0 using sdk_s60_3rd...but after try to build/run in carbide c++ 2.0.. it shows some error:

    1.ARToolKitPlus/TrackerSingleMarker.h: No such file or directory[/Nokia/artoolkitplus-s60/OpenGLEx/SimpleCube/inc/Tracker_ARTK.h:14]
    2.error: `ARToolKitPlus' has not been declared
    3.error: ISO C++ forbids declaration of `TrackerSingleMarker' with no type
    4.error: expected `;' before '*' token
    5.error: `tracker' undeclared (first use this function)
    6.error: (Each undeclared identifier is reported only once for each function it appears in.)


    so what is the solution to overcome this error...plz plz ..help me..
    Well, it shows header missing in the path. Check such generic things.

    Also it looks to me that you just took some c++ code from somewhere and trying to compile. I would advise you to stick to some examples from SDK to check on nuances of Symbian and then try to port(if at all this is what you are doing).

  3. #3
    Registered User
    Join Date
    May 2009
    Posts
    38

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by Symbian_Neil View Post
    Well, it shows header missing in the path. Check such generic things.

    Also it looks to me that you just took some c++ code from somewhere and trying to compile. I would advise you to stick to some examples from SDK to check on nuances of Symbian and then try to port(if at all this is what you are doing).
    I try this sample program which is published by nokia..for augmented reality application.this program(simple cube) is run with arttolkitplus s60..
    so..plz details me how i add the such path to recover such error.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,544

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by rassall_jubair View Post
    I try this sample program which is published by nokia..for augmented reality application.this program(simple cube) is run with arttolkitplus s60..
    so..plz details me how i add the such path to recover such error.
    Please dont spam..avoid multipost with same issues. Savaj already has listed a few threads of yours in your other thread http://discussion.forum.nokia.com/fo...048#post586048

    Please stick to one thread and give more details of where you found the code, etc so that anybody who wants to help you atleast knows what application you are talking about without actually searching.

  5. #5
    Registered User
    Join Date
    May 2009
    Posts
    38

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by Symbian_Neil View Post
    Please dont spam..avoid multipost with same issues. Savaj already has listed a few threads of yours in your other thread http://discussion.forum.nokia.com/fo...048#post586048

    Please stick to one thread and give more details of where you found the code, etc so that anybody who wants to help you atleast knows what application you are talking about without actually searching.
    ok.. i understand..i try to follow the post.. the code is build with artoolkitplus s60 tool.this is sample/example program.im working in visual c++ platform. & also wokring with augmented reality(ar) application...now im try to run ar application in mobile specially symbian..so try to run this program in carbide c++ & i m getting such error.i have already installed the sdk,openGLES etc,plugin,.so if anybody know this..suggest me ..thanks...

  6. #6
    Registered User
    Join Date
    May 2009
    Posts
    38

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by rassall_jubair View Post
    ok.. i understand..i try to follow the post.. the code is build with artoolkitplus s60 tool.this is sample/example program.im working in visual c++ platform. & also wokring with augmented reality(ar) application...now im try to run ar application in mobile specially symbian..so try to run this program in carbide c++ & i m getting such error.i have already installed the sdk,openGLES etc,plugin,.so if anybody know this..suggest me ..thanks...
    Problem Solved...i had to edit .mmp file to include path edit.also had to artoolkit.lib into bin.
    thanks anyway..

  7. #7
    Registered User
    Join Date
    Apr 2009
    Posts
    2

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by rassall_jubair View Post
    Problem Solved...i had to edit .mmp file to include path edit.also had to artoolkit.lib into bin.
    thanks anyway..
    Hi rassall_jubair,

    Iam facing a similar problem as yours..can you kindly elaborate on how you resolved it..thanks

  8. #8
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by vikrum View Post
    Iam facing a similar problem as yours..can you kindly elaborate on how you resolved it
    rassall_jubair already mentioned how he resolved the issue, check it.

    Quote Originally Posted by rassall_jubair
    Problem Solved...i had to edit .mmp file to include path edit.also had to artoolkit.lib into bin.
    Anyway, Exactly what the problem you facing?

  9. #9
    Registered User
    Join Date
    Apr 2009
    Posts
    2

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by savaj View Post
    rassall_jubair already mentioned how he resolved the issue, check it.



    Anyway, Exactly what the problem you facing?
    when you mentioned one has to copy "ArToolkit.lib" into bin----> which Bin would that be?..and where exactly is the file "ArToolkit.lib"? and wot has to be included in the path?..thankx

  10. #10
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,544

    Re: error while run simple cube program in carbide c++ ..plz help

    Quote Originally Posted by vikrum View Post
    when you mentioned one has to copy "ArToolkit.lib" into bin----> which Bin would that be?..and where exactly is the file "ArToolkit.lib"? and wot has to be included in the path?..thankx
    Describe your problem correctly and it would be easier to help rather than say 'same problem'. Whats the error you are getting..past the error message, its always better.

Similar Threads

  1. Carbide c++ 2.0 Ghost run configuration... where is it stored?
    By olhed in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 2
    Last Post: 2009-04-27, 09:58
  2. Carbide 1.1Developed application Run on Device but Carbide 1.3 application Failed.
    By uday.neo in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 15
    Last Post: 2009-01-15, 13:10
  3. Can not run file manager program
    By agsapt in forum Symbian
    Replies: 0
    Last Post: 2002-08-27, 07:37
  4. i cannot run any java program in 9200 SDK
    By chili_fi in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2002-08-12, 23:34

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×