×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    2.0 support for 3rd FP1 devices?

    Hello. I haven't found anything that specifically answers this question, so here goes:

    Will PyS60 2.0 have at least the same level of support for 3rd FP1 devices (N95, E71, etc, etc) as the current PyS60 1.4.5?

    The reason I ask is that the "PyS60[1.9.4] Tests and Feedback" thread states that scriptext will not be backported, and current support is for 3rd FP2 devices. This seems to break support for many apps on the N95, such as SMS apps: The inbox module is not included in 1.9.4 (at least it no longer imports), and the new messaging is done through scriptext.

    Thanks

  2. #2
    Regular Contributor
    Join Date
    Sep 2005
    Location
    Finland, Helsinki
    Posts
    323

    Re: 2.0 support for 3rd FP1 devices?

    Quote Originally Posted by chris_uvic View Post
    Will PyS60 2.0 have at least the same level of support for 3rd FP1 devices (N95, E71, etc, etc) as the current PyS60 1.4.5?

    The reason I ask is that the "PyS60[1.9.4] Tests and Feedback" thread states that scriptext will not be backported, and current support is for 3rd FP2 devices. This seems to break support for many apps on the N95, such as SMS apps: The inbox module is not included in 1.9.4 (at least it no longer imports), and the new messaging is done through scriptext.
    Hmm, perhaps I missed something, but my N82 (FP1) imports inbox and scriptext without any problems in 1.9.4 (devcert signed with all available capabilities):

    Code:
    >>> import sysinfo, inbox, e32
    >>> e32.pys60_version
    '1.9.4 svn3103'
    >>> sysinfo.sw_version()
    u'V 31.0.016 09-12-08 RM-313 Sharaku(c)NMP'
    >>> ib = inbox.Inbox()
    >>> ib
    <inbox.Inbox object at 0x185c410>
    >>> import scriptext
    >>> dir(scriptext)
    ['EventCanceled', 'EventCompleted', 'EventError', 'EventInParamCheck', 'EventInProgress', 
     'EventOutParamCheck', 'EventQueryExit', 'EventStarted', 'EventStopped', 'ScriptextError',
     'ScriptextHandle', 'ScriptextIterableWrapper', 'ScriptextListWrapper', 'ScriptextMapWrapper', 
     '__doc__', '__file__', '__name__', 'load']
    --
    Aapo Rista
    http://code.google.com/p/pys60gps/
    http://opennetmap.org/

  3. #3
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: 2.0 support for 3rd FP1 devices?

    Hmm... I'm seeing that problem with two N95s. I'll try resetting one and reinstalling.

    Thanks

  4. #4
    Regular Contributor
    Join Date
    Sep 2005
    Location
    Finland, Helsinki
    Posts
    323

    Re: 2.0 support for 3rd FP1 devices?

    Quote Originally Posted by chris_uvic View Post
    Hmm... I'm seeing that problem with two N95s. I'll try resetting one and reinstalling.
    I tested in a N95 (no SIM-card), imports inbox and scriptext without any problems.

    All stuff is installed in the phone's memory.
    --
    Aapo Rista
    http://code.google.com/p/pys60gps/
    http://opennetmap.org/

  5. #5
    Nokia Developer Expert
    Join Date
    Apr 2007
    Posts
    131

    Re: 2.0 support for 3rd FP1 devices?

    Quote Originally Posted by aaaaapo View Post
    I tested in a N95 (no SIM-card), imports inbox and scriptext without any problems.

    All stuff is installed in the phone's memory.
    Are your queries answered or you still have something that is not clear ?

  6. #6
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: 2.0 support for 3rd FP1 devices?

    I have a question connected with this thread so I don't want to start a new one.

    I've installed pys60 v1.9.4 and I tried to run this script (it is one of examples from Library Reference):
    Code:
    import scriptext
    
    # Load the desired SAPI
    appmanager_handle = scriptext.load('Service.AppManager', 'IAppManager')
    try:
       f = open('c:\\data.txt', 'a+')
       app_info = []
       appmanager_info = appmanager_handle.call('GetList', {'Type': u'Application'})
       for item in appmanager_info:
           app_info.append(item['UID'])
           app_info.append(item['Caption'])
           print item['UID']
           print item['Path']
           print item['Caption']
           print item['ShortCaption']
       f.write(str(app_info))
    except scriptext.ScriptextError, err:
       print "Error getting the list of Installed Application: ", err
    When I try to run this script python closes and nothing happen.
    I'm using Nokia e51 (FP1).
    Is there posibility to run this script on my phone?

  7. #7
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: 2.0 support for 3rd FP1 devices?

    hello sqblak

    AFAIK scriptext module is available only for S60 FP2 devices and above.

    So the script will not work in your device which is a FP1 device.

    Regards
    Gaba88

  8. #8
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: 2.0 support for 3rd FP1 devices?

    So is there any other way to get list of installed applications on FP1 phone?

  9. #9
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: 2.0 support for 3rd FP1 devices?

    Quote Originally Posted by sqblak View Post
    So is there any other way to get list of installed applications on FP1 phone?
    hello sqblak

    i am not sure but there is an extension module known as applist using which you can get the list of all installed applications.

    Please make a search at the forum nokia wiki.

    Hope this helps you

  10. #10
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: 2.0 support for 3rd FP1 devices?

    hello again

    i have made a search for you follow this article.

    Cheers,
    Gaba88

  11. #11
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: 2.0 support for 3rd FP1 devices?

    Thank You very much for your help but I still have the problem.

    I've downloaded from here APPLIST.unsigned.sis and APPLIST_3rdEd_1.0.unsigned.sis but after installing any of them doesn't seem to work. I get an error 'No module named applist'.

    Do You know how to solve this problem?

  12. #12
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: 2.0 support for 3rd FP1 devices?

    Quote Originally Posted by sqblak View Post
    Thank You very much for your help but I still have the problem.

    I've downloaded from here APPLIST.unsigned.sis and APPLIST_3rdEd_1.0.unsigned.sis but after installing any of them doesn't seem to work. I get an error 'No module named applist'.

    Do You know how to solve this problem?
    hello sqblak

    Have you signed the extension at the symbiansigned.

    Have you installed the application in the same drive where your python runtime is installed.

    One important thing which PyS60 version you are using???

  13. #13
    Registered User
    Join Date
    Sep 2008
    Posts
    7

    Re: 2.0 support for 3rd FP1 devices?

    Ok I've solved problem.

    You were right it was connected with unsigned extension and PyS60 version.

    I had 1.9.4 but I uninstalled it. Now I have 1.4.5. Then I got error caused by unsigned version of extension but I googled another one and now it seems to work fine.

    Thank you again for Your help
    sqblak

  14. #14
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: 2.0 support for 3rd FP1 devices?

    Quote Originally Posted by sqblak View Post
    Ok I've solved problem.

    You were right it was connected with unsigned extension and PyS60 version.

    I had 1.9.4 but I uninstalled it. Now I have 1.4.5. Then I got error caused by unsigned version of extension but I googled another one and now it seems to work fine.

    Thank you again for Your help
    sqblak
    Hello sqblak

    great that you got applist working correctly.

    Feel free to post if you face any sort of problems furthur.

    Enjoy Pythoning

Similar Threads

  1. AMR support for APS 2.0
    By nly in forum VoIP
    Replies: 2
    Last Post: 2007-03-16, 18:53
  2. Hotkey support in S60 3rd ed FP1
    By svdwal in forum Symbian User Interface
    Replies: 0
    Last Post: 2007-02-12, 12:09
  3. Which devices support OBEX?
    By ed_welch in forum Mobile Java Networking & Messaging & Security
    Replies: 18
    Last Post: 2007-01-17, 15:57
  4. Replies: 1
    Last Post: 2007-01-15, 20:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×