Hi

I have a project which uses SATSA-crpto.ar from WTK2.5.2
I've places this jar in polihs.home/import folder and added build entry with binaryLirary

Code:
While building this i get an error
[[Nokia] proguard: Warning: com.sun.satsa.crypto.RSACipher: can't find referenced class com.sun.midp.ssl.Cipher
[Nokia] proguard: Warning: com.sun.satsa.crypto.RSACipher: can't find referenced class com.sun.midp.ssl.Cipher
[Nokia] proguard: Warning: com.sun.satsa.crypto.RSACipher: can't find referenced class com.sun.midp.ssl.CryptoException
[Nokia] proguard: Warning: com.sun.satsa.crypto.RSACipher: can't find referenced class com.sun.midp.ssl.CryptoException
[Nokia] proguard: Warning: com.sun.satsa.crypto.RSACipher: can't find referenced class com.sun.midp.ssl.CryptoException
[Nokia] proguard: Warning: there were 50 unresolved references to program class members.
  [Nokia] proguard:          You may need to specify additional library jars (using '-libraryjars'),
    [Nokia] proguard:          or perhaps the '-dontskipnonpubliclibraryclasses' option.
    [Nokia] proguard: Warning: there were 172 unresolved references to program class members.
    [Nokia] proguard:          Your input classes appear to be inconsistent.
    [Nokia] proguard:          You may need to recompile them and try again.
    [Nokia] proguard:          Alternatively, you may have to specify the options
    [Nokia] proguard:          '-dontskipnonpubliclibraryclasses' and/or
    [Nokia] proguard:          '-dontskipnonpubliclibraryclassmembers'.
    [Nokia] proguard: Error: Please correct the above warnings first.
    [Nokia] ProGuard arguments: [java, -jar, C:\Program Files\J2MEPolish\lib\proguard.jar, -injars, E:\Projects\zCentral\SecureZ\MobileGateway\build\real\source.jar, -outjars, E:\Projects\zCentral\SecureZ\MobileGateway\build\real\dest.jar, -libraryjars, "'C:/Program Files/J2MEPolish/import/mmapi.jar'";"'C:/Program Files/J2MEPolish/import/cldc-1.1.jar'";"'C:/Program Files/J2MEPolish/import/midp-2.0.jar'";"'C:/Program Files/J2MEPolish/import/nokia-ui.jar'";"'C:/Program Files/J2MEPolish/import/wmapi.jar'";"'C:/Program Files/J2MEPolish/import/btapi.jar'";"'C:/Program Files/J2MEPolish/import/m3g.jar'";"'C:/Program Files/J2MEPolish/import/pdaapi.jar'";"'C:/Program Files/J2MEPolish/import/jsr172.jar'";"'C:/Program Files/J2MEPolish/import/jsr180.jar'";"'C:/Program Files/J2MEPolish/import/m2g.jar'";"'C:/Program Files/J2MEPolish/import/locationapi-1.0.jar'";"'C:/Program Files/J2MEPolish/import/jsr234.jar'", -keep, class com.tranzfinity.mobile.core.ui.TranzfinityMidlet, -dontoptimize, -applymapping, E:\Projects\zCentral\SecureZ\MobileGateway\build\real\Nokia\N95\en_US\input-obfuscation-map.txt, -printmapping, E:\Projects\zCentral\SecureZ\MobileGateway\build\real\Nokia\N95\en_US\obfuscation-map.txt, -allowaccessmodification, -overloadaggressively, -defaultpackage, "", -dontusemixedcaseclassnames]
What can be the reason

I can not remove obfuscation tag since i am using Buncy castle and it requires obfucation.

how do i specify this:
-dontskipnonpubliclibraryclassmembers

I have rebuilt the progurad jar with above option, but still it gives preverify error

Geetanjali