×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    24

    unable to show sysinfo.signal_dbm() in S60 2 ED

    unable to show sysinfo.signal_dbm() in S60 2 ED

    error show
    File "<console>", line 1, in ?
    AttributeError: 'module' object has no attribute 'signal_dbm'

    any one please help

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: unable to show sysinfo.signal_dbm() in S60 2 ED

    From the PyS60 Library Reference:
    signal_dbm()
    Returns the current network signal strength in dBm. This is available SDK 2.8 onwards. If using an emulator value 0 is always returned.
    SDK 2.8 means S60 2nd Edition, Feature Pack 3. Your phone is probably older than that.

  3. #3
    Registered User
    Join Date
    May 2009
    Posts
    24

    Re: unable to show sysinfo.signal_dbm() in S60 2 ED

    thanks bogdan,
    I found the problem my phone is N70, which is S60 2nd Edition FP3. I get
    this problem because I install wrong python version.

    and now I would like to know how to install python SDK for carbide c++ because I try to find any document in here but not found.

    Quote Originally Posted by bogdan.galiceanu View Post
    From the PyS60 Library Reference:


    SDK 2.8 means S60 2nd Edition, Feature Pack 3. Your phone is probably older than that.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: unable to show sysinfo.signal_dbm() in S60 2 ED

    Quote Originally Posted by k_suntti View Post
    and now I would like to know how to install python SDK for carbide c++ because I try to find any document in here but not found.
    Carbide.c++ is an IDE, you can't install a Python SDK on it. The Python SDK is basically just a ZIP archive that you extract into the installation directory of your S60 SDK. That puts all the necessary files in the appropriate locations. And as a note, Carbide.c++ doesn't work for Python development.

Similar Threads

  1. Python for S60 1.9.0 released
    By tvijayan in forum Symbian
    Replies: 48
    Last Post: 2009-01-27, 15:39
  2. Replies: 2
    Last Post: 2008-12-29, 06:53
  3. openc s60 2nd ed. FP3
    By tulimiero in forum Open C/C++
    Replies: 1
    Last Post: 2008-11-22, 12:32
  4. Hotkey support in S60 3rd ed FP1
    By svdwal in forum Symbian User Interface
    Replies: 0
    Last Post: 2007-02-12, 12:09

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •