×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    144

    Carbide 2.0 Problem

    Hi All,

    I had installed carbide 2.0. i created dll & build(ARMI) for SDK 2.1 version, it gives me error
    UID out of range
    so i changed UID3 to 0x01000000. but this dll is not loaded....

    is carbide 2.0 not compatible for All sdk? What is the problem?


    Thanks & Regards,
    Sheetal.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide 2.0 Problem

    Quote Originally Posted by pornima View Post
    Hi All,

    I had installed carbide 2.0. i created dll & build(ARMI) for SDK 2.1 version, it gives me error
    UID out of range
    so i changed UID3 to 0x01000000. but this dll is not loaded....

    is carbide 2.1 not compatible for All sdk? What is the problem?


    Thanks & Regards,
    Sheetal.
    carbide 2.1 only supports SDK starting from v3.x . you need to use carbide v1.2

  3. #3
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    144

    Re: Carbide 2.0 Problem

    Quote Originally Posted by skumar_rao View Post
    carbide 2.1 only supports SDK starting from v3.x . you need to use carbide v1.2

    Hello,

    I ask about carbide v2.0? it is also not compatible?

    Sheetal.

  4. #4
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,143

    Re: Carbide 2.0 Problem

    maybe you could try using the UIDs from the defined ranges, here's one Wiki article that shows the ranges: http://wiki.forum.nokia.com/index.ph...d_applications

  5. #5
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide 2.0 Problem

    Quote Originally Posted by pornima View Post
    Hello,

    I ask about carbide v2.0? it is also not compatible?

    Sheetal.
    yes it is not compatible with v2.x SDKs

  6. #6
    Regular Contributor
    Join Date
    Jun 2008
    Posts
    144

    Re: Carbide 2.0 Problem

    Quote Originally Posted by skumar_rao View Post
    yes it is not compatible with v2.x SDKs
    I change UID3 to one of uid from carbide1.1. sis file is created. but load dll is failed with -1....
    so any solution exists to use carbidev2.0 for SDK2.1?or i have to shift to Carbide v1.1?


    Regards,
    Sheetal.

  7. #7
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Carbide 2.0 Problem

    you have to use Carbide v1.2 or below

  8. #8
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,568

    Re: Carbide 2.0 Problem

    Actually the templates are still present in Carbide.c++ v2.x, so the method described in Lucian's blog (http://blogs.forum.nokia.com/blog/lu...carbide.c-v1.3) may work.

Similar Threads

  1. How to include path in carbide c++ 2.0?
    By rassall_jubair in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 29
    Last Post: 2010-11-11, 16:02
  2. Problem in compiling 2nd Edition project wid Carbide 2.0
    By nital_shah in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2009-05-17, 04:45
  3. Build problem on ARMV5 and GCCE with Carbide c++ 2.0 (S60 3rd Edition FP1)
    By pinkhardlionel in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 10
    Last Post: 2009-01-14, 09:02
  4. TRK 3.0.8 not working in Carbide 2.0
    By ilancopelyn in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 3
    Last Post: 2008-12-08, 23:26
  5. Carbide C++ 1.2 License Problem
    By meihao in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2008-02-28, 21:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •