×

Discussion Board

Results 1 to 8 of 8
  1. #1
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    442

    Play Audio file successfully but do not working pause().

    Hi

    I am Play Audio file using CVideoPlayerUtility::OpenURL() and file played succefully, but when i click on pause than pause also but when i clicked on continue do nothing.

    why audio file not able to play after pause.

    Regards
    SymbianTH.

  2. #2
    Super Contributor
    Join Date
    Mar 2004
    Location
    Bangalore,India
    Posts
    2,146

    Re: Play Audio file successfully but do not working pause().

    There would be some return code/errors after caling the function in the callback functions, they would you an indication of what happened. Also check this wiki link which has the code snippet :-

    http://wiki.forum.nokia.com/index.ph...oPlayerUtility
    Cheers,
    Mayank

  3. #3
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    442

    Re: Play Audio file successfully but do not working pause().

    Quote Originally Posted by mayankkedia View Post
    There would be some return code/errors after caling the function in the callback functions, they would you an indication of what happened. Also check this wiki link which has the code snippet :-

    http://wiki.forum.nokia.com/index.ph...oPlayerUtility
    Hi

    I able to play, pause, rewind video file and also able to play audio file using CVideoPlayerUtility.

    But not able to pause, rewind audio file.

    Regards,
    SymbianTH

  4. #4
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: Play Audio file successfully but do not working pause().

    Hi,

    what you have wrote in continue? try to debug it.
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  5. #5
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    442

    Re: Play Audio file successfully but do not working pause().

    Hi

    Thanks For help.

    I am colling function with wrong object name.

    Thanks, I solved.
    SymbianTH

  6. #6
    Super Contributor
    Join Date
    Mar 2004
    Location
    Bangalore,India
    Posts
    2,146

    Re: Play Audio file successfully but do not working pause().

    Quote Originally Posted by SymbianTH View Post
    Hi

    Thanks For help.

    I am colling function with wrong object name.

    Thanks, I solved.
    SymbianTH
    Good ole Sherlock Holmes would have said "Its elementary my dear Mr. Watson" !!!
    Cheers,
    Mayank

  7. #7
    Regular Contributor
    Join Date
    Aug 2009
    Location
    Bangalore, India
    Posts
    454

    Re: Play Audio file successfully but do not working pause().

    Quote Originally Posted by mayankkedia View Post
    There would be some return code/errors after caling the function in the callback functions, they would you an indication of what happened. Also check this wiki link which has the code snippet :-

    http://wiki.forum.nokia.com/index.ph...oPlayerUtility
    Hi, I have tried with this example...its getting played the video, but if I increase/decrease the volume, then the value is getting changed but video stops playing...even if I press pause option also...

    only Play option is working...why is it getting stuck if I select Volume Up/Down ?
    Regards,
    Sunitha.M

  8. #8
    Registered User
    Join Date
    Sep 2009
    Posts
    63

    Re: Play Audio file successfully but do not working pause().

    // pause function
    if (iState == EPlaying)
    {
    errorViewer = iMdaPlayer->GetPosition(aTime);
    iMdaPlayer->Stop();
    iState = EPause;
    }
    //////////////////////////////////
    //play function
    if (iState == EPause || iState == EReadyToPlay)
    {
    iMdaPlayer->SetPosition(aTime);
    iState=EPlaying;
    iMdaPlayer->Play();
    }
    //////////////////////////////////

Similar Threads

  1. Regarding BMCONV
    By sanah007 in forum Symbian
    Replies: 2
    Last Post: 2009-05-26, 12:47
  2. play audio file
    By nitroxxx123 in forum Symbian
    Replies: 1
    Last Post: 2009-04-12, 07:52
  3. Can I play MPEG Audio Layer-3 file using CMdaAudioOutputStream
    By anand_zain76 in forum Symbian Media (Closed)
    Replies: 7
    Last Post: 2008-03-17, 09:27
  4. Error with makesis.exe and creating the .pkg file
    By gramya87 in forum Symbian Tools & SDKs
    Replies: 7
    Last Post: 2007-10-10, 13:53
  5. Help needed with a 3gp file...
    By joedoe_1981 in forum Streaming and Video
    Replies: 0
    Last Post: 2007-07-18, 18:58

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×