×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Oct 2008
    Posts
    17

    what else has to be done if i changed application name

    i got into the situation that i have to change the name of the exe application. i changed in the mmp file.i can run the apllication using emulator but not on phone. i created sis and installed on phone sucussfully but i can' start the application .no error message,no crash. just no reaction when i hit the apllication icon.

    can anyone give me a hint what could be the problem?
    thanks

  2. #2
    Nokia Developer Expert
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,142

    Re: what else has to be done if i changed application name

    extended panic might help: http://wiki.forum.nokia.com/index.ph...ded_panic_code, if the ErrRd approach does not work, then do try my Y-Tasks:: Crash monitor, it always gets the process exit code.

    Make sure you also do change your registration resource file & pkg files to match your now name..

  3. #3
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Budapest, Hungary
    Posts
    28,567

    Re: what else has to be done if i changed application name

    If you modified the name of the .exe, you should also modify APP_REGISTRATION_INFO.app_file in the _reg.rss file.
    Also note that the name of your 'main' resource file should match with the name of the .exe

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,491

    Re: what else has to be done if i changed application name

    Quote Originally Posted by Zhuwei View Post
    i got into the situation that i have to change the name of the exe application. i changed in the mmp file.i can run the apllication using emulator but not on phone. i created sis and installed on phone sucussfully but i can' start the application .no error message,no crash. just no reaction when i hit the apllication icon.

    can anyone give me a hint what could be the problem?
    thanks
    Its quite possible that it wouldnt run on emulator too if it wasnt for old files already there. I would suggest you to go in for a reallyclean build for emulator, and try it. Most possibly (I am almost certain) it wont work on emulator either. Then use filemon to monitor epoc.exe and see what files it fails on(what filenames it expects and what you are using) and this would indicate where you have forgotten to change.

    You cannot change it only in mmp file to make it run. The resources also need an attention (There are a few explicit and few implicit calls on the names.)

    edit: Ah finally the answer typed long ago (no track of time) gets posted!!!!!

Similar Threads

  1. problem in Auto starting application in s60_2nd_fp3
    By gaurav.gupta in forum Symbian C++
    Replies: 14
    Last Post: 2009-04-30, 11:09
  2. Call for webkit GUI and application engine model
    By yant in forum Symbian User Interface
    Replies: 1
    Last Post: 2009-04-16, 10:04
  3. AutoStart My application at bootup
    By prakashs in forum Symbian C++
    Replies: 7
    Last Post: 2009-03-24, 10:06
  4. Updating an application
    By Alfury in forum Mobile Java Networking & Messaging & Security
    Replies: 2
    Last Post: 2008-04-08, 16:56
  5. Replies: 0
    Last Post: 2005-05-28, 10:20

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •