×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    Regular Contributor
    Join Date
    May 2009
    Posts
    50

    Qt configuration Problem in Carbide C++ 2.0

    Hello, I am new to Symbian C++ and using CArbide C/C++ 2.0 and Nokia N97 SDK_v0.5. I want to develop simple QT Gui Widget with Carbide C++ 2.0. I have installed both Qt SDK 2009.02 and Qt 4.5.0 garden, when I choose new Project from Carbide C++ and after Gui widget option I get the following error:

    No SDK's were found that contain Qt support

    What can be reason of this? I have already located Qt bin and include path from Carbide C++ 2.0
    under windows->preferences menu like:

    Bin PATH = C:\Qt\2009.02\qt\bin
    include PATH = C:\Qt\2009.02\qt\include

  2. #2
    Regular Contributor
    Join Date
    May 2009
    Posts
    50

    Re: Qt configuration Problem in Carbide C++ 2.0

    I got also following logs when trying to build qt 4.5.0 with make debug-winscw, is something wrong with the logs?

    bldmake bldfiles
    ABLD.BAT build winscw udeb
    make -r -f "\S60\devices\Nokia_N97_SDK_v0.5\EPOC32\BUILD\qt-4.5.0-garden\EXPO
    RT.make" EXPORT VERBOSE=-s
    make[1]: Entering directory `C:/qt-4.5.0-garden'
    Nothing to do
    make[1]: Leaving directory `C:/qt-4.5.0-garden'
    make -r -f "\S60\devices\Nokia_N97_SDK_v0.5\EPOC32\BUILD\qt-4.5.0-garden\WINS
    CW.make" MAKEFILE VERBOSE=-s
    make[1]: Entering directory `C:/qt-4.5.0-garden'
    make -s -C \qt-4.5.0-garden\src\s60main -f "MAKEFILE_0X2001E61F.MK" TO_ROOT=..\
    ..\.. EPOCBLD=\S60\devices\Nokia_N97_SDK_v0.5\EPOC32\BUILD\MAKEFILE_0X2001E61F\W
    INSCW TO_BLDINF=..\..\..\qt-4.5.0-garden PLATFORM=WINSCW MAKMAKE
    perl -S makmake.pl -D \qt-4.5.0-garden\src\s60main\S60MAIN_0X2001E61F WINSCW

    make -s -C \qt-4.5.0-garden\src\corelib -f "MAKEFILE_0X2001B2DC.MK" TO_ROOT=..\
    ..\.. EPOCBLD=\S60\devices\Nokia_N97_SDK_v0.5\EPOC32\BUILD\MAKEFILE_0X2001B2DC\W
    INSCW TO_BLDINF=..\..\..\qt-4.5.0-garden PLATFORM=WINSCW MAKMAKE
    concurrent/qfuturewatcher.h:0: Warning: No relevant classes found. No output gen
    erated.
    perl -S makmake.pl -D \qt-4.5.0-garden\src\corelib\CORELIB_0X2001B2DC WINSCW

    WARNING: Frozen .def file \qt-4.5.0-garden\src\bwins\QtCoreu.def not found - pro
    ject not frozen
    In file included from C:\qt-4.5.0-garden\include\tmp\../../src/corelib/global/qn
    amespace.h:25,
    from C:\qt-4.5.0-garden\include\QtCore/qnamespace.h:1,
    from C:\qt-4.5.0-garden\include\tmp\../../src/corelib/kernel/qo
    bjectdefs.h:22,
    from C:\qt-4.5.0-garden\include\QtCore/qobjectdefs.h:1,
    from C:\qt-4.5.0-garden\include\tmp\../../src/corelib/kernel/qo
    bject.h:24,
    from C:\qt-4.5.0-garden\include\QtCore/qobject.h:1,
    from C:\qt-4.5.0-garden\include\tmp\../../src/corelib/plugin/ql
    ibrary.h:22,
    from C:\qt-4.5.0-garden\include\QtCore\qlibrary.h:1,
    from C:\qt-4.5.0-garden\src\corelib\tools\qharfbuzz.cpp:22:
    C:\S60\devices\Nokia_N97_SDK_v0.5\epoc32\include\e32def.h:298: warning: `TRUE' r
    edefined
    C:\qt-4.5.0-garden\src\3rdparty\harfbuzz\src\harfbuzz-global.h:55: warning: this
    is the location of the previous definition
    make -s -C \qt-4.5.0-garden\src\xml -f "MAKEFILE_0X2001B2E0.MK" TO_ROOT=..\..\.
    . EPOCBLD=\S60\devices\Nokia_N97_SDK_v0.5\EPOC32\BUILD\MAKEFILE_0X2001B2E0\WINSC
    W TO_BLDINF=..\..\..\qt-4.5.0-garden PLATFORM=WINSCW MAKMAKE
    perl -S makmake.pl -D \qt-4.5.0-garden\src\xml\XML_0X2001B2E0 WINSCW
    WARNING: Frozen .def file \qt-4.5.0-garden\src\bwins\QtXmlu.def not found - proj
    ect not frozen
    make -s -C \qt-4.5.0-garden\src\gui -f "MAKEFILE_0X2001B2DD.MK" TO_ROOT=..\..\.
    . EPOCBLD=\S60\devices\Nokia_N97_SDK_v0.5\EPOC32\BUILD\MAKEFILE_0X2001B2DD\WINSC
    W TO_BLDINF=..\..\..\qt-4.5.0-garden PLATFORM=WINSCW MAKMAKE
    kernel/qsound.h:0: Warning: No relevant classes found. No output generated.
    kernel/qsound_p.h:0: Warning: No relevant classes found. No output generated.
    widgets/qmenudata.h:0: Warning: No relevant classes found. No output generated.
    dialogs/qabstractprintdialog.h:0: Warning: No relevant classes found. No output
    generated.
    dialogs/qabstractpagesetupdialog.h:0: Warning: No relevant classes found. No out
    put generated.
    dialogs/qpagesetupdialog.h:0: Warning: No relevant classes found. No output gene
    rated.
    dialogs/qprintdialog.h:0: Warning: No relevant classes found. No output generate
    d.
    util/qsystemtrayicon.h:0: Warning: No relevant classes found. No output generate
    d.
    dialogs/qprintpreviewdialog.h:0: Warning: No relevant classes found. No output g
    enerated.
    dialogs/qprintpreviewdialog.cpp:0: Warning: No relevant classes found. No output
    generated.
    widgets/qprintpreviewwidget.h:0: Warning: No relevant classes found. No output g
    enerated.
    widgets/qprintpreviewwidget.cpp:0: Warning: No relevant classes found. No output
    generated.
    perl -S makmake.pl -D \qt-4.5.0-garden\src\gui\GUI_0X2001B2DD WINSCW
    WARNING: Frozen .def file \qt-4.5.0-garden\src\bwins\QtGuiu.def not found - proj
    ect not frozen
    maccess/qnetworkaccessdebugpipebackend_p.h:ake -s -C \qt-4.5.0-garden\src\netwo
    rk -f "MAKEFILE_0X2001B2DE.MK" TO_ROOT=..\..\.. EPOCBLD=\S60\devices\Nokia_N97_S
    DK_v0.5\EPOC32\BUILD\MAKEFILE_0X2001B2DE\WINSCW TO_BLDINF=..\..\..\qt-4.5.0-gard
    en PLATFORM=WINSCW MAKMAKE
    0: Warning: No relevant classes found. No output generated.
    socket/qlocalserver.h:0: Warning: No relevant classes found. No output generated
    .
    socket/qlocalserver_p.h:0: Warning: No relevant classes found. No output generat
    ed.
    socket/qlocalsocket.h:0: Warning: No relevant classes found. No output generated
    .
    perl -S makmake.pl -D \qt-4.5.0-garden\src\network\NETWORK_0X2001B2DE WINSCW

    WARNING: Frozen .def file \qt-4.5.0-garden\src\bwins\QtNetworku.def not found -
    project not frozen

  3. #3
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Qt configuration Problem in Carbide C++ 2.0

    Quote Originally Posted by MuratMetu View Post
    Hello, I am new to Symbian C++ and using CArbide C/C++ 2.0 and Nokia N97 SDK_v0.5. I want to develop simple QT Gui Widget with Carbide C++ 2.0. I have installed both Qt SDK 2009.02 and Qt 4.5.0 garden, when I choose new Project from Carbide C++ and after Gui widget option I get the following error:

    No SDK's were found that contain Qt support

    What can be reason of this? I have already located Qt bin and include path from Carbide C++ 2.0
    under windows->preferences menu like:

    Bin PATH = C:\Qt\2009.02\qt\bin
    include PATH = C:\Qt\2009.02\qt\include
    Only Qt 4.5.0 garden is require for developing Qt application for S60, and if i am not wrong than Qt SDK 2009.02 is not for S60.

    Install Qt 4.5.0 garden properly and set environment variable for them properly.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,562

    Re: Qt configuration Problem in Carbide C++ 2.0


  5. #5
    Regular Contributor
    Join Date
    May 2009
    Posts
    50

    Re: Qt configuration Problem in Carbide C++ 2.0

    Thanks Symbian_Neil and savaj, I solved the problem.

  6. #6
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Qt configuration Problem in Carbide C++ 2.0

    Quote Originally Posted by MuratMetu View Post
    Thanks Symbian_Neil and savaj, I solved the problem.
    It will be helpful to others if you explain how you resolved issue.

  7. #7
    Regular Contributor
    Join Date
    May 2009
    Posts
    50

    Re: Qt configuration Problem in Carbide C++ 2.0

    I have followed the instructions in the following links, the problem is that I didn't set the environment variables correctly..

    Check the installation guide http://library.forum.nokia.com/index...4BCE2866A.html
    http://pepper.troll.no/s60prerelease...stall-s60.html

  8. #8
    Nokia Developer Champion
    Join Date
    Sep 2007
    Location
    Bhavnagar
    Posts
    928

    Re: Qt configuration Problem in Carbide C++ 2.0

    Hi,
    What problem are you facing in setting the envronment variable?
    Jajal Mehul

  9. #9
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Qt configuration Problem in Carbide C++ 2.0

    And which SDK version of Qt you are using? Qt SDK 2009.02?

  10. #10
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,562

    Re: Qt configuration Problem in Carbide C++ 2.0

    Quote Originally Posted by MuratMetu View Post
    I have followed the instructions in the following links, the problem is that I didn't set the environment variables correctly..

    Check the installation guide http://library.forum.nokia.com/index...4BCE2866A.html
    http://pepper.troll.no/s60prerelease...stall-s60.html
    Also when you tell somebody to check some link, please make sure that you copy location and not just the shortened link test from some post!!

  11. #11
    Regular Contributor
    Join Date
    May 2009
    Posts
    50

    Re: Qt configuration Problem in Carbide C++ 2.0

    I get this error when installing qt-4.5.0 garden, the path variable is pointing towards Qt SDK 2009.02 installation directory when I got this error.

  12. #12
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Qt configuration Problem in Carbide C++ 2.0

    As i said in post #3, use Qt 4.5.0 garden not Qt SDK 2009.02.

  13. #13
    Registered User
    Join Date
    Feb 2010
    Posts
    17

    Re: Qt configuration Problem in Carbide C++ 2.0

    hello
    i am very new to qt everytime i am making a creating a QT PROJECT FOR CARBIDE.C++ I AM GETTING AN ERROR NO SDK WERE FOUND THAT CONATIN QT SUPPORT
    I HAVE INSTALLED QT-SDK-WIN-OPENSOURCE-2010.01 ,KINDLY HELP ME AND TELL ME WHETER I HAVE TO INSTALL 4.5 GARDEN VERSION TO MAKE MY APPLICATION RUN
    IHAVE NOKIA N-97 SDK AND JRE VERSION 1.6.0_18 and ACTIVVE PERL v5.10.0 version

    thanks & regards
    pushpankar

  14. #14
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Qt configuration Problem in Carbide C++ 2.0

    Up, you have a broken keyboard it seems

    You have the wrong Qt SDK installed. The WIN in QT-SDK-WIN-OPENSOURCE-2010.01 stands for Windows, and therefore Carbide.c++ is right in telling you that you don't have any Qt enabled SDK for Symbian.

    Have a S60 SDK installed (the one compatible with your phone) then download and install Qt for Symbian v4.6.2. When asked, select your Symbian SDK and install Qt on top of it. Then continue the installation instructions, configuring Carbide.c++ for Qt builds.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  15. #15
    Registered User
    Join Date
    Feb 2010
    Posts
    17

    Re: Qt configuration Problem in Carbide C++ 2.0

    thank you sir, i have installed the QT version 4.6.0 and now i got rid of the error ("no sdk were found that contain QT support"),but now i am gettting some other when i am building my project ,it is showing many error like:

    1. the file stddef.h cannot be opened
    2. (include from
    3. D:Qt\4.6\include\QtCore\qglobal.h:1
    and many similar types of error are coming ,kindly suggest me what should i do .

    Thanks & regards
    pushpankar

Similar Threads

  1. Carbide C++ 2.0: crippled build and design scripts
    By elviin in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 4
    Last Post: 2009-04-15, 12:19
  2. Build problem on ARMV5 and GCCE with Carbide c++ 2.0 (S60 3rd Edition FP1)
    By pinkhardlionel in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 10
    Last Post: 2009-01-14, 09:02
  3. Q&A posted from Carbide webinar
    By Mike Trujillo in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2009-01-12, 23:01
  4. Problem with Carbide Express in Win Vista
    By kartee_g in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 16
    Last Post: 2008-11-06, 09:50
  5. Issues with Carbide vs 2.0 installer!
    By kt10208 in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2006-01-16, 09:27

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×