×

Discussion Board

Results 1 to 9 of 9
  1. #1
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    80

    Unhappy Nokia S60 emulator timeout - no debug possible

    Hi,

    I was debugging my application, and it worked fine for an hour when I started to experience grave problems. The notorious timeouts started and degraded it, and now I can't get any debugging session running at all.
    I use the standard out-of-the-box Nokia S60 5th Edition SDK V1.0 emulator.

    PROBLEM:
    - timeout of debug session.
    - emulator seem to play a role here
    - I need to know if it's a setting problem/version compatibility problem or else how to fix this

    CAUSE:
    - I need a solution, project time flies.

    HAVE TRIED THIS:
    - Restart of NetBeans doesn't help.
    - I have tested turning FW OFF - no help there
    - I have tried to let the emulator stay running and try to abort session through SDK Progress windows Abort command. However in the next run the Emulator will complain about two midlet and wo'nt work...

    Typical Output:
    .
    .
    Starting emulator in debug server mode on port 1925
    []
    nbdebug:
    KdpDebugTask connecting to debugger 1 ..
    KdpDebugTask connecting to debugger 2 ..
    KdpDebugTask connecting to debugger 3 ..
    KdpDebugTask connecting to debugger 4 ..
    KdpDebugTask connecting to debugger 5 ..
    Connecting JPDA Debugger to emulator timed out after 5 attempts and 31 seconds.

    ENVIRONMENT
    My IDE and other SW is plain vanilla right from this Forums recommendations, as I understood them:
    - NetBeans IDE 5.1
    - Nokia S60 SDK 5th Edition SDK V1.0
    - Java JDK 1.6 (Default)

    - PC: Windows XP Pro SP3, 3 GB RAM

    (I need check this problem in the debugger, can't test it on my mobile.)

    I've spent the last two days searching for a solution to this.
    I've tried every tip I found there and elsewhere. Please help!


    /Per

  2. #2
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    Re: Nokia S60 emulator timeout - no debug possible

    you did add the Java JDK 1.6 to some configuration file within the SDK right ? I cant remember where that was located nor what the file is called but I do remember that out of the box the 1.6 version (Java 6) isnt supported and should be added manually...
    after that have u tried removing the S60 emulator platform from the supported platforms in NetBeans, restart NetBeans and add that platform again ?

  3. #3
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    80

    Re: Nokia S60 emulator timeout - no debug possible

    Thanks for the tip's, however the problem still persist.

    The slow start of the emulator triggers repeaded messages like this below.
    .
    .
    Attaching to localhost:2345
    Connection refused.

    When I let the emulator remains open, I get a warning in the emulator window when launcing the new debug session that says I cannot have two MIDlet in the emulator. It then says:
    .
    .
    Installation complete
    Reading Start MIDlet
    Starting MIDlet request
    Please wait...
    .
    -> and there it hangs forever.
    What to do??

    Thanks in advance.
    /Per

  4. #4
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    Re: Nokia S60 emulator timeout - no debug possible

    hhmm.. how does it work whislt using the WTK emulator instead of the Nokia's one ?

  5. #5
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    80

    Re: Nokia S60 emulator timeout - no debug possible

    hmmm, I cannot find any good info on how to activate and use it in a safe way.. sorry.
    coud you please give a hint. can't find it in NetBeans.

    /P

  6. #6
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    Re: Nokia S60 emulator timeout - no debug possible

    Tools->Java Platforms

    Therre you can do Add Platform, then select a Java ME MIDP Platform emulator and then you can point to where your S60 SDK is located...

    Also download and install WTK 2.5.2 and make an emulator platform out of that also...

  7. #7
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    80

    Re: Nokia S60 emulator timeout - no debug possible

    Hi Tiger,

    I'm very greatful that you support me.
    But I cannot make my NetBeans to use the WTK emulator even though I see the different versions in the Jav Platforms Manager.
    When I click on the newest "Sun Java(TM) Wireless Toolkit 2.5.2_01 for CLDC" it shows WTK emulator versions under Devices.
    Also, I can see four different models when clicking on "Tools & Extensions" -> "Open Preferences".

    BUT I cannot find a way to choose these emulator to pop up when I try to Run my project.
    ----
    As for the Nokia S60 emulator:
    IF this is a timeout problem
    THEN clearly one must be able to extend this timer somewhere?
    ELSE can the people who know the Nokia S60 emulator please extend a hand.

    Thank you in advance!
    /Per

  8. #8
    Regular Contributor
    Join Date
    Mar 2009
    Posts
    80

    Wink Re: Nokia S60 emulator timeout - now debug possible again

    I have now fixed the problem.
    Since the upgrade to Sun Java(TM) Wireless Toolkit 2.5.2_01 for CLDC did do the trick,
    I de-installed the whole "S60_5th_Edition_SDK_v1.0" and then re-installed it again and connected it with NetBeans.

    Now it work like a charm.
    Rgds
    Per

  9. #9
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    Re: Nokia S60 emulator timeout - no debug possible

    good to know, setting up a working environment can be a hassle unfortunately

Similar Threads

  1. Python S60 Emulator
    By NAYSAMBO in forum Symbian
    Replies: 25
    Last Post: 2009-04-08, 10:22

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×