×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Nov 2008
    Posts
    42

    Question Why RConnection start without any response ?

    My app have a problem .

    First time login the server , the RConnection starts well ,and gets response in RunL().

    But the second time i login , my app remember the network connection point and login automaticly. But RConnection starts without geting any response either in RunL or RunError.

    Why ?

  2. #2
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,752

    Re: Why RConnection start without any response ?

    That is quite unlikely.
    Because you mention RunError, note that RunError is getting invoked if RunL happens to leave. So it has nothing to do with iStatus.
    So if you do something like this:
    Code:
    RunL()
    {
        if(iStatus==KErrNone)
        {
            ...everything is fine...
        }
    }
    and expect RunError to be invoked if iStatus!=KErrNone, that will not happen.

  3. #3
    Registered User
    Join Date
    Nov 2008
    Posts
    42

    Re: Why RConnection start without any response ?

    but i did in this way:

    RunL()
    {
    RDebug....print logs

    }

    RunError()
    {
    RDebug....print logs

    }

    The first time login successfully , those logs show they are correct.
    The second time , there is no log at all and APP quit unexpectly.

    Is there anyway to show this problem ?

  4. #4
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,169

    Re: Why RConnection start without any response ?

    You should get the panic code for the application crash, apps just don't "quit unexpectly", but usually they crash because of bugs in your coding.

Similar Threads

  1. S40 devices do not handle HTTP HEAD response correctly
    By warwickhunter in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2009-03-06, 08:11
  2. Start exe file after installation
    By sashaslonmailer in forum Symbian Tools & SDKs
    Replies: 4
    Last Post: 2008-05-12, 15:27
  3. Cannot handle SIP response
    By biyikli in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2007-04-20, 12:31
  4. Problem retreiving custom HTTP response header
    By hmeet2 in forum Symbian Networking & Messaging (Closed)
    Replies: 0
    Last Post: 2007-01-03, 09:35
  5. Nokia receives a different http response code then sent
    By jaazz in forum Mobile Java Networking & Messaging & Security
    Replies: 1
    Last Post: 2006-07-27, 13:00

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×