×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Apr 2009
    Posts
    24

    Displaying an HTML File

    hi all
    i'm tyring to display an html file on N85 which has N86 software.
    my problem is this html file has a background and sometimes it appears and sometimes not!!! why is that although when i copied this file on Phone memory and tried to open it many times it works successfully.
    i've 3 scenarios:
    1) openin the html file for the 1st time. it displays the background successfuly. but when i open it again it doesn't.
    2) opening the html file for the 1st time. it doesn't appear the background but if i opened another html it will.
    3) Opening the html files many times any one of them would displays the background (Randomaly)

    i tested these scenarios (Debuging) and it works. but on phone it isn't ?!?

    I'm using carbid. Emulator Debug for FP2.

    thnx
    Last edited by B.A; 2009-06-07 at 12:40. Reason: more details

  2. #2
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Displaying an HTML File

    Do you have any errors? How you trying to display html files?

    Check these links:

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: Displaying an HTML File

    Quote Originally Posted by A.A.M. View Post
    Do you have any errors? How you trying to display html files?

    Check these links:
    B.A's problem is some parts are not refreshed of html are not displayed properly when opened multiple times.

  4. #4
    Nokia Developer Champion
    Join Date
    Jan 2008
    Location
    Moscow, Russia
    Posts
    3,348

    Re: Displaying an HTML File

    But some parts of code (or problem html content examples) were not provided...

  5. #5
    Registered User
    Join Date
    Apr 2009
    Posts
    24

    Re: Displaying an HTML File

    Hi all,

    Actually i'm using N86 8GP (FP2). and i tested my application on 6720 (FP2)and it works well.
    there are no error msgs. it works in all devices exccept this one.

    i'm using BrCtlInterface Class. as follows:
    CreateWindowL();
    SetRect(aRect);
    ActivateL();
    TRect rect(/*Position()*/ TPoint(0,0), Size());
    iCommandBase = TBrCtlDefs::ECommandIdBase;
    iBrCtlInterface = CreateBrowserControlL( this, rect, iBrCtlCapabilities,iCommandBase, NULL, NULL,
    NULL, NULL, NULL);
    _LIT(KUrl, "file:///c:\\BrCtlSampleApp\\sample1.htm");
    iBrCtlInterface->LoadUrlL(KUrl);


    you can see this example in FP2 SDK (S60\devices\S60_3rd_FP2_SDK\S60CppExamples\BrCtlSampleApp)
    i tested this application (the SDK's expl app.) in N86 and it didnt work too.
    but it worked in other devices.

    please help.

    thnx

Similar Threads

  1. Regarding BMCONV
    By sanah007 in forum Symbian
    Replies: 2
    Last Post: 2009-05-26, 12:47
  2. Replies: 0
    Last Post: 2009-05-05, 16:31
  3. Contacts fields order??
    By timatima in forum Symbian
    Replies: 1
    Last Post: 2007-06-08, 13:51

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×