×

Discussion Board

Page 1 of 2 12 LastLast
Results 1 to 15 of 28
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    15

    HelloWorld gui application error

    Hi,
    I am new in Symbian C++.
    When I go to create a simple HelloWorld gui application, then the following error message shows after Build Project click.

    1.Unable to open file for reading! \Symbian\9.2\S60_3rd_FP1\epoc32\winscw\c\system\temp\s4b0.tmp\.._gfx_qgn_menu_HelloWorld.svgb

    2.the file 'HelloWorld.rsg' cannot be opened

    3.HelloWorld.rsg: No such file or directory


    I use Carbide.c++ v2, s60_3rd_fp1, Active Perl 5.6.1.635.
    Interesting thing, when i first install everything and then create a HelloWorld gui Application,it runs successfully but now it doesn't run.

    Anyone can share his experience to solve this.
    Thankx in advance.

    Arefin

  2. #2
    Super Contributor
    Join Date
    Jul 2007
    Location
    Beijing, China
    Posts
    538

    Re: HelloWorld gui application error

    resources error, may be something wrong with HelloWorld.rss

  3. #3
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: HelloWorld gui application error

    You should propably check the console for any compilation errors that might be reported.

  4. #4
    Registered User
    Join Date
    May 2009
    Posts
    15

    Re: HelloWorld gui application error

    Quote Originally Posted by naqib View Post
    Hi,
    I am new in Symbian C++.
    When I go to create a simple HelloWorld gui application, then the following error message shows after Build Project click.

    1.Unable to open file for reading! \Symbian\9.2\S60_3rd_FP1\epoc32\winscw\c\system\temp\s4b0.tmp\.._gfx_qgn_menu_HelloWorld.svgb

    2.the file 'HelloWorld.rsg' cannot be opened

    3.HelloWorld.rsg: No such file or directory


    I use Carbide.c++ v2, s60_3rd_fp1, Active Perl 5.6.1.635.
    Interesting thing, when i first install everything and then create a HelloWorld gui Application,it runs successfully but now it doesn't run.

    Anyone can share his experience to solve this.
    Thankx in advance.

    Arefin


    Actually I need help to solve the problem. I can't do any symbian program.
    so, Please help..

  5. #5
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,167

    Re: HelloWorld gui application error

    ok, sis you try compiling it with carbide, and seeing whether there is any error's while doing it ?

  6. #6
    Registered User
    Join Date
    May 2009
    Posts
    15

    Re: HelloWorld gui application error

    Quote Originally Posted by symbianyucca View Post
    ok, sis you try compiling it with carbide, and seeing whether there is any error's while doing it ?
    Now only one error shows
    1.Unable to open file for reading! \Symbian\9.2\S60_3rd_FP1\epoc32\winscw\c\system\temp\s3g4.tmp\.._gfx_qgn_menu_HelloWorld.svgb
    Now what can I do?
    Last edited by naqib; 2009-06-09 at 07:22.

  7. #7
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: HelloWorld gui application error

    Quote Originally Posted by naqib View Post
    Now only one error shows
    1.Unable to open file for reading! \Symbian\9.2\S60_3rd_FP1\epoc32\winscw\c\system\temp\s3g4.tmp\.._gfx_qgn_menu_HelloWorld.svgb
    Now what can I do?
    Your are building it for winscw or gcce? paste pkg file.

  8. #8
    Super Contributor
    Join Date
    Mar 2004
    Location
    Singapore
    Posts
    9,968

    Re: HelloWorld gui application error

    make sure you have install all tools and SDKs on C drive.

  9. #9
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,674

    Re: HelloWorld gui application error

    What happens if you edit the "Icons_aif_scalable_dc.mk", and add a /X switch to mifconv?
    Code:
    	mifconv $(ICONTARGETFILENAME) /X \

  10. #10
    Registered User
    Join Date
    May 2009
    Posts
    15

    Re: HelloWorld gui application error

    Quote Originally Posted by Symbian_Neil View Post
    Your are building it for winscw or gcce? paste pkg file.
    I am building it for winscw. but cant understand which pkg paste? sis folder contains HelloWorld.pkg .I am new in Symbian c++.

  11. #11
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: HelloWorld gui application error

    Quote Originally Posted by naqib View Post
    I am building it for winscw. but cant understand which pkg paste? sis folder contains HelloWorld.pkg .I am new in Symbian c++.
    Like wizard suggested, check the Icons_aif_scalable_dc.mk file.

  12. #12
    Registered User
    Join Date
    May 2009
    Posts
    15

    Re: HelloWorld gui application error

    Quote Originally Posted by skumar_rao View Post
    make sure you have install all tools and SDKs on C drive.
    yes, I am sure about that. my installed file are as follows:

    1.C:\Program Files\Nokia\Carbide.c++ v2.0
    2.C:\Perl
    3.C:\Symbian\9.2\S60_3rd_FP1
    4.C:\Symbian\Carbide\workspace\HelloWorld
    5.C:\Nokia

    I could not understand whats the problem?

  13. #13
    Registered User
    Join Date
    May 2009
    Posts
    15

    Re: HelloWorld gui application error

    Quote Originally Posted by wizard_hu_ View Post
    What happens if you edit the "Icons_aif_scalable_dc.mk", and add a /X switch to mifconv?
    Code:
    	mifconv $(ICONTARGETFILENAME) /X \

    Thankx.
    At last, after doing this there is no error while I build project. But when i click Run as -> Run Symbian OS Application, there shows no emulator.

    So, what can i do?

  14. #14
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: HelloWorld gui application error

    Quote Originally Posted by naqib View Post
    Thankx.
    At last, after doing this there is no error while I build project. But when i click Run as -> Run Symbian OS Application, there shows no emulator.

    So, what can i do?
    try launching epoc from command-line.

  15. #15
    Registered User
    Join Date
    May 2009
    Posts
    15

    Re: HelloWorld gui application error

    Quote Originally Posted by Symbian_Neil View Post
    try launching epoc from command-line.
    When i type epoc in CMD then nothing shows.
    My User Environment Variable has EPOCROOT variable whose value is \Symbian\9.2\S60_3rd_FP1\

    Thank you.

Similar Threads

  1. error including vector
    By Lichtens in forum Open C/C++
    Replies: 5
    Last Post: 2009-04-03, 14:19
  2. Parsing file content
    By hendrawan.ashari in forum Symbian
    Replies: 7
    Last Post: 2007-03-09, 10:41
  3. C-code..unable to make sis
    By Symbian_Neil in forum Symbian
    Replies: 9
    Last Post: 2006-12-02, 07:55
  4. My BuilderX (with S60 SDK 2.1.NET MS version) cannot build ARMI UREL
    By danielvidonyi@hotmail.com in forum Symbian Tools & SDKs
    Replies: 1
    Last Post: 2006-05-04, 21:30

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×