×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    5

    User perspective: WRT support S60 FP1 vs FP2

    Hi,

    A recent post on the web said:

    "WRT tools support Nokia handsets - 27 models including all those running Series 60 3rd Edition Feature Pack 2 and above. WRT plug-ins also support select S60 3rd Edition, Feature Pack 1 devices, with a Nokia software updater."

    Q:
    (a) As a user (not a developer) does this imply I have to firmware update my S60 3d FP1 phone before a WRT capable app will run?

    (b) Does this imply that I can freely use any WRT capable app without any firmware updates on my S60 3rd FP2 phone?

    (c) If I run a WRT app on a non supported phone what message do i as a user get to advise me to do a firmware update?

    thanks

  2. #2
    Nokia Developer Moderator
    Join Date
    Mar 2003
    Location
    Lempäälä/Finland
    Posts
    29,166

    Re: User perspective: WRT support S60 FP1 vs FP2

    a : depends on when the device was bought and what firmware version was in it. If the firmware version in the device is not supporting WRT, then a update is required in order to support WRT Widgets.

    b: Yes. Provided that no platform service APIs etc are not used with it. Platform services are supported from 5th edition.

    c: You can not install a WRT widget into a device that does not support it. No advises are given though.

  3. #3
    Registered User
    Join Date
    May 2009
    Posts
    5

    Re: User perspective: WRT support S60 FP1 vs FP2

    Thank you for prompt response.

    By Platform Services in 5th edition i presume you mean hoemscreen widget capabilty?

    Jyri

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: User perspective: WRT support S60 FP1 vs FP2

    No, he means the ability of a WRT widget to access phone features, such as contacts and location through Java Script extension APIs.
    The Home screen and its WRT Widget support is not a platfrom feature on S60 5th Edition, it is a device specific feature on Nokia N97.

    Of course an "user" does not need to know all that Please use an end-user focused site for discussions about Nokia products, you can share there the info collected here as well.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

Similar Threads

  1. Trouble after patching S60 FP2 SDK to support Windows Vista
    By jmatthauser in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2008-12-17, 10:58
  2. Autofocus S60 3rd ed FP1 to FP2
    By Christophe.A in forum Symbian Media (Closed)
    Replies: 9
    Last Post: 2008-09-10, 13:30
  3. Does S60 3rd Edition FP2 support camera?
    By Zhang Jianliang in forum Streaming and Video
    Replies: 5
    Last Post: 2008-07-31, 10:01
  4. What is going on with Vibration on S60?
    By amd_rikus in forum Mobile Java General
    Replies: 3
    Last Post: 2006-06-16, 00:29

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×