×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    May 2009
    Posts
    51

    Question Debugging in emulator - IDE has greyed out variables, functions

    I have just opened a new Symbian GUI application and have written a new function to test the way I want to implement some code that uses TLex.

    When I open the *AppUi.cpp file, the variables and functions are all greyed out as if the IDE can't resolve their source. The code compiles and runs fine (as it is the base template for the GUI app) - I have even removed my own added code to check that. Is there something I can do to refresh the IDE so it recognises the function calls and variables?

    E.g. I want to be able to "hover" over variables and see their declarations etc but atm it is just showing nothing or "Occurence of ''".

    TIA!

  2. #2
    Regular Contributor
    Join Date
    May 2009
    Posts
    51

    Post Re: Debugging in emulator - IDE has greyed out variables, functions

    Oh well I didn't change anything but closing the IDE and opening it solved the problem.

  3. #3
    Super Contributor
    Join Date
    Mar 2004
    Location
    Bangalore,India
    Posts
    2,146

    Re: Debugging in emulator - IDE has greyed out variables, functions

    Even I have seen this issue a few times, even though the .h and other required things are in place, a system function is just greyed out making one believe that they have called a wrong function or possibly passed some wrong arguments to the function.

    You can report it as a bug if you want, you will have to create an account for that I believe:

    https://xdabug001.ext.nokia.com/bugzilla/
    Cheers,
    Mayank

  4. #4
    Regular Contributor
    Join Date
    May 2009
    Posts
    51

    Re: Debugging in emulator - IDE has greyed out variables, functions

    Yes I've seen it a few times now. E.g. TPtr.Append was ok but .AppendNum was greyed out. Might report it sometime (or look to see if someone else has!).

    Cheers

Similar Threads

  1. Issue when trying to generate .sis file
    By rmulam in forum Symbian Tools & SDKs
    Replies: 9
    Last Post: 2009-08-13, 14:10
  2. returning variables from member functions
    By diptanu in forum Symbian
    Replies: 12
    Last Post: 2008-01-28, 16:10

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×