×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    147

    Unhappy N97 Emulator in SDK issue

    Hi All,

    Has anybody noticed that the N97 emulator window in portrait is too big for common laptop resolutions (1280x800). On my laptop only 3/4 of the phone is visible and the rest is off-screen (the window does not provide scroll bars).

    Anyhow, I thought I would mitigate this by creating a new skin that just displays the main phone display and the three buttons with the rest of the default skin removed. It works, but I have run into an issue where if I configure the epoc.ini with my skin config, the configuration switcher stops working in the emulator.

    What I can't figure out is that in default installation there are four skins configured but only two of those are visible in preferences and only two are "switchable"

    Original config:
    Code:
    MegabytesOfFreeMemory 58
    configuration epoc_640x360_touch_qwerty.ini
    configuration epoc_360x640_touch_keypadoff.ini
    configuration epoc_360x640_touch_keypadoff_f.ini
    configuration epoc_640x360_touch_qwerty_f.ini
    LogToDebugger 1
    PlatSecDiagnostics ON
    PlatSecEnforceSysBin ON
    PlatSecProcessIsolation ON
    PlatSecEnforcement OFF
    PlatSecDisabledCaps NONE
    LogToFile 1
    JustInTime none
    _EPOC_DRIVE_D \epoc32\winscw\d
    _EPOC_DRIVE_E
    _EPOC_LocDrv_1
    MultiMediaCardSize=16000
    patchdata_apserv_dll_KApaLoadDataRecognizersOnDemand 1
    etel_KPriorityClientSid 0x100058B3
    SYMBIAN_GRAPHICS_USE_WSERV2 ON
    WindowTitle Nokia N97 SDK v0.5
    after I modified the epoc.ini with config to my skin it looks like this:

    Code:
    MegabytesOfFreeMemory 68
    configuration epoc_small_portrait.ini
    configuration epoc_640x360_touch_qwerty.ini
    LogToDebugger 1
    PlatSecDiagnostics ON
    PlatSecEnforceSysBin ON
    PlatSecProcessIsolation ON
    PlatSecEnforcement OFF
    PlatSecDisabledCaps NONE
    LogToFile 1
    JustInTime none
    _EPOC_DRIVE_D \epoc32\winscw\d
    _EPOC_DRIVE_E
    _EPOC_LocDrv_1
    MultiMediaCardSize=16000
    patchdata_apserv_dll_KApaLoadDataRecognizersOnDemand 1
    etel_KPriorityClientSid 0x100058B3
    SYMBIAN_GRAPHICS_USE_WSERV2 ON
    WindowTitle Nokia N97 SDK v0.5
    My skin is working and both skins are visible in preferences BUT the switcher is not working.

    So the questions are as follows:
    1. Why are only two skins visible even though four are configured in original config?
    2. Why does the switcher stop working when specifying custom config?

    Hope somebody can shed some light on this issue as the alternative is to change the default skin and restart the emulator whenever the need arises to switch from portrait to landscape.

    Thanks

    Raf

  2. #2
    Nokia Developer Moderator
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: N97 Emulator in SDK issue

    This might not be the best place to ask this. There's a forum for general discussion and one for feedback on tools that you could use since this has nothing to do with Python...
    Last edited by bogdan.galiceanu; 2009-06-17 at 08:57. Reason: Fixed link

  3. #3
    Registered User
    Join Date
    Nov 2008
    Location
    Bangalore
    Posts
    12

    Re: N97 Emulator in SDK issue

    Hi Raf,
    I have re posted your question here: http://discussion.forum.nokia.com/fo...d.php?t=170909 and it is answered by our team member. You may pls continue your discusion in the above thread.
    Regards,
    Bakkiaraj
    Nokia India

  4. #4
    Regular Contributor
    Join Date
    Nov 2007
    Posts
    147

    Re: N97 Emulator in SDK issue

    I have posted a new small skin file for anybody having the same issue:

    http://www.bdcsoftware.com/blog/entr..._Emulator_Skin

    This will allow you to work with the emulator in portrait mode on screens with 1280x800 resolution (it might work on 1024x768 but I haven't tested it).

    Raf

Similar Threads

  1. S60 5th Beta SDK Issue?
    By Nitesh Bhardwaj in forum General Development Questions
    Replies: 5
    Last Post: 2011-01-08, 21:54
  2. S60 5th Ed. SDK v0.9 and Carbide.vs 3.01 Issue
    By Igor Pchelko in forum Tools and SDK Feedback (Closed)
    Replies: 1
    Last Post: 2009-01-06, 19:47
  3. MIDP applicatyion accessing a servlet not working in series 60 emulator
    By ferozekadamapuzha in forum Mobile Java General
    Replies: 11
    Last Post: 2008-05-07, 18:04
  4. Series 60 Concept Emulator (SDK Beta 0.2 Linux) not working
    By mattbee in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2003-06-10, 11:43
  5. Series 60Series 60 MIDP Concept SDK Beta 0.2 Linux bug?
    By kauppi in forum Mobile Java Tools & SDKs
    Replies: 3
    Last Post: 2003-04-07, 09:05

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •