×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    May 2009
    Posts
    3

    Unhappy HttpConnection.close() not working in Nokia5310 XpressMusic

    Hello everybody,

    I have some problems in HttpConnection.close() method in Nokia5310. Whenever I call this method, the [G] symbol on top is not disappearing causing my MIDlet to perform inaccurately. The connection is still there I think thats one causing the problem, when I try to run the MIDlet on other device such as Nokia5000d the connection is closing normally. You can see it because the [G] symbol disappears, and the app is performing well.

    Are there any native methods for nokia devices that forcibly disconnects GPRS connection after the task has been performed?

    Please help me,...

    Thank you!

  2. #2
    Super Contributor
    Join Date
    Apr 2007
    Posts
    2,708

    Re: HttpConnection.close() not working in Nokia5310 XpressMusic

    check this thread :

    http://discussion.forum.nokia.com/fo...d.php?t=171030

    It's of today, so if you'd have looked around in the Forum you might have saved yourself the creation of your own Thread...

  3. #3
    Super Contributor
    Join Date
    Mar 2008
    Location
    The Capital of INDIA
    Posts
    4,328

    Re: HttpConnection.close() not working in Nokia5310 XpressMusic

    Hi
    The connection is still there I think thats one causing the problem,
    What issues you are facing either?
    Thanks with Regards,

    R a j - The K e r n e l


    Join Delhi-NCR Nokia Developer's Community,

  4. #4
    Registered User
    Join Date
    May 2009
    Posts
    3

    Red face Re: HttpConnection.close() not working in Nokia5310 XpressMusic

    The problem I am facing with this opened connection is that, when I try to reconnect again to a URL it sends the request twice. When I track the server log URL requests, my client is sending this request two times in one Connector.open(URL) when the connection is still open causing it to have an error. This happens to a certain device only like 5310's. The GPRS connection should be closed after a certain request has been fulfilled. And the worst thing is I can't do anything to the server.

    My app is working on other devices like N5000d, n76, etc. So I can assume that the error is not from the app, its from the phone itself. I also tried to update the firmware of this device and nothing happened. I also bought a new one but no effect, the problem is still there. Are these errors have something to do with cache, cookies or something? Any idea? Please help me,...

Similar Threads

  1. CAknMessageQueryDialog not working on the Target E61
    By symbians60 in forum Symbian User Interface
    Replies: 4
    Last Post: 2008-04-23, 20:15
  2. Working on GSM, Not working on CDMA
    By aminuddin09 in forum Mobile Java Networking & Messaging & Security
    Replies: 0
    Last Post: 2007-03-21, 07:07
  3. Program suddenly not working - doesn't recognise hardware
    By luciadoll in forum Bluetooth Technology
    Replies: 0
    Last Post: 2006-12-10, 01:54
  4. 7650 / BlueUSB Bluetooth USB dongle / PC-suite not working!
    By mahaikol in forum Bluetooth Technology
    Replies: 7
    Last Post: 2002-12-28, 06:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×