×

Discussion Board

Results 1 to 4 of 4
  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    18

    supports for s60 5th

    hi,

    i think since 1.9.2 or 1.9.3 it already supports s60 5th. What I don't understand is how is it possible if the SDK provided supports only s60 3rd f2?

    I am kind of confuse of the library or api support against the support provided by the SDK?

    is there a way now for *.py to compile into *.sis?

    thanks,

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: supports for s60 5th

    Quote Originally Posted by james_027 View Post
    i think since 1.9.2 or 1.9.3 it already supports s60 5th. What I don't understand is how is it possible if the SDK provided supports only s60 3rd f2?
    Applications developed for 3rd Edition work on 5th Edition too, assuming 5th Edition still has the same APIs as 3rd, which it usually does. Anyway, you can use the 3rd Ed FP2 SDK, it seems to work fine on the 5th Edition emulator.

    Quote Originally Posted by james_027 View Post
    I am kind of confuse of the library or api support against the support provided by the SDK?
    What do you mean?

    Quote Originally Posted by james_027 View Post
    is there a way now for *.py to compile into *.sis?
    Yes, using the PyS60 Application Packager (after you install PythonForS60_1.9.5_Setup.exe you can find it in Start->All Programs->PythonForS60 1.9.5->PyS60 Application Packager).

  3. #3
    Registered User
    Join Date
    Jun 2009
    Posts
    18

    Re: supports for s60 5th

    Quote Originally Posted by bogdan.galiceanu View Post
    What do you mean?
    what I mean is if the version of pys60 has support for s60 5th, how can it run if the sdk doesn't support yet? I am kinda puzzle

    thanks,

  4. #4
    Super Contributor
    Join Date
    Mar 2003
    Location
    Espoo, Finland
    Posts
    976

    Re: supports for s60 5th

    Quote Originally Posted by james_027 View Post
    what I mean is if the version of pys60 has support for s60 5th, how can it run if the sdk doesn't support yet? I am kinda puzzle
    This is something called "backwards compatibility", which means that S60 5th SDK supports same APIs as S60 3rd FP2 SDK supported. Otherwise you would have to recompile, repackage and re-release each and every application for future phones. This would make many users and developers so annoyed that they might ask for a more stable platform. Fortunately all S60 platforms have been backwards compatible ever since S60 3.0 release.

    S60 5th SDK can have additional APIs, which are not available in S60 3rd FP2 SDK. For example Touch UI support. If you develop application using 5th SDK, but want to run it on 3rd FP2 device, you have to be very careful to use only APIs which are available in the earlier platform.

    Cheers,

    --jouni

Similar Threads

  1. Icons in s60
    By drizzt6 in forum Mobile Java General
    Replies: 5
    Last Post: 2009-03-06, 09:32
  2. Audio Routing API for S60 5th
    By heuven in forum Symbian User Interface
    Replies: 6
    Last Post: 2009-02-14, 23:39
  3. Who to start UI development in Series 60 5th edition??
    By rohanwaugh in forum Symbian User Interface
    Replies: 3
    Last Post: 2008-11-03, 06:14
  4. Replies: 3
    Last Post: 2008-10-03, 13:03
  5. Since 3650 supports WMA, and it supports Push Registry as well ?
    By akokchai in forum Mobile Java General
    Replies: 0
    Last Post: 2003-04-23, 07:49

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×