×

Discussion Board

Results 1 to 14 of 14
  1. #1
    Registered User
    Join Date
    Mar 2009
    Posts
    20

    Carbide + Symbian help

    Hello people. I am getting started with Carbide.c++ (v2.0) and Symbian programming. Could I please get a good tutorial on how to create an application, build it, and get it onto my phone ( Nokia E51 ). I also get a "BLDMAKE ERROR: Platform ARMV5 not supported by "\Symbian\Carbide\workspace\helloworld\group\BLD.INF"" error when I try to build the application with the "Phone release (ARMV5) [S60_3rd_FP1]" option.

    Your help is appreciated

  2. #2
    Super Contributor
    Join Date
    Jul 2007
    Location
    Beijing, China
    Posts
    538

    Re: Carbide + Symbian help

    try to build GCCE release not ARMV5

  3. #3
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: Carbide + Symbian help

    The compiler RVCT/ARMV5 is not distributed free with SDK, if you want to use it then you have to purchase it. Anyway you can use GCCE compiler using Phone release (GCCE) [S60_3rd_FP1] options, it is distributed free with SDK.

  4. #4
    Nokia Developer Moderator
    Join Date
    Oct 2006
    Location
    Finland
    Posts
    4,533

    Re: Carbide + Symbian help

    And if you have a RVCT compiler, then to use it you will have to add that as supported platform in the bld.inf

  5. #5
    Registered User
    Join Date
    Mar 2009
    Posts
    20

    Unhappy Re: Carbide + Symbian help

    Ok i came to the conclusion myself, that i did not have the ARMV5 tool. Now, i am having some other problems.

    What is the difference between S60_3rd_FP1 and S60_3rd_FP1_2? ( is it a more up-tp-date SDK? )

    Why is my Emulator blank ( and then closes after a while ) when i try to debug a program?

    Why does the Emulator never show when i try to run a program?

    I have put a registration number into the emulator, and am able to start it from the start menu. I have also tried the _EPOC_DRIVE_D fix, and it has not worked. Somebody Please help me.

  6. #6
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Carbide + Symbian help

    If you install the same SDK several times it will add a counter to the installation directory making it S60_3rd_FP1_[N].

    Read this, it will help you to understand the emulator problem: http://wiki.forum.nokia.com/index.ph...arbide.c%2B%2B
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  7. #7
    Registered User
    Join Date
    Mar 2009
    Posts
    20

    Re: Carbide + Symbian help

    where do i get those settings, since i missed the inital dialog?

  8. #8
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Carbide + Symbian help

    You can open the configuration settings from the Run menu:


    then in the configuration dialog change replace <application>.exe with epoc.exe if you want your emulator to be the process started.

    Attached Images Attached Images
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  9. #9
    Registered User
    Join Date
    Mar 2009
    Posts
    20

    Re: Carbide + Symbian help

    Sorry to have been neglecting my thread, been a bit busy on other projects. I have changed the run configuration as Itomuta said. The emulator comes up now in both run and debug modes. However my app does not show. I go into the Installations folder, and it is not there. What am I supposed to do?

    Also, I have built the same helloworld app as a self-signed sis file. I have gotten it to install on my phone, but it does not show in the Installations folder. What am I supposed to do to make it visible.

    Thanx for all your help.

  10. #10
    Registered User
    Join Date
    May 2007
    Location
    USA
    Posts
    120

    Re: Carbide + Symbian help

    ismithx,
    I'm surprised you're not able to run the helloworld app in the emulator. Were you able to get rid of the build errors?

    Is this the helloworld app that ships with the SDK? If so you should be able to see an icon in the applications folder which you can double-click and run. Which SDK are you using?
    --Himanshu
    Nokia N8-00 (Symbian Belle, NAM RM-596)
    Nokia 5800 XpressMusic (S60 5th Ed., NAM RM-428, v51.2.007)
    S/w: ADT v1.4 + S60 5.0 SDK on Win7 x64

  11. #11
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Carbide + Symbian help

    Have you built a GUI app or a console based (OpenC) project? The later does not have an icon in the menu and thus cannot be started.

    I suggest that you start with a GUI project and start leaning about the files it generates and how the application integrates itself in phone's shell. Then, if you need more advanced use cases (e.g .daemons) or you need to port existing code from other platforms then you should have a look at non-GUI apps as well.
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  12. #12
    Registered User
    Join Date
    Mar 2009
    Posts
    20

    Re: Carbide + Symbian help

    I used a basic console application (EXE). Also, the examples included with carbide do not seem to want to compile ( they usually have a problem with a *.hrh.hlp and a KGeneral_Information being undeclared ).

  13. #13
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,359

    Re: Carbide + Symbian help

    Yes, the problem with building the help file should be fixed by now, you just have to update Carbide.c++ to version 2.0.2.025. Also, if you search or KGeneral_Information in this forum you will find indications about how to solve the problem yourself. If not, post here the console output and we will help you.

    Start a new GUI project and build it then let's see where it goes from there. Btw, have to read yesterday's useful article from my signature?
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  14. #14
    Registered User
    Join Date
    Mar 2009
    Posts
    20

    Re: Carbide + Symbian help

    Yes! it worked! Upgrading carbide did indeed fix the problem. The sis file installs on my phone, also, it runs in the emulator. Thanks to everybody who helped!

Similar Threads

  1. Replies: 2
    Last Post: 2009-01-22, 10:52
  2. Q&A posted from Carbide webinar
    By Mike Trujillo in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 0
    Last Post: 2009-01-12, 23:01
  3. Symbian MMF with RTP
    By swatiSymbi in forum Symbian Media (Closed)
    Replies: 11
    Last Post: 2008-02-18, 12:25
  4. fopen gives error in symbian os c/c++ using carbide c++.
    By nokia_maniac in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2007-12-25, 19:05
  5. carbide symbian S60 v3.0 setup
    By mikewilson in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 6
    Last Post: 2006-06-24, 20:50

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×