×

Discussion Board

Results 1 to 1 of 1
  1. #1
    Regular Contributor
    Join Date
    Apr 2009
    Posts
    442

    KErrCouldNotConnect -34 Failed to connect

    Hi

    I am working on Video Example for play Video file from RTSP server.
    and not able play video on real device E71, getting error in following code.

    I am using S60 3rd edition FP1.

    TRAPD(unsupported, iPlayer->OpenUrlL(_L("rtsp://stream.zoovision.com/musicvideos/well_make_a_lover_of_you.3gp"),KUseDefaultIap, KNullDesC8));

    Am I missing anything? Do I need to connect to the internet explicitly or my application will connect to the internet using the IAPid I gave in the OpenUrlL()?

    Code
    TRAPD(unsupported, iPlayer->OpenUrlL(_L("rtsp://stream.zoovision.com/musicvideos/well_make_a_lover_of_you.3gp"),KUseDefaultIap, KNullDesC8));

    Include Capabilities in .MMP file:
    NetworkServices
    ReadUserData
    UserEnvironment
    WriteUserData


    Code:
    Code:
    void CVideoPlayerAdapter::MvpuoPrepareComplete(TInt aError)
        {
        CFileLogger::WriteLogL(_L("MvpuoPrepareComplete"));
        iFileDetails->iDurationInSeconds = 0;
    
        TBuf<100> log;
        log.Copy(_L("GetError: "));
        log.AppendNum(aError);
        CFileLogger::WriteLogL(log); //Here print in log is GetError:-34
        
    	if(aError == KErrNone || aError == KErrMMPartialPlayback)
    		{
            TSize size( 0, 0 );
            TRAPD(ignored,
            	iPlayer->VideoFrameSizeL(size);
            	iFileDetails->iResolutionHeight = size.iHeight;
            	iFileDetails->iResolutionWidth = size.iWidth;
    
    			// Check if audio
            	iFileDetails->iAudioTrack = iPlayer->AudioEnabledL();
    
            	// Video track
            	iFileDetails->iVideoTrack = iPlayer->VideoBitRateL();
    
            	// Duration of the video clip
            	iFileDetails->iDurationInSeconds = 
                    iPlayer->DurationL().Int64() / KMPOneSecond;
            	
            	_LIT(KMPCopyright,"Copyright");
            	_LIT(KMPTitle,"Title");
            	TInt metaCount = iPlayer->NumberOfMetaDataEntriesL();
            	CMMFMetaDataEntry* metaData;
            	for (TInt i = 0; i < metaCount; i++)
            	    {
            	      metaData = iPlayer->MetaDataEntryL(i);
            	      if (!metaData->Name().CompareF(KMPCopyright))
            	        	{
            	        	iFileDetails->iCopyright = metaData->Value().AllocL();
            	            }
            	      if (!metaData->Name().CompareF(KMPTitle))
            	        	 {
            	        	 iFileDetails->iTitle = metaData->Value().AllocL();
            	        	 } 
            	       CFileLogger::WriteLogL(metaData->Name());
            	       CFileLogger::WriteLogL(metaData->Value());
            	       CFileLogger::WriteLogL(KNullDesC);
            	       delete metaData;
            	     }
            	);
            
            log.Copy(_L("TRAPDError: "));
            log.AppendNum(ignored);
            CFileLogger::WriteLogL(log);
    		}
    
        if ( iCtrlrListener )
            {
            TRAPD(ignored,iCtrlrListener->InitControllerCompletedL(aError));
            }
        }
    Where is the problem? any idea? please tell me where is i am going on wrong?.

    I also post same thread in http://discussion.forum.nokia.com/fo...d.php?t=171410.

    symbianyucca gave me replay also like: "could be really anything, for example a firewall that prevents the connection.." Thanks Again to symbianyucca.

    I think that it's a network related problem so i post this thread over here.

    Please help me.

    Regards,
    SymbianTH
    Last edited by SymbianTH; 2009-06-23 at 09:51.

Similar Threads

  1. flogger connect failed
    By emillaud in forum Symbian Networking & Messaging (Closed)
    Replies: 1
    Last Post: 2008-03-28, 16:27
  2. Replies: 0
    Last Post: 2007-07-19, 12:37
  3. Help Required to connect to Phones without using Nokia Phone Suit
    By sumit_vij11 in forum PC Suite API and PC Connectivity SDK
    Replies: 2
    Last Post: 2006-03-23, 21:25
  4. Nokia Image Converter
    By davidpurdie in forum General Development Questions
    Replies: 0
    Last Post: 2004-02-18, 15:31
  5. Connect failed
    By patbys in forum Bluetooth Technology
    Replies: 3
    Last Post: 2003-05-06, 11:47

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×