×

Discussion Board

Results 1 to 12 of 12
  1. #1
    Registered User
    Join Date
    Dec 2008
    Posts
    81

    the problem about CParser

    There is a error(Error :-993)when I start parser the XML file's <body> by the CParser.

  2. #2
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: the problem about CParser

    Mismatch in XML tag cause Error -993. check more error code here.
    http://www.newlc.com/Symbian-OS-Error-Codes.html

  3. #3
    Registered User
    Join Date
    Dec 2008
    Posts
    81

    Re: the problem about CParser

    thank you for your replay, but i want to know why happen it.

  4. #4
    Super Contributor
    Join Date
    Jun 2006
    Location
    India
    Posts
    3,037

    Re: the problem about CParser

    Hi,

    As the error says "EXmlTagMismatch", So look into the code might be you are missing something.

    if you try some google you will get lots of example
    Use [URL="http://qt.nokia.com/products/qt-quick/"]Qt-Quick[/URL] to make your application UI more attractive.

    [URL="http://store.ovi.com/content/271896"]http://store.ovi.com/content/271896[/URL] | [URL="http://store.ovi.com/content/276199"]http://store.ovi.com/content/276199[/URL] |[URL="http://store.ovi.com/content/276202"] http://store.ovi.com/content/276202[/URL] | [URL="http://store.ovi.com/content/280827"]http://store.ovi.com/content/280827[/URL]

  5. #5
    Registered User
    Join Date
    Dec 2008
    Posts
    81

    Re: the problem about CParser

    yes~ thnak you very but the problem is not resolved
    my xml file like this :
    --------------------------------------------------------------------------------------------------------------------------------------------------
    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/strict.dtd">

    <html lang="en">
    <head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8">
    <meta name="keywords" content="Thomson J. Arthur, ebooks, ebook, books, book, free, online, audio">
    <meta name="description" content="Download the free eBook: The Outline of Science, Vol. 1 (of 4) by J. Arthur Thomson">
    <meta name="classification" content="public">
    <meta http-equiv="Content-Style-Type" content="text/css">

    <link rel="stylesheet" type="text/css" href="/css/pg-002.css"> <link rel="shortcut icon" href="/favicon.ico">
    <title>The Outline of Science, Vol. 1 (of 4) by J. Arthur Thomson - Project Gutenberg</title>
    </head>

    <body class="IEhack">
    <div class="menubar">
    <div id="logo" class="logo">
    <a tabindex="1" href="/wiki/Main_Page"
    title="Go to Main Page"></a>
    ........
    -----------------------------------------------------------------------------------------------------------------------------------------------------
    it is work between the <head> and </head>. But when i parser the <body> tab and the parser fail(Erroe:-993). I don't know why. Does parser <head> work put into the OnStartElementL()?
    There are nothing to do in the OnStartDocumentL(), OnEndDocumentL(), OnEndElementL() in my code.

  6. #6
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: the problem about CParser

    Where is closing body tag </body> ???

  7. #7
    Registered User
    Join Date
    Dec 2008
    Posts
    81

    Re: the problem about CParser

    Quote Originally Posted by savaj View Post
    Where is closing body tag </body> ???
    the file is too long,this is the a part of xml file.

  8. #8
    Super Contributor
    Join Date
    Oct 2007
    Location
    જુનાગઢ - India
    Posts
    3,034

    Re: the problem about CParser

    Then check if any closing tag (including </body>) is missing.

  9. #9
    Registered User
    Join Date
    Dec 2008
    Posts
    81

    Re: the problem about CParser

    I think my file is right.

  10. #10
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: the problem about CParser

    Quote Originally Posted by denniswang View Post
    I think my file is right.
    Everyone does.

    Anyway, it is certainly not a valid XML file, since HTML is not valid XML. Just check the head tag (which you have posted completely), no meta-s have closing tags.

  11. #11
    Registered User
    Join Date
    Dec 2008
    Posts
    81

    Re: the problem about CParser

    Quote Originally Posted by wizard_hu_ View Post
    Everyone does.

    Anyway, it is certainly not a valid XML file, since HTML is not valid XML. Just check the head tag (which you have posted completely), no meta-s have closing tags.
    you mean is CParser can't parser HTML file?
    or need to preliminary parser and then use CParser?

  12. #12
    Nokia Developer Moderator
    Join Date
    Feb 2006
    Location
    Oslo, Norway
    Posts
    28,751

    Re: the problem about CParser

    A generic XML parser does not have to be aware of what it actually parses. While a HTML parser has to be aware of HTML itself.
    You can probably extract the HTML parser from WebKit (http://webkit.org), that is the base of the built-in browser too.

Similar Threads

  1. STLPort namespace issue
    By yickhong in forum Open C/C++
    Replies: 0
    Last Post: 2009-04-09, 08:54
  2. SyncML link problem
    By samuel_ in forum Symbian
    Replies: 4
    Last Post: 2009-03-27, 08:02
  3. Problem with eglSwapBuffers and heap corruption
    By greatape in forum Symbian Media (Closed)
    Replies: 2
    Last Post: 2007-05-24, 03:35
  4. netcards - Problem with opening adapter
    By kernj in forum Symbian Tools & SDKs
    Replies: 5
    Last Post: 2007-01-10, 08:56
  5. Problem: S60 SDK for CW in PC with .NET
    By anttij in forum Carbide.c++ IDE and plug-ins (Closed)
    Replies: 1
    Last Post: 2005-02-28, 11:36

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×