×

Discussion Board

Results 1 to 7 of 7
  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    S60 3rd FP2 SDK v1.1 Installation Problem

    I´ve just installed the S60 3rd FP2 emulator following the S60_3rd_Edition_FP2_SDK_for_Symbian_OS_Installation_Guide_V1.1.pdf instructions.
    First I installed Active Perl 5.10.0 (it needs v5.6.1 or newer), then i checked my JRE version and it is 1.6 update 14 (it needs v1.5,0 or newer) and finally installed the emulator. In the end it asked to install CSL ARM Q1C Toolchain and I installed it.

    The problem is that when I open the emulator there is nothing inside the screen and it automatically close after a few seconds (about 10~15 seconds) without showing an error message or something like that, it just closes automatically. I tried clicking in a few buttons before it closes, but nothing happened. The only things I´m able to do before it closes is changing the screen type to landscape and returning it to portrait and showing/hiding the keypad... :(

    Does anyone have a clue about what might be causing the problem?

    I downloaded everything from the official sites and I already tried re-installing the JRE6.

    http://f.imagehost.org/0216/S60_3rd_FP2_emulator.jpg
    http://f.imagehost.org/0488/S60_3rd_...scape_view.jpg

  2. #2
    Registered User
    Join Date
    May 2007
    Location
    USA
    Posts
    120

    Re: S60 3rd FP2 SDK v1.1 Installation Problem

    Can you confirm that the versin of Perl required is 5.6.1 or newer? In the current S60 5th edition it clearly states that only 5.6.1 should be used, not newer.
    --Himanshu
    Nokia N8-00 (Symbian Belle, NAM RM-596)
    Nokia 5800 XpressMusic (S60 5th Ed., NAM RM-428, v51.2.007)
    S/w: ADT v1.4 + S60 5.0 SDK on Win7 x64

  3. #3
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    Re: S60 3rd FP2 SDK v1.1 Installation Problem

    Well, I read it in the pdf that came inside the .rar file i downloaded at Tools->Platforms->All-in-one SDKs->3rd Edition, FP2 v1.1 (455 MB).

    Here is a picture just to show the part of the pdf that says that.
    But maybe this information is wrong, I´ll try downloading this specific version you said, 5.6.1, and then I´ll post here the results.
    Cya

  4. #4
    Nokia Developer Moderator
    Join Date
    Sep 2004
    Location
    Tampere, Finland
    Posts
    11,355

    Re: S60 3rd FP2 SDK v1.1 Installation Problem

    The document is wrong, the SDK only works with Active Perl 5.6.1 but you can enable support for more recent Active Perl releases by applying KIS001302 - Compiling context-sensitive help fails with latest version of Perl
    -- Lucian

    If you are not yet a DVLUP member it is time to correct that mistake :) Click here to join: http://www.dvlup.com/lucian/Invite

  5. #5
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    Re: S60 3rd FP2 SDK v1.1 Installation Problem

    I made a clean install right now.

    First uninstalled CLS ARM, S60 emulator and then the Perl 5.10.0.

    After a reboot, I installed Perl 5.6.1 build 635 followed by S60 3rd Edition FP2 v1.1 and CLS ARM Toolchain.

    But the problem persists, the emulator opens, with nothing on the display (see the links in the first post), and after a few secs it closes without an error message or anything...

  6. #6
    Nokia Developer Moderator
    Join Date
    Oct 2007
    Location
    Deva, Romania
    Posts
    3,471

    Re: S60 3rd FP2 SDK v1.1 Installation Problem

    Just a guess: maybe your problem is similar to this one?

  7. #7
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    Re: S60 3rd FP2 SDK v1.1 Installation Problem

    It worked, I just right-clicked My Computer, then Manage, Driver Manager and disabled my Realtek High Definition Audio driver.
    After that I was able to run the emulator without problems.

    I´m going to report this incompatibility, but I´m not quite sure where to do that. :P

    Anyway, thank you all for you help.

Similar Threads

  1. Python for S60 1.9.2 released
    By tvijayan in forum Symbian
    Replies: 26
    Last Post: 2009-03-11, 09:28
  2. S60 SDK, 3rd FP2 works well, 5th not.
    By sblantipodi in forum Mobile Java Tools & SDKs
    Replies: 1
    Last Post: 2008-12-28, 20:19
  3. build problem with S60 3rd FP2 SDK
    By dakosurf in forum Symbian
    Replies: 2
    Last Post: 2008-04-03, 17:52
  4. Problem in Installation MWS SDK Plugin for S60 3rd MR
    By pankaj.dubey in forum Tools and SDK Feedback (Closed)
    Replies: 3
    Last Post: 2007-12-07, 06:55
  5. Problem installing S60 3rd Ed. (MR) SDK in Win
    By dcelzinga in forum Symbian Tools & SDKs
    Replies: 2
    Last Post: 2007-10-06, 16:44

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •