×

Discussion Board

Results 1 to 5 of 5
  1. #1
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    Unhappy Packaging problem using pys60 1.9.4

    hi I'm new here.I want to make a package that can be installed directly on any 3rdED S60 phone even if there's no python interpreter.I tried pys60 1.9.4 first of all couldnt install it on my 6120 phone error "certificate not valid yet".But there's an exe application with GUI that makes sis packages.I gave it python files it converts itto sis packages.is that enough to be singned then installed on any 3rd S6 phones?I signed them and tried to install them but i had the following error "Python Runtime and PIPS Library ".what are baby steps to generate that kind of package using 1.9.4 application packager gui?
    thanks in advance

  2. #2
    Super Contributor
    Join Date
    Feb 2008
    Location
    Belo Horizonte, Brazil
    Posts
    744

    Re: Packaging problem using pys60 1.9.4

    Hi,

    Welcome to the Python DiBo

    Well, a basic thing we need to know before going on with this discussion: is your device 3rd Edition FP2? The thread about runtime deployment says it will only work with 3rd Edition FP2 onwards ...



    BR,

    Rafael.

  3. #3
    Registered User
    Join Date
    Jun 2009
    Posts
    4

    Re: Packaging problem using pys60 1.9.4

    Thanks for your reply.
    do u mean 3rd FP2 only or 3rd FP2 and later??
    and how to include all dependencies and runtime in just one input.the input taken by the 1.9.4 gui packager

  4. #4
    Nokia Developer Champion
    Join Date
    Feb 2008
    Location
    Ahmedabad, Gujarat, India
    Posts
    3,852

    Re: Packaging problem using pys60 1.9.4

    Quote Originally Posted by shery_ashraf View Post
    Thanks for your reply.
    do u mean 3rd FP2 only or 3rd FP2 and later??
    and how to include all dependencies and runtime in just one input.the input taken by the 1.9.4 gui packager
    hello shrey_ashraf

    your device is 6120 which is actually a S60 3rd edition FP1 device. So the method given by rafael will not work here i guess.

    Moreover if you want to merge all the dependencies then you can use the Mergesis command but as i have not testes this i am not aware of the command available with GUI packager, so please make a confirmation of that.

    Regards
    Gaba88

  5. #5
    Regular Contributor
    Join Date
    Jul 2007
    Location
    Eindhoven, the Netherlands
    Posts
    187

    Re: Packaging problem using pys60 1.9.4

    Quote Originally Posted by shery_ashraf View Post
    I tried pys60 1.9.4 first of all couldnt install it on my 6120 phone error "certificate not valid yet".
    This is usually the result of the phone time not being in sync (behind) the system time of the symbian pc doing the signing.
    Make sure your phone has the correct time, then try installing the sis again.

Similar Threads

  1. Python 1.9.4 SDK problem
    By raichea in forum Symbian
    Replies: 4
    Last Post: 2009-05-19, 12:43
  2. New to Python for S60 (PyS60)? Read this first!
    By croozeus in forum Nokia N9
    Replies: 2
    Last Post: 2008-10-17, 19:23
  3. PyS60 Talks #2 : PyS60 Extensions
    By croozeus in forum Symbian
    Replies: 14
    Last Post: 2008-09-15, 14:23
  4. packaging problem
    By amaj1407 in forum Symbian
    Replies: 2
    Last Post: 2007-08-03, 10:56
  5. Replies: 1
    Last Post: 2005-05-11, 09:13

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  
×